LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 07-28-2004, 06:10 AM   #1
Shuja
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
upgrade glibc-2.2.4 to glibc-2.3.2 on redhat 7.2


Hi,

I'm trying to upgrade glibc-2.2.4 to glibc-2.3.2 on redhat 7.2

but when I finally compiled gclib, it shows me this error.

dl-runtime.c:57: error: conflicting types for 'fixup'
../sysdeps/i386/dl-machine.h:158: error: previous declaration of 'fixup' was here
dl-runtime.c:57: error: conflicting types for 'fixup'
../sysdeps/i386/dl-machine.h:158: error: previous declaration of 'fixup' was here
dl-runtime.c:137: error: conflicting types for 'profile_fixup'
../sysdeps/i386/dl-machine.h:161: error: previous declaration of 'profile_fixup' was here
dl-runtime.c:137: error: conflicting types for 'profile_fixup'
../sysdeps/i386/dl-machine.h:161: error: previous declaration of 'profile_fixup' was here
../sysdeps/i386/dl-machine.h:158: warning: 'fixup' declared `static' but never defined
../sysdeps/i386/dl-machine.h:161: warning: 'profile_fixup' declared `static' but never defined
make[2]: *** [/mnt/lfs/builds/glibc-build/elf/dl-runtime.os] Error 1
make[2]: Leaving directory `/mnt/lfs/builds/glibc-build/glibc-2.3.3-lfs-5.1/elf'
make[1]: *** [elf/subdir_lib] Error 2
make[1]: Leaving directory `/mnt/lfs/builds/glibc-build/glibc-2.3.3-lfs-5.1'
make: *** [all] Error 2

Anybody come across such a problem and fixed it, kindly share the solution.

Thank You.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
newb question on GNU glibc-2.3.1 upgrade to GNU glibc-2.3.2 clindy528 Slackware 1 11-10-2005 06:49 AM
Replacing glibc using linuxthreads for glibc using nptl (native positx thread library CestusGW Linux From Scratch 4 01-20-2005 07:26 AM
HELP! GLIBC 2.3 Upgrade in redhat 7.2 problem ihealthbuzz Linux - Software 1 10-08-2004 03:34 PM
Upgrading glibc-2.2.4 to glibc-2.3.2 on redhat 7.2 Shuja Linux From Scratch 2 07-30-2004 12:34 AM
wrong upgrade of glibc . Can i go back to the correct version? RedHat 7.3 enrique-t Red Hat 1 03-06-2004 02:52 PM


All times are GMT -5. The time now is 08:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration