LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 09-11-2003, 06:53 PM   #1
IgD
Member
 
Registered: Mar 2002
Location: Parts unknown
Posts: 37

Rep: Reputation: 15
up2date skipping some packages


How can I fix this? (See below) up2date seems to be skipping some important packages during the update process.



[root@www root]# up2date -uv

Fetching package list for channel: redhat-linux-i386-8.0...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-8.0...
########################################

Fetching rpm headers...
The following Packages were marked to be skipped by your configuration:

Name Version Rel Reason
-------------------------------------------------------------------------------
ttfonts-ja 1.2 16 Config modified
No advisory information available

mailcap 2.1.12 1 Config modified
No advisory information available


None of the packages you requested were found, or they are already updated.
 
Old 09-12-2003, 03:49 AM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
So... your system is up to date...
 
Old 09-12-2003, 08:06 AM   #3
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
You have configured your up2date client so that it skips packages which would install a config file with changes (in that case you may need to verify your configuration). Run up2date --configure or up2date-config and change that setting.
 
Old 09-12-2003, 09:07 AM   #4
jhibbets
Red Hat
 
Registered: Sep 2003
Location: Raleigh, NC
Distribution: Red Hat Enterprise Linux v 2.1, v 3, v 4
Posts: 174

Rep: Reputation: 30
skip list?

check items in the skip list, use -f option to override this.

Also, use rpm -q package name to verify the version. If it's the same, then your good.

You may need up2date -p to re-sync your rom db with RHN db.
You may need to clear out /var/spool/up2date of all files.
 
Old 09-12-2003, 12:07 PM   #5
IgD
Member
 
Registered: Mar 2002
Location: Parts unknown
Posts: 37

Original Poster
Rep: Reputation: 15
Thanks jhibbets! I did up2date -uvf as you suggested and it fixed the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4: up2date has unsigned packages??? RottenMutt Fedora 5 07-08-2005 11:28 AM
Up2date packages flagged to be skipped 60s TV Batman Fedora 2 04-04-2005 01:54 AM
yum can not find up2date packages !! m2azer Linux - Newbie 3 01-03-2005 11:54 AM
FC2 test 3 mouse skipping a beat, movie skipping also jang Fedora 1 10-28-2004 07:42 PM
Red Hat Up2date d/l bad packages? Pcghost Linux - General 5 04-01-2003 06:01 PM


All times are GMT -5. The time now is 07:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration