LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 09-12-2003, 09:26 AM   #16
jhibbets
Red Hat
 
Registered: Sep 2003
Location: Raleigh, NC
Distribution: Red Hat Enterprise Linux v 2.1, v 3, v 4
Posts: 174

Original Poster
Rep: Reputation: 30

Test your connectivity with RHN:
telnet xmlrpc.rhn.redhat.com 443

You should get this:
[root@jaws root]# telnet xmlrpc.rhn.redhat.com 443
Trying 66.187.232.101...
Connected to xmlrpc.rhn.redhat.com (66.187.232.101).
Escape character is '^]'.


Are there any other network issues? Proxy server?
 
Old 09-12-2003, 11:21 AM   #17
pcdunx
Newbie
 
Registered: Aug 2003
Location: UK
Distribution: RH9, IPCop, Censornet
Posts: 9

Rep: Reputation: 0
i have just re-installed RH9 Linux (again as a server), mainly cos I needed to put a Doze partition on to have w2k on there as well.

I downloaded the stuff from RHN for up2date and tried the --nodeps, still doesnt work.

Tried the telnet, but get error:-

Temporary failure in name resolution
rhn.redhat.com: Hostname lookup failure

I tried the same telnet command on a Doze pc on the same network/proxy server and it connects ok to RHN.

There must be some little setting I need to change to make it work, any clues please??
 
Old 09-12-2003, 01:04 PM   #18
jhibbets
Red Hat
 
Registered: Sep 2003
Location: Raleigh, NC
Distribution: Red Hat Enterprise Linux v 2.1, v 3, v 4
Posts: 174

Original Poster
Rep: Reputation: 30
Sounds like a DNS issue, check your /etc/resolv.conf file, make sure you can ping your nameservers. Can you resolve other hostnames?

try to ping xmlrpc.redhat.com then try to ping the IP address 66.187.232.101

Examples:

# cat /etc/resolv.conf
; generated by /sbin/dhclient-script
nameserver 10.0.0.254
nameserver 10.0.0.253

# ping xmlrpc.rhn.redhat.com
PING xmlrpc.rhn.redhat.com (66.187.232.101) from 10.0.0.1 : 56(84) bytes of data.
64 bytes from xmlrpc.rhn.redhat.com (66.187.232.101): icmp_seq=1 ttl=126 time=75.5 ms
64 bytes from xmlrpc.rhn.redhat.com (66.187.232.101): icmp_seq=2 ttl=126 time=68.4 ms

--- xmlrpc.rhn.redhat.com ping statistics ---
2 packets transmitted, 2 received, 0% loss, time 1010ms
rtt min/avg/max/mdev = 68.412/71.967/75.523/3.565 ms

# ping 66.187.232.101
PING 66.187.232.101 (66.187.232.101) from 10.0.0.1 : 56(84) bytes of data.
64 bytes from 66.187.232.101: icmp_seq=1 ttl=126 time=82.5 ms
64 bytes from 66.187.232.101: icmp_seq=2 ttl=126 time=82.2 ms
64 bytes from 66.187.232.101: icmp_seq=3 ttl=126 time=75.2 ms

--- 66.187.232.101 ping statistics ---
3 packets transmitted, 3 received, 0% loss, time 2016ms
rtt min/avg/max/mdev = 75.224/79.987/82.505/3.369 ms
 
Old 09-13-2003, 06:15 PM   #19
srstudios
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
To pcdunx, post #17

I just had a similar issue with RHN. In my case, after up2date update, the system profile on the RHN website had entered a second system profile that was no longer the sign-on name I had been using. I deleted the new profile, checked the original system profile, and changed my entitlements from none to demo. All now works as before. Hope this helps.
 
Old 09-15-2003, 03:27 PM   #20
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Quote:
Originally posted by lub0
Hi, I am afraid I am a bit of a newbie myself, all I can say on this subject is I tried everthing to get my up2date to work, I kept getting an error like the one you got. I overcame the it with "rpm -Fvh --nodeps up2date*"
Ignoring package dependencies is an ugly workaround and can be the source of problems in case you've got wrong packages. Normally, you would download both packages, up2date and up2date-gnome, and install both at once:

rpm -Fvh up2date*
or:
rpm -Uvh up2date*

or explicit:
rpm -Uvh up2date-gnome-3.9.26-2.i386.rpm up2date-3.9.26-2.i386.rpm
 
Old 09-15-2003, 09:00 PM   #21
Shadow-X
Newbie
 
Registered: Sep 2003
Location: USA
Distribution: Red Hat / Fedora Core 2 / and Slack soon!
Posts: 5

Rep: Reputation: 0
Cool Ok First post here!!!

I too was having probs and after readin here i tried some things...and im cool with up2date now!!! ...Thanks!!!

Heres what i did!
wget -q -O - https://rhn.redhat.com/help/new-cert.sh | /bin/bash
Testing SSL connectivity against https://xmlrpc.rhn.redhat.com/XMLRPC ...
Connectivity OK, test succeeded

The file /usr/share/rhn/RHNS-CA-CERT has been successfully updated.
Please run 'up2date' to download the latest updates.

OOH and BTW.......26 mins. of updates....on cable!!!

Last edited by Shadow-X; 09-17-2003 at 07:38 PM.
 
Old 09-18-2003, 09:50 AM   #22
chris.hicks
Member
 
Registered: Sep 2003
Location: Newcastle upon Tyne
Distribution: Red Hat 9
Posts: 42

Rep: Reputation: 15
I followed the instructions from:
https://rhn.redhat.com/help/latest-up2date.pxt
md5sum 'filename' worked fine
rpm -Fvh up2date-* worked fine
up2date -p asked me to run up2date --register
up2date --register ran the update agent, but when I clicked 'forward'
the console was filled by rubbish from traceback and the console froze.

Any help would be gratefully received.
Thanks,
Chris
 
Old 09-18-2003, 10:04 AM   #23
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Quote:
Originally posted by chris.hicks
up2date -p asked me to run up2date --register
That doesn't sound right unless you didn't have a RHN account before.
Quote:
up2date --register ran the update agent, but when I clicked 'forward'
the console was filled by rubbish from traceback and the console froze.
What version of Red Hat Linux?

What version of up2date? rpm -qa 'up2date*'

What traceback output? You could run up2date from a terminal program and redirect its output to a file:
up2date &> output.txt
 
Old 09-18-2003, 10:24 AM   #24
chris.hicks
Member
 
Registered: Sep 2003
Location: Newcastle upon Tyne
Distribution: Red Hat 9
Posts: 42

Rep: Reputation: 15
I have a virgin copy of RedHat 9, which I have not been able to register yet.

[root@MMME1 pascal]# rpm -qa 'up2date*'
up2date-3.1.23.2-1
up2date-gnome-3.1.23.2-1

Traceback output:
[root@MMME1 pascal]# up2date --register
Traceback (most recent call last):
File "/usr/share/rhn/up2date_client/gui.py", line 405, in onPrivacyPagePrepare text = rhnreg.privacyText()
File "/usr/share/rhn/up2date_client/rhnreg.py", line 176, in privacyText
return rpcServer.doCall(s.registration.privacy_statement)
File "/usr/share/rhn/up2date_client/rpcServer.py", line 114, in doCall
ret = apply(method, args, kwargs)
File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
return self.__send(self.__name, args)
File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
verbose=self._verbose
File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 112, in request
connection = self.get_connection(host)
File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 239, in get_connection
trusted_certs=self.trusted_certs)
File "/usr/lib/python2.2/site-packages/rhn/connections.py", line 184, in __init__
HTTPProxyConnection.__init__(self, proxy, host, port, username, password)
File "/usr/lib/python2.2/site-packages/rhn/connections.py", line 119, in __init__
HTTPConnection.__init__(self, proxy)
File "/usr/lib/python2.2/site-packages/rhn/connections.py", line 50, in __init__
httplib.HTTPConnection.__init__(self, host, port)
File "/usr/lib/python2.2/httplib.py", line 491, in __init__
self._set_hostport(host, port)
File "/usr/lib/python2.2/httplib.py", line 502, in _set_hostport
raise InvalidURL("nonnumeric port: '%s'" % host[i+1:])
httplib.InvalidURL: nonnumeric port: '8080/'
 
Old 09-18-2003, 10:25 AM   #25
chris.hicks
Member
 
Registered: Sep 2003
Location: Newcastle upon Tyne
Distribution: Red Hat 9
Posts: 42

Rep: Reputation: 15
I forgot to say thanks to Misc!
 
Old 09-18-2003, 11:04 AM   #26
jhibbets
Red Hat
 
Registered: Sep 2003
Location: Raleigh, NC
Distribution: Red Hat Enterprise Linux v 2.1, v 3, v 4
Posts: 174

Original Poster
Rep: Reputation: 30
Try to remove your system profile from RHN website, then re-register the system. If you re-register and get errors, remove the RPM's and re-install them. Check your md5 sum, check the package names. Clear out /var/spool/up2date, clear out /etc/sysconfig/rhn/

good luck

If that doesn't work, grab your original rpm's from your CD's and use the wget stuff posted here.
 
Old 09-18-2003, 11:32 AM   #27
chris.hicks
Member
 
Registered: Sep 2003
Location: Newcastle upon Tyne
Distribution: Red Hat 9
Posts: 42

Rep: Reputation: 15
Thanks for your reply.

I'm a newbie and would be grateful if you would let me know how to remove and reinstall the RPMs.

Thanks,
Chris
 
Old 09-18-2003, 12:36 PM   #28
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Don't reinstall up2date. It doesn't look like it's necessary. It looks more like you made a configuration mistake when you configured a proxy server. Check your up2date configuration: up2date --configure

Or post the /etc/sysconfig/rhn/up2date file. I'm sure at least the httpProxy= line is wrong.
 
Old 09-19-2003, 10:42 AM   #29
chris.hicks
Member
 
Registered: Sep 2003
Location: Newcastle upon Tyne
Distribution: Red Hat 9
Posts: 42

Rep: Reputation: 15
I have reloaded my RedHat 9 from scratch.

The md5sums are fine:
md5sum *
3faabcb9cc610627fe378b88d0b2b928 up2date-3.1.23.2-1.i386.rpm
733d0aca17c15af0b1fa709ba86337dc up2date-gnome-3.1.23.2-1.i386.rpm

The rpm -Fvh up2date-* was fine:
rpm -Fvh up2date-*
Preparing... ########################################### [100%]
1:up2date ########################################### [ 50%]
2:up2date-gnome ########################################### [100%]

However, up2date --register now gives:
Fatal error retrieving privacy statement: name or service not known

up2date --configure looks OK
RedHat server: https://xmlrpc.rhn.redhat.com/XMLRPC
The proxy is correct too.

Any ideas or help would be gratefully received.

Many thanks,
Chris
 
Old 09-19-2003, 10:46 AM   #30
chris.hicks
Member
 
Registered: Sep 2003
Location: Newcastle upon Tyne
Distribution: Red Hat 9
Posts: 42

Rep: Reputation: 15
Here is the contents of my /etc/sysconfig/rhn/up2date file:

[root@MMME1 rhn]# cat up2date
# Automatically generated Red Hat Update Agent config file, do not edit.
# Format: 1.0
networkSetup[comment]=None
networkSetup=1

retrieveOnly[comment]=Retrieve packages only
retrieveOnly=0

enableRollbacks[comment]=Determine if up2date should create rollback rpms
enableRollbacks=0

pkgSkipList[comment]=A list of package names, optionally including wildcards, to skip
pkgSkipList=kernel*;

storageDir[comment]=Where to store packages and other data when they are retrieved
storageDir=/var/spool/up2date

adminAddress[comment]=List of e-mail addresses for update agent to communicate with when run in batch mode
adminAddress=root@localhost;

noBootLoader[comment]=To disable modification of the boot loader (lilo, silo, etc)
noBootLoader=0

serverURL[comment]=Remote server URL
serverURL=https://xmlrpc.rhn.redhat.com/XMLRPC

fileSkipList[comment]=A list of file names, optionally including wildcards, to skip
fileSkipList=;

sslCACert[comment]=The CA cert used to verify the ssl server
sslCACert=/usr/share/rhn/RHNS-CA-CERT

noReplaceConfig[comment]=When selected, no packages that would change configuration data are automatically installed
noReplaceConfig=1

noReboots[comment]=Disable the reboot actions
noReboots=None

useNoSSLForPackages[comment]=Use the noSSLServerURL for package, package list, and header fetching
useNoSSLForPackages=0

systemIdPath[comment]=Location of system id
systemIdPath=/etc/sysconfig/rhn/systemid

enableProxyAuth[comment]=To use an authenticated proxy or not
enableProxyAuth=0

retrieveSource[comment]=Retrieve source RPM along with binary package
retrieveSource=1

versionOverride[comment]=Override the automatically determined system version
versionOverride=

headerFetchCount[comment]=The maximimum number of rpm headers to fetch at once
headerFetchCount=10

networkRetries[comment]=Number of attempts to make at network connections before giving up
networkRetries=5

enableProxy[comment]=Use a HTTP Proxy
enableProxy=1

proxyPassword[comment]=The password to use for an authenticated proxy
proxyPassword=

noSSLServerURL[comment]=Remote server URL without SSL
noSSLServerURL=http://xmlrpc.rhn.redhat.com/XMLRPC

keepAfterInstall[comment]=Keep packages on disk after installation
keepAfterInstall=1

proxyUser[comment]=The username for an authenticated proxy
proxyUser=

removeSkipList[comment]=A list of package names, optionally including wildcards
that up2date will not remove
removeSkipList=kernel*;

useGPG[comment]=Use GPG to verify package integrity
useGPG=1

gpgKeyRing[comment]=The location of the gpg keyring to use for package checking
gpgKeyRing=/etc/sysconfig/rhn/up2date-keyring.gpg

debug[comment]=Whether or not debugging is enabled
debug=0

httpProxy[comment]=HTTP proxy in hostort format, e.g. squid.redhat.com:3128
httpProxy=http://www.ncl.ac.uk/default.pac

headerCacheSize[comment]=The maximum number of rpm headers to cache in ram
headerCacheSize=40

forceInstall[comment]=Force package installation, ignoring package, file and config file skip list
forceInstall=0

noReboot[comment]=Disable the reboot action
noReboot=0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with up2date... monkiidansu Fedora 12 09-26-2005 11:37 AM
Problems with up2date mohd281 Linux - Newbie 13 08-17-2005 04:13 AM
Up2date problems dreyes81 Linux - Newbie 2 07-10-2005 03:22 PM
up2date problems... chiefreborn Linux - Software 3 06-14-2005 03:57 AM
up2date problems Arc4ne Linux - Security 5 08-27-2004 10:28 PM


All times are GMT -5. The time now is 07:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration