LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Unresponsive Keyboard and Mouse after boot (RHEL6) (http://www.linuxquestions.org/questions/red-hat-31/unresponsive-keyboard-and-mouse-after-boot-rhel6-4175472540/)

hdbngr 08-07-2013 04:50 PM

Unresponsive Keyboard and Mouse after boot (RHEL6)
 
Had to physically move a PC to a new location within same office.
RHEL 6
Properly/cleanly shut down PC. Removed cables including USB keyboard and USB mouse.
Plugged cables back in including same keyboard and mouse. Powered on. Keyboard not working at grub menu initially. Desktop login screen - no keyboard (still) AND no mouse.

Moved USB connections to physically different ports and power cycled... Got keyboard to work at grub AND BIOS AND Diagnostics showed mouse was working within the Diagnostic interface screen. Boots to desktop login screen, no keyboard/no mouse...

Tried different USB ports/USB port combinations/keyboards/mice... Same results... >:(

Logged in from another host and "services" saw hald not running...
PIDs were there in ps -ef output...???
pkill -9 hald
/etc/init.d/haldaemon start [OK]

Saw that keyboard started working at login prompt, but mouse did not...
init 6...
keyboard did NOT work at grub menu... And again, no keyboard nor mouse at login prompt... Ughhh.... And never again despite recycling hald as I had before...

Any thoughts?

John VV 08-07-2013 05:23 PM

By chance were the mouse and keyboard configured in xorg.conf ?

if so
you might need to make 100% sure that the usb ports are the exact same

during boot can you get the keyboard to work well enough to boot into single user mode ( int 1 ) or into text only ( int 3 )
-- add a 3 to the end of the boot line --
-----------------------
hit < e > during the 3 sec countdown
use the down arrow to move to the kernel line in the on screen window
place a blank space then a 3 at the end ,after "rhgb quiet"
---------------
Code:

--- the start of the boot line ...KEYTABLE=us crashkernel=auto rdblacklist=nouveau rhgb quiet 3
Then read the boot and massage logs in /vat/log/ ?

and this is the SAME mouse and keyboard ?
and not different ones ?

hdbngr 08-07-2013 05:44 PM

Thanks for responding...
I'll take xorg.conf into consideration next time I am on the machine (tomorrow)...

We have got it to work in single user mode and started down the path to looking at /etc/init.d/haldaemon

We have the following hack to work to get the desktop login to work:
- ssh to problem node
- /etc/init.d/haldaemon stop [FAILED] (Just checking)
- /etc/init.d/haldaemon start [FAILED] (Just trying)
- pkill -9 hald
- /usr/sbin/hald start
- init 5

Mouse and keyboard work at login! - WTF? Subsequent reboot will fail at desktop as before... Need to fix this...

John VV 08-07-2013 06:33 PM

seeing as you moved the box , it might be possible that a card came partly out of it's slot on the motherboard

open up the tower and reseat the boards

hdbngr 08-08-2013 10:12 AM

Came across this:

Complete information about this errata can be found at the following location:
https://rhn.redhat.com/rhn/errata/de...s.do?eid=24077

Bug Fix Advisory - RHBA-2013:1132-1
------------------------------------------------------------------------------
Summary:
initscripts bug fix update

Updated initscripts packages that fix one bug are now available for Red Hat Enterprise Linux 6.


Description:
The initscripts package contains basic system scripts to boot the system, change runlevels, activate and deactivate most network interfaces, and shut down the system cleanly.

This update fixes the following bug:

* In Red Hat Enterprise Linux 6.4, a master device was always started after its slaves while using Mode 6 bonding. As a consequence, bonded interfaces were unusable. This update ensures the master device is always set up before its slaves and Mode 6 bonding now works as expected. (BZ#987998)

Users of initscripts are advised to upgrade to these updated packages, which fix this bug.

Applying this today or tomorrow... Will update thread as events warrant...


All times are GMT -5. The time now is 10:07 PM.