LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Unable to install package through yum (http://www.linuxquestions.org/questions/red-hat-31/unable-to-install-package-through-yum-721971/)

troelskn 04-27-2009 07:41 AM

Unable to install package through yum
 
Hi,

I'm trying to install imagemagick on a redhat machine, and have run into a road block, with the following:

Code:

$ sudo yum install rpm-devel
Loading "installonlyn" plugin
Loading "security" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages from Red Hat Enterprise Linux 5Server - x86_64 - rpmforge - Unwire Local Repository
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package rpm-devel.i386 0:4.4.2.3-9.el5 set to be updated
---> Package rpm-devel.x86_64 0:4.4.2.3-9.el5 set to be updated
--> Running transaction check
--> Processing Dependency: rpm-libs = 4.4.2.3-9.el5 for package: rpm-devel
--> Processing Dependency: nss-devel for package: rpm-devel
--> Processing Dependency: rpm = 4.4.2.3-9.el5 for package: rpm-devel
--> Processing Dependency: popt = 1.10.2.3-9.el5 for package: rpm-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package nss-devel.x86_64 0:3.12.2.0-4.el5 set to be updated
---> Package rpm.x86_64 0:4.4.2.3-9.el5 set to be updated
---> Package rpm-libs.x86_64 0:4.4.2.3-9.el5 set to be updated
---> Package popt.x86_64 0:1.10.2.3-9.el5 set to be updated
--> Running transaction check
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-python
--> Processing Dependency: nspr-devel >= 4.6.99 for package: nss-devel
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-build
--> Processing Dependency: nss = 3.12.2.0-4.el5 for package: nss-devel
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-libs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package rpm-build.x86_64 0:4.4.2.3-9.el5 set to be updated
---> Package rpm-python.x86_64 0:4.4.2.3-9.el5 set to be updated
---> Package nspr-devel.x86_64 0:4.7.3-2.el5 set to be updated
---> Package nss.x86_64 0:3.12.2.0-4.el5 set to be updated
--> Running transaction check
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-libs
--> Processing Dependency: nspr >= 4.6.99 for package: nss
--> Processing Dependency: nspr = 4.7.3-2.el5 for package: nspr-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package nspr.x86_64 0:4.7.3-2.el5 set to be updated
--> Running transaction check
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-libs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Dependency: rpm = 4.4.2-47.el5 for package: rpm-libs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Unable to satisfy dependencies
Error: Package rpm-libs needs rpm = 4.4.2-47.el5, this is not available.

What does this error mean, and how do I resolve it?

Dudydoo 04-27-2009 07:57 AM

Why are you trying to install rpm-devel?

troelskn 04-27-2009 08:10 AM

Quote:

Originally Posted by Dudydoo (Post 3522314)
Why are you trying to install rpm-devel?

Because of this:

Code:

$ sudo yum install ImageMagick-6.5.1-7.x86_64.rpm
Loading "installonlyn" plugin
Loading "security" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages from Red Hat Enterprise Linux 5Server - x86_64 - rpmforge - Unwire Local Repository
Finished
Parsing package install arguments
Examining ImageMagick-6.5.1-7.x86_64.rpm: ImageMagick - 6.5.1-7.x86_64
Marking ImageMagick-6.5.1-7.x86_64.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package ImageMagick.x86_64 0:6.5.1-7 set to be updated
--> Running transaction check
--> Processing Dependency: rpmlib(FileDigests) <= 4.6.0-1 for package: ImageMagick
--> Processing Dependency: libdjvulibre.so.21()(64bit) for package: ImageMagick
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package djvulibre.x86_64 0:3.5.21-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: rpmlib(FileDigests) <= 4.6.0-1 for package: ImageMagick
--> Finished Dependency Resolution
Error: Missing Dependency: rpmlib(FileDigests) <= 4.6.0-1 is needed by package ImageMagick


Dudydoo 04-27-2009 08:50 AM

What is the output of?:

Code:

yum repolist

troelskn 04-27-2009 08:58 AM

Quote:

Originally Posted by Dudydoo (Post 3522356)
What is the output of?:

Code:

yum repolist

Here:
Code:

$ sudo yum repolist
Loading "installonlyn" plugin
Loading "security" plugin

usage: yum [options] < grouplist, localinstall, groupinfo, localupdate, resolvedep, erase, deplist, groupremove, makecache, upgrade, list-security, provides, shell, install, whatprovides, groupinstall, update, groupupdate, info, search, check-update, list-sec, list, remove, info-sec, clean, info-security, grouperase >

options:
  -h, --help            show this help message and exit
  -t, --tolerant        be tolerant of errors
  -C                    run entirely from cache, don't update cache
  -c  [config file]    config file location
  -R  [minutes]        maximum command wait time
  -d  [debug level]    debugging output level
  -e  [error level]    error output level
  -y                    answer yes for all questions
  --version            show Yum version and exit
  --installroot=[path]  set install root
  --enablerepo=[repo]  enable one or more repositories (wildcards allowed)
  --disablerepo=[repo]  disable one or more repositories (wildcards allowed)
  -x [package], --exclude=[package]
                        exclude package(s) by name or glob
  --obsoletes          enable obsoletes processing during updates
  --noplugins          disable Yum plugins
  --security            Include security relevant packages
  --cve=CVE            Include packages needed to fix the given CVE
  --bz=BZ              Include packages needed to fix the given BZ
  --advisory=ADVISORY  Include packages needed to fix the given advisory

But I suspect that's not overly useful?

troelskn 04-27-2009 09:42 AM

I think I figured out what's wrong. After speaking to my sysadm, I found out that we have an internal repository. I reckon that's why it couldn't find those dependencies. In any case, we ended up simply building imagemagick from source instead.

Thanks for your help nonetheless.


All times are GMT -5. The time now is 05:26 AM.