LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 02-07-2006, 12:49 PM   #1
redhat_newb
LQ Newbie
 
Registered: Feb 2006
Posts: 3

Rep: Reputation: 0
trying to install openssl-devel


Hi there,

I am using redhat 7.3 and I am trying to install openssl-devel-0.9.6b-18.i386.rpm but I get the following error message when I try to install:

error: failed dependencies:
openssl = 0.9.6b-18 is needed by openssl-devel-0.9.6b-18

The thing that confuses me most is that when I check my machine it says that openssl-0.9.6m-2.src.rpm is already installed. I notice that this is a different version than the one openssl-devel requires, but the build date of
"openssl-0.9.6m-2.src.rpm" is Tue Jun 1 14:01:14 2004 and is actually newer than the build date of "openssl-0.9.6b-35.7.i386.rpm" which is 2003/Sep/24 21:24:27 .

I hessitate to install the older version, "openssl-0.9.6b-35.7.i386.rpm" on top of my existing newer version, "openssl-0.9.6m-2.src.rpm".

Is this anything to be worried about? I'm just worried that if I install the older version on top of the newer version it'll overwrite some files and something will stop working on my machine, because I don't know what other dependencies are depending on my existing version on my machine at the moment.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Openssl-devel, for Mandriva2006 katorrex Linux - Newbie 4 01-24-2006 11:22 AM
Package fam-devel needs libselinux-devel belkins Linux - Newbie 2 10-18-2004 03:02 PM
Upgrading OpenSSL rpm install to a source install userini Linux - Software 3 06-05-2004 10:23 AM
Openssl does not install libssl.so ninen Linux - Software 2 03-25-2003 02:35 AM
mplayer and gtk-devel and libpng-devel ... purpleburple Linux - Software 1 03-16-2003 03:57 AM


All times are GMT -5. The time now is 01:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration