LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-11-2012, 01:18 PM   #1
gusthecat
LQ Newbie
 
Registered: Feb 2012
Posts: 19

Rep: Reputation: Disabled
/tmp/cdrom does not exist with RH 6.3 kickstart %post


I have a working redhat 5.8 Kickstart that mounts the /tmp/cdrom to copy files to the HDD in the %post section. The same %post with redhat 6.3 does not work. What's changed with 6.3?
Is /tmp/cdrom called something else? Googling around I read
its an anaconda issue in that it ejects the disk prematurely. Could that be?


The error

"mount: special device /tmp/cdrom does not exist"

the KS post

%post --nochroot
mkdir -m 777 -p /mnt/cdrom
mount -t iso9660 /tmp/cdrom /mnt/cdrom
cp -fpr /mnt/cdrom/iqcustom /mnt/sysimage/tmp
umount /mnt/cdrom
rmdir /mnt/cdrom
 
Old 12-12-2012, 01:43 PM   #2
gusthecat
LQ Newbie
 
Registered: Feb 2012
Posts: 19

Original Poster
Rep: Reputation: Disabled
I got it to work with the following. Notice the --nochroot option has been removed

%post --log=/root/ks-post.log

mkdir /mnt/cdrom
mount -t iso9660 -o ro /dev/cdrom /mnt/cdrom
cp -fpr /mnt/cdrom/iqcustom /tmp/
umount /mnt/cdrom
rmdir /mnt/cdrom
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CDROM refuses to mount, /dev/cdrom does not exist shane25119 Linux - Hardware 10 08-02-2009 10:43 PM
Cannot mount cdrom in kickstart post-install VG1 Linux - Enterprise 3 05-20-2009 10:37 AM
'/tmp' does not exist or is not a directory, when connecting to [IPC$] BAD_NETWORK_NA michaelgod5 Linux - Networking 1 03-05-2008 05:57 PM
'/tmp' does not exist or is not a directory, when connecting to [IPC$] xbaez Linux - Networking 4 12-28-2005 05:44 AM
Kickstart installation. Access to cdrom in %post mrcash Fedora - Installation 2 07-21-2005 11:29 AM


All times are GMT -5. The time now is 11:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration