LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-18-2008, 07:22 AM   #1
ganick
LQ Newbie
 
Registered: Jan 2006
Posts: 19

Rep: Reputation: 0
Switching between keyboard layouts


Hi all,

My OS is CentOS 5.

I have this strange problem: my keyboard is permanently switched to
greek layout and I cannot switch back to english. When I open a terminal
I can only write in greek, so I cannot issue any valid commands.
I can always go back to text console (Ctrl+Alt+F1) and issue commands in english, but this is not possible to do in graphical (KDE) environment.
I can also remotely access the server using XDMCP (GDM) with normal XWindow environment. But, localy, the keyboard cannot be switched.
The keyboard switching icon on the Panel shows "err" when choosing
english.

Any ideas on how to solve this ?
 
Old 12-18-2008, 10:55 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
If you use KDE, you should open the System Settings window (aka Control Center, whatever it's called these days), from there locate keyboard settings and change the language that way - no writing is needed, you can click your way trough. If there are multiple keyboard layouts in a list, you can set one to be default, or if you don't need the others, remove them and leave only your preferred language in the list, so you don't accidentally switch it to something else.

There's a key combination that switches the layout between the selected layouts (configured in the settings mentioned above), in some cases I think it's left shift + left alt, but it probably depends on configuration; it's fairly easy to accidentally push those buttons and get a weird layout, so if you don't need several layouts, I suggest configuring the keyboard language settings so that only one language is available for switching.

The same applies for other desktop environments too, at least those I'm aware of where you can have multiple layouts.

Last edited by b0uncer; 12-18-2008 at 10:57 AM.
 
Old 12-18-2008, 01:41 PM   #3
ganick
LQ Newbie
 
Registered: Jan 2006
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by b0uncer View Post
If you use KDE, you should open the System Settings window (aka Control Center, whatever it's called these days), from there locate keyboard settings and change the language that way - no writing is needed, you can click your way trough.
Already done that to no avail. I think that somebody messed up the
X11 configuration files, don't know what or where.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
switching between keyboard layouts trawler Linux - Software 1 10-22-2005 06:51 AM
Switching keyboard layouts jrdioko Linux - General 0 10-24-2004 02:07 PM
keyboard layouts misulo Fedora 0 08-17-2004 01:29 PM
Switching between keyboard layouts ??? GloVe Linux - General 1 10-13-2003 10:26 AM
switching keyboard layouts linuxfond Linux - Newbie 1 05-28-2003 10:04 PM


All times are GMT -5. The time now is 01:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration