LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Switching between keyboard layouts (http://www.linuxquestions.org/questions/red-hat-31/switching-between-keyboard-layouts-691461/)

ganick 12-18-2008 07:22 AM

Switching between keyboard layouts
 
Hi all,

My OS is CentOS 5.

I have this strange problem: my keyboard is permanently switched to
greek layout and I cannot switch back to english. When I open a terminal
I can only write in greek, so I cannot issue any valid commands.
I can always go back to text console (Ctrl+Alt+F1) and issue commands in english, but this is not possible to do in graphical (KDE) environment.
I can also remotely access the server using XDMCP (GDM) with normal XWindow environment. But, localy, the keyboard cannot be switched.
The keyboard switching icon on the Panel shows "err" when choosing
english.

Any ideas on how to solve this ?

b0uncer 12-18-2008 10:55 AM

If you use KDE, you should open the System Settings window (aka Control Center, whatever it's called these days), from there locate keyboard settings and change the language that way - no writing is needed, you can click your way trough. If there are multiple keyboard layouts in a list, you can set one to be default, or if you don't need the others, remove them and leave only your preferred language in the list, so you don't accidentally switch it to something else.

There's a key combination that switches the layout between the selected layouts (configured in the settings mentioned above), in some cases I think it's left shift + left alt, but it probably depends on configuration; it's fairly easy to accidentally push those buttons and get a weird layout, so if you don't need several layouts, I suggest configuring the keyboard language settings so that only one language is available for switching.

The same applies for other desktop environments too, at least those I'm aware of where you can have multiple layouts.

ganick 12-18-2008 01:41 PM

Quote:

Originally Posted by b0uncer (Post 3380107)
If you use KDE, you should open the System Settings window (aka Control Center, whatever it's called these days), from there locate keyboard settings and change the language that way - no writing is needed, you can click your way trough.

Already done that to no avail. I think that somebody messed up the
X11 configuration files, don't know what or where.


All times are GMT -5. The time now is 08:15 AM.