LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-05-2005, 07:07 PM   #1
binchin
LQ Newbie
 
Registered: Sep 2005
Distribution: RH9, FC4, FC4ppc, Slack
Posts: 7

Rep: Reputation: 0
strange net config behavior - interesting experience...


Previous question was how to set up an isa eepro card with a built-in pci in a dell optiplex in rh 9.

after normal setup w/o an rc.modules file,
I get the built-in 3c59x card mapped to eth0 and that's it.
at this point, I can modprobe eepro io irq and it maps to eth1.

but then dhclient still wouldn't set up my ip for eth1.
so I added the device ifcfg-eth1 to sysconfig networking folders devices and default by copying ifcfg-eth0: BOOT dhcp, etc.

in rc.modules, I added modprobe eepro io=blah irq=10, and suddenly, it ONLY finds the isa card, and doesn't bother finishing loading the onboard 3c59x.
WHY? perhaps it only cares to load the first one. fine.
I added an explicit modprobe to my rc.modules for the 3c59x card.

Great.. it loads the modules, but dhclient still doesn't automatically configure it on startup.
When I manually "dhclient eth1", things work out and I have two nics set up nicely.

What I really want is the isa card for wan as eth0, and the onboard 10/100 for lan as eth1.

Any comments welcome.

Last edited by binchin; 09-05-2005 at 07:09 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
interesting gmplayer behavior DJOtaku Linux - Software 2 08-12-2005 09:56 AM
Very Strange Behavior raysr Mandriva 4 08-31-2004 02:06 PM
Debian strange behavior about network config Half_Elf Debian 3 04-01-2004 12:07 PM
Strange Behavior andrewb758 Linux - Hardware 5 08-31-2003 02:42 PM
strange behavior abhijit Linux - General 3 07-09-2003 11:25 PM


All times are GMT -5. The time now is 01:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration