LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   snmpd failed: No such file or directory (http://www.linuxquestions.org/questions/red-hat-31/snmpd-failed-no-such-file-or-directory-544525/)

kav 04-09-2007 09:02 AM

snmpd failed: No such file or directory
 
Running an up to date RHEL4 system trying to get SNMP working

# /etc/init.d/snmpd start
Starting snmpd: //usr/sbin/snmpd: error while loading shared libraries: librpm-4.4.so: cannot open shared object file: No such file or directory
[FAILED]
# locate librpm-4
/usr/lib/librpm-4.3.so


I have searched the internet for days trying to figure out what rpm I need to install to upgrade librpm-4.3 to 4.4 but haven't found anything useful. What do I need to do? Please, I need help. My boss is getting adgitated at my lack of progress. I'm used to debian and red hat is unfamiliar to me :(

freeindia 04-09-2007 10:24 AM

http://rpm.pbone.net/index.php3/stat.../field%5B%5D/2

kav 04-09-2007 10:37 AM

This is what happens when I try to install it. What do I do now?

# rpm -Uvh librpm4.4-4.4.2-15.2_60.el4.at.i386.rpm
warning: librpm4.4-4.4.2-15.2_60.el4.at.i386.rpm: V3 DSA signature: NOKEY, key ID 66534c2b
error: Failed dependencies:
libsqlite3.so.0 is needed by librpm4.4-4.4.2-15.2_60.el4.at.i386
librpm-4.3.so is needed by (installed) rpm-4.3.3-18_nonptl.i386
librpm-4.3.so is needed by (installed) rpm-python-4.3.3-18_nonptl.i386
librpm-4.3.so is needed by (installed) rpm-build-4.3.3-18_nonptl.i386
librpm-4.3.so is needed by (installed) rpm-devel-4.3.3-18_nonptl.i386
librpmbuild-4.3.so is needed by (installed) rpm-4.3.3-18_nonptl.i386
librpmbuild-4.3.so is needed by (installed) rpm-build-4.3.3-18_nonptl.i386
librpmdb-4.3.so is needed by (installed) rpm-4.3.3-18_nonptl.i386
librpmdb-4.3.so is needed by (installed) rpm-python-4.3.3-18_nonptl.i386
librpmdb-4.3.so is needed by (installed) rpm-build-4.3.3-18_nonptl.i386
librpmdb-4.3.so is needed by (installed) rpm-devel-4.3.3-18_nonptl.i386
librpmio-4.3.so is needed by (installed) rpm-4.3.3-18_nonptl.i386
librpmio-4.3.so is needed by (installed) rpm-python-4.3.3-18_nonptl.i386
librpmio-4.3.so is needed by (installed) rpm-build-4.3.3-18_nonptl.i386
librpmio-4.3.so is needed by (installed) rpm-devel-4.3.3-18_nonptl.i386

freeindia 04-09-2007 12:08 PM

1)) It means the existing shared libraries are required by other rpm packages. I guess better idea is to get back the previous version of snmp version which can run using the existing libraries.

rpm -a |grep -i snmp

ldd /usr/sbin/snmpd

2)) or upgrade all the rpm pkgs with new shared libraries. i guess that's something requires more work and have large impact.

kav 04-09-2007 12:26 PM

Let's say I want option 1) roll back snmp.

rpm -a doesn't return anything at all, even without the grep

here is the output of ldd:

]# ldd /usr/sbin/snmpd
/usr/sbin/snmpd: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/sbin/snmpd)
/usr/sbin/snmpd: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib/libnetsnmpmibs.so.15)
/usr/sbin/snmpd: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib/libnetsnmpagent.so.15)
/usr/sbin/snmpd: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib/libnetsnmphelpers.so.15)
/usr/sbin/snmpd: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/lib/libnetsnmp.so.15)
libnetsnmpmibs.so.15 => /usr/lib/libnetsnmpmibs.so.15 (0x00316000)
libnetsnmpagent.so.15 => /usr/lib/libnetsnmpagent.so.15 (0x00f51000)
libnetsnmphelpers.so.15 => /usr/lib/libnetsnmphelpers.so.15 (0x00566000)
libnetsnmp.so.15 => /usr/lib/libnetsnmp.so.15 (0x00111000)
librpm-4.4.so => not found
librpmio-4.4.so => not found
libpopt.so.0 => /usr/lib/libpopt.so.0 (0x00cfc000)
libz.so.1 => /usr/lib/libz.so.1 (0x009ca000)
libcrypto.so.6 => not found
libperl.so => not found
libresolv.so.2 => /lib/libresolv.so.2 (0x009dc000)
libnsl.so.1 => /lib/libnsl.so.1 (0x00c8c000)
libdl.so.2 => /lib/libdl.so.2 (0x0089a000)
libm.so.6 => /lib/tls/libm.so.6 (0x00875000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x00639000)
libutil.so.1 => /lib/libutil.so.1 (0x00df7000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0x00981000)
libc.so.6 => /lib/tls/libc.so.6 (0x00748000)
/lib/ld-linux.so.2 (0x0072a000)

You are being very helpful, thank you. How should I proceed now?

freeindia 04-09-2007 12:32 PM

sorry that command is

rpm -qa |grep -i snmp

kav 04-09-2007 12:41 PM

that returned this

net-snmp-5.4-1
net-snmp-libs-5.1.2-11.EL4.7

freeindia 04-09-2007 12:47 PM

Remove the snmp package from the system
rpm -ve net-snmp-5.4-1

and install the lower version of snmp , net-snmp-5.1.3.1-1.el4.i386.rpm

http://rpm.pbone.net/index.php3?stat...=net-snmp&dist[]=42&field[]=1&field[]=2

I guess snmp-lib need to be as its.

give a try and let us see.

kav 04-09-2007 01:16 PM

]# rpm -Uvh net-snmp-5.3-1.el4.i386.rpm
Preparing... ########################################### [100%]
1:net-snmp ########################################### [100%]

# /etc/init.d/snmpd start
Starting snmpd: [ OK ]


And there you have it my friend. Interestingly enough, after reviewing the dependencies of the version of snmp I was removing before installing this one is that it was required by zenoss. I'm positive I upgraded that file just to get zenoss installed. So doesn't that make it ironic that installing the software actually broke it's own primary means of data gathering?

And to think that damn program was the only reason I went through the painfull process of forcing MySQL 5 to install rather than using the version included.

I've had enough of zenoss, I'm trying zabbix. The boss probly won't know the difference.

Thanks a lot for your help freeindia. I now have a slightly better understanding of how to use rpm and where to get them.


All times are GMT -5. The time now is 01:40 AM.