LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 02-08-2005, 11:44 AM   #1
Sizam
LQ Newbie
 
Registered: Jun 2003
Posts: 8

Rep: Reputation: 0
Unhappy Sendmail, kinda working, kinda borken


I've been running a RH server since 7.1 and generally everything works out great, one of my HDs fried recently so I decided to reinstall with Fedora, I've gotten the server back up and running on all fronts except mail, its not quite working. First off, my firewall is blocking my SMTP port so I can't currently _receive_ mail from outside my server but I'm aware of this problem and will be fixing it shortly. What is stumping me is that I can't send mail to certain domains _from_ my server, it either times out or is refused:

Feb 6 10:27:46 domain sendmail[18536]: j15KvUHl013820: to=<account@gmail.com>, ctladdr=<user@domain> (500/500
), delay=21:30:16, xdelay=00:03:00, mailer=esmtp, pri=2011505, relay=gsmtp57.google.com. [216.239.57.27], dsn=4.0
.0, stat=Deferred: Connection timed out with gsmtp57.google.com.

Feb 8 07:24:46 domain sendmail[20081]: j18EOvHl020075: to=<user@domain.org>, ctladdr=<user@domain.net> (500/500), delay=00:59:49, xdelay=00:00:00, mailer=esmtp, pri=121546, relay=mxpool.postoffice.net. [165.212.6
5.113], dsn=4.0.0, stat=Deferred: Connection refused by mxpool.postoffice.net.

But to users at other domains the mail gets sent fine. Why would it only fail on sending to some domains, is it a problem with my DNS?

Any help is much appreciated,
Thanks!
 
Old 02-08-2005, 12:16 PM   #2
Sizam
LQ Newbie
 
Registered: Jun 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Ok, found the fix to allow me to access port 25 from outside my box, and thats now working but I still can't send mail to certain addresses, gmail.com for example.

EDIT:
After more reading it looks like it might be related to my /etc/hosts file which currently reads:

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 myname.net myname localhost.localdomain localhost


What should I add to this, not all websites agree, but something in the form of:

myipaddress myname.net myname.net(which is what HOSTNAME is)

Last edited by Sizam; 02-08-2005 at 01:58 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 questions kinda the same emg Suse/Novell 6 04-24-2005 12:20 PM
basic proftp questions - kinda works kinda don't case1984 Linux - Newbie 4 11-06-2003 12:29 AM
postfix kinda not working thesnaggle Linux - Software 2 10-01-2003 12:20 PM
DVD in mplayer, working... kinda SlvrDakotaRT Linux - Software 2 02-19-2003 09:10 AM
DNS working....kinda diveguy Linux - Networking 0 02-27-2002 09:04 AM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration