LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 02-12-2004, 10:36 PM   #1
venkatm
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Rep: Reputation: 0
Screen Resolution Problem with Redhat 9


Hi,
I am new to Linux , I recently installed Redhat linux 9 with windows XP dual booting on my Dell 2400 PC. Installation went well, but the sceens are too big to fit in monitor. Scrrens not fitting in monitor window. Labels over lap on login screen also.

I feel problem is with resolutions. I tried to for various resolution modes graphilly but it seems it is taking only 640x480 as i got this from physical monitor adjustment window. If i edited and remove the 640x480, my X window not starting and probing and asking me to select resolution.

MY Monitor is Dell E773c with windows 1024 X 768 resolution and Intel 82845 G/GL/.... video card.
I appreciate for your help.
with regards,
venkat

Last edited by venkatm; 02-13-2004 at 04:26 PM.
 
Old 02-13-2004, 05:24 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Most likely you haven't configured the hsync and vsync refresh rates properly. Have you tried running the Redhat xconfig again or tried xf86config to reconfigure X?
 
Old 02-13-2004, 09:19 PM   #3
venkatm
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Original Poster
Rep: Reputation: 0
Thak you, i am enclosing the config file here for your ref.

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "DELL E773c"
DisplaySize 320 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 845"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 02-14-2004, 05:58 AM   #4
zatka
Member
 
Registered: Dec 2003
Distribution: Fedora 7
Posts: 75

Rep: Reputation: 15
In the section screen (of above config file) try reducing the value. it should look like this,
Modes "1024x768" "800x600" "640x480".
try deleting the first value if u still didn't get correct resolution.
otherwise start the terminal as root & run 'setup' (without qoutes). there choose display related configuration & configure it.
 
Old 02-14-2004, 07:43 PM   #5
venkatm
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Original Poster
Rep: Reputation: 0
I changed the modes to above 3 only.But of no use. setup does not have an option to change display.
 
Old 02-15-2004, 05:37 AM   #6
cedric_b
LQ Newbie
 
Registered: Oct 2003
Posts: 3

Rep: Reputation: 0
Hi,
I've just changed my screen resolution from 800x600 to 1024x768.
First time I attempted to do it edit the config file and change it directly prepending 1024x768, without changing the vertical and horizontal frequencies, and resolution remained unchanged after reboot.
Finally I changed the resolution, using the desktop toolbar: System Settings -> Display,
changing the resolution to 1024x768 and also the screen refresh frequencies to the vendor's values , according to my monitor user guide , clicking on the Advanced tab.
The frequency values guessed by redhat where different from the real monitor capabilities.
That may be the point that prevents you from getting the right resolution.
I hope that will help you ,
CÚdric
 
Old 02-20-2004, 08:29 AM   #7
venkatm
LQ Newbie
 
Registered: Feb 2004
Posts: 5

Original Poster
Rep: Reputation: 0
i got solution, the problem is with frame buffer size in bios, it is 1 mb, i changed it to 8 mb, now i am able to get required resolution.
Thank you. Thanks for your advices.
 
Old 03-13-2004, 06:28 PM   #8
sundaysun
LQ Newbie
 
Registered: Mar 2004
Posts: 1

Rep: Reputation: 0
cannot set resolution

Hello, how did you change the frame buffer size? Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen size problem darkstar420 Slackware 5 08-08-2004 03:12 PM
Redhat login screen size odd Linux - Software 0 06-26-2004 02:04 PM
Screen size probem with redhat linux 9 installation venkatm Linux - General 0 02-12-2004 07:56 PM
Screen size problem Linux~Powered Linux - Hardware 5 02-11-2004 01:24 AM
screen size problem alim Slackware 1 04-22-2002 09:10 AM


All times are GMT -5. The time now is 02:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration