LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 11-30-2003, 10:42 PM   #1
srikz
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Rep: Reputation: 0
Samba Works, Windows can access Linux Side but ............


hello

i have 2 redhat linux9 servers both running on IBM eservers, the windows client can access these data and appliation servers but the problem is my linux servers cannot get connected to the wondows systems, so that i can copy the files from windows shared folders in to the server.

what to do...........

Thanks in advace
 
Old 12-01-2003, 12:07 AM   #2
p_mithaulia
LQ Newbie
 
Registered: Jun 2003
Posts: 1

Rep: Reputation: 0
using SAMBA server to access files....
 
Old 12-01-2003, 12:34 AM   #3
wartstew
Member
 
Registered: Apr 2002
Location: Albuquerque, NM USA
Distribution: Slackware, Ubuntu, Debian, Maemo
Posts: 464

Rep: Reputation: 30
Sorry, we need more information:

What have you tried, and what happened?

Did you create an account on your windows servers that match what you are logging in on with your Linux machine? How are you trying to access your windows machines? (smbclient, smbfs, "smb://" in Konquerquer, Linneighborhood, gnosamba, etc.)
 
Old 12-01-2003, 03:42 AM   #4
Ashish Pathak
LQ Newbie
 
Registered: Sep 2003
Location: Pune, India.
Posts: 17

Rep: Reputation: 0
Okie!!

You wanna access windows share from linux .. Ok.
You can do this by compiling kernel with smbfs support or download linneighbourhood from this link (http://java.thn.htu.se/~toor/).
This tool is just like windows network neighbourhood.
If you dont find this tool then you need to compile ur kernek with smbfs support option enabled in network filesystems menu.
After this simply create one user in ur windows machine as well as in linux machine.
Note : This user should be present one both windows as well as linux machines and just give proper rights to the share folder for this user.
Loged in with new user in linux.

Then just try to mount windows share giving following command: -

mount -t smbfs //winservername/sharefolder /mountpoint.
I guess this will work!! ..

Thanks,
/Ashish/Pathak.
/Pune/India.
 
Old 12-01-2003, 10:14 AM   #5
srikz
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
sorry guys i was kinda busy as the deadline for a project is round the corner. thanks ashish for the help i will download the linneighbourhood and then reply. hope it works
bye guys and thanks for the help
srikz
 
Old 12-01-2003, 12:56 PM   #6
bindsocket
LQ Newbie
 
Registered: Oct 2003
Posts: 9

Rep: Reputation: 0
Samba can see other sambas but no Windows shares

I am running RH9. I can access other samba shares using mount -t smbfs... and using Nautilus 2.2.1 . There are two different Sambas running on our network and I can access them with no problems. However, whenever I attempt to access any of the windows shares (every computer in the office has at least one folder shared for backup purposes) I cannot access them at all.
mount -t smbfs -o username=username,password=password //computer/folder /tmp/smbmount run on any of the windows shares results in "Connection to computer failed SMB connection failed". Nautilus returns "Couldn't display "computer", because no host "computer" could be found...".
Incidentally, I can no longer browse Network Neighborhood from any machine (linux nor windows). However, I do not believe this is related as I can mount the windows shares manually from the other windows machines.
 
Old 12-01-2003, 04:22 PM   #7
darkseed2g3
Member
 
Registered: Sep 2003
Location: Philadelphia ,Pa
Distribution: Fedora Core 1 BABY !!! YEA
Posts: 67

Rep: Reputation: 19
here is the easiest way , screw the neighborhood bullshit . You went with linux to get away from microcraps deception. What you do is enter this command

mount -t smbfs -o username=usr,password=password //host/sharename /mountpoint

put that up in a script and voila , there it is.

make sure that you have netbois and all the crap installed on windows and its up and running when you do this
 
Old 12-02-2003, 01:29 AM   #8
srikz
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
ok now it works

yeah using the command line works.... so screw the neighbour hood
... but if you still insist on using GUI. linneighbourhood goes the job
 
Old 12-02-2003, 01:37 AM   #9
wartstew
Member
 
Registered: Apr 2002
Location: Albuquerque, NM USA
Distribution: Slackware, Ubuntu, Debian, Maemo
Posts: 464

Rep: Reputation: 30
I don't think I've ever got the "mount -t smbfs" thing working without having an /etc/samba/smb.conf file correctly configured to the network I was attaching too. I'm not sure what minimum parameters are required to make it work, but things like the workgroup and password encryption setting might be required. Then I think you need at least nmbd running to be able to find the computer you are trying to attach to.

Please correct me where I'm wrong. I kind of would like to know the minimum configuration that is necessary for this to work.
 
Old 12-02-2003, 02:30 AM   #10
srikz
LQ Newbie
 
Registered: Nov 2003
Posts: 19

Original Poster
Rep: Reputation: 0
open the /etc/samba/smb.conf file and assign your workgroup name and then the local master, browser master settings. if your running rh9 no need starting the nmbd deamon.
just issue the command # service smb restart.
 
Old 12-02-2003, 09:24 AM   #11
wartstew
Member
 
Registered: Apr 2002
Location: Albuquerque, NM USA
Distribution: Slackware, Ubuntu, Debian, Maemo
Posts: 464

Rep: Reputation: 30
So you are saying that nmbd *does* need to be running? (as in you are restarting the whole samba service with the /etc/rc.d/init.d script.)

In any case, if you just enable "swat" (by placing or uncommenting the line in /etc/inetd.conf), then you can get a nice point & shoot GUI for configuring your smb.conf file from your favorite browser by using something like http://localhost:901

Also, if you run KDE, another smb access is by simply entering "smb://machine/share" in Konquerer's url form and it will go there. ... Nice!

(There is so many ways of doing things in GNU/Linux that it makes my head spin!)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba: Windows can't access linux. Password needed?!? mcgoon Linux - Networking 26 06-10-2005 06:53 PM
Samba: Windows XP Pro access to Linux box bramadams Slackware 7 02-05-2005 09:25 AM
Samba access by Windows users locking out directory access with Konqueror harry_fine Suse/Novell 1 12-18-2004 05:33 AM
No internet access in linux, works fine in windows c0uchm0nster Linux - Networking 8 01-29-2004 06:45 AM
Samba / XP login failures while tring to access shared files (works with win2k) Zero-0-Effect General 2 01-24-2004 09:27 PM


All times are GMT -5. The time now is 09:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration