LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 05-24-2005, 05:01 PM   #1
hverne
LQ Newbie
 
Registered: May 2005
Posts: 3

Rep: Reputation: 0
rsync daemon


I want to starup rsync as a daemon.
I tried "rsync --daemon", no error message but ps could not find it.
Here is what I do know.
1. /etc/xinetd.d/rsync does exist (I changed disble to = no)
2. /us/bin/rsync executable exists.
3. there is no entry in /etc/rc.d/init.d for rsync(d)
4. rsync(d).conf does not exist.
5. using latest redhat version of rsync (2.6.3)
6. kernel 2.6.11-1.14_FC3
I
nterestingly enough, I have rsync working fine on my windows machines, using cygwin. I am having troubles with Fedora!

TIA
Help!
 
Old 06-01-2005, 01:34 PM   #2
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
First of all, note that there is a "Fedora" forum here at linuxquestions.org. The "Red Hat" forum is for Red Hat Enterprise Linux and old Red Hat Linux.

You don't need a separate rsync daemon, because the rsync server is driven by the Internet services daemon xinetd. Instead of editing /etc/xinetd.d/rsync yourself, you would simply run "chkconfig rsync on" and configure rsync (read "man rsyncd.conf"). That is, you must create the rsyncd.conf file. When xinetd is active and running, it would start rsync for incoming connections. If it is not running already, "chkconfig xinetd on ; service xinetd start" enables and starts it.
 
1 members found this post helpful.
Old 06-02-2005, 05:53 AM   #3
bramhastra
Member
 
Registered: May 2005
Location: India
Distribution: RHEL 4.0
Posts: 136

Rep: Reputation: 15
LAUNCHING THE RSYNC DAEMON

This is how to go

The rsync daemon is launched by specifying the --daemon option to rsync.

The daemon must run with root privileges if you wish to use chroot, to bind to a port numbered under 1024 (as is the default 873), or to set file ownership. Otherwise, it must just have permission to read and write the appropriate data, log, and lock files.

You can launch it either via inetd, as a stand-alone daemon, or from an rsync client via a remote shell. If run as a stand-alone daemon then just run the command "rsync --daemon" from a suitable startup script. If run from an rsync client via a remote shell (by specifying both the "-e/--rsh" option and server mode with "::" or "rsync://"), the --daemon option is automatically passed to the remote side.

When run via inetd you should add a line like this to /etc/services:


rsync 873/tcp
and a single line something like this to /etc/inetd.conf:


rsync stream tcp nowait root /usr/bin/rsync rsyncd --daemon
Replace "/usr/bin/rsync" with the path to where you have rsync installed on your system. You will then need to send inetd a HUP signal to tell it to reread its config file.

Note that you should not send the rsync server a HUP signal to force it to reread the rsyncd.conf file. The file is re-read on each client connection.
 
Old 06-02-2005, 07:05 AM   #4
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Quote:
Originally posted by bramhastra
When run via inetd you should add a line like this to /etc/services:
Please don't mess with /etc/services. It knows about the rsync port number by default. Also note that xinetd is used, not inetd.
 
Old 06-02-2005, 07:16 AM   #5
bramhastra
Member
 
Registered: May 2005
Location: India
Distribution: RHEL 4.0
Posts: 136

Rep: Reputation: 15
Well he can give a try and see if it works
 
Old 06-02-2005, 07:21 AM   #6
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
No. inetd and xinetd use fundamentally different configuration files. rsync via xinetd comes pre-configured on Fedora Core 3 (and older). He just needs to read my post and set up rsyncd.conf according to the manual page.
 
Old 06-04-2005, 09:37 PM   #7
hverne
LQ Newbie
 
Registered: May 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks guys, It works fine now!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rsync sant25 Linux - General 2 09-02-2005 04:34 PM
rsync daemon hverne Fedora 1 05-27-2005 08:58 AM
Windows Rsync Upload to Linux Rsync - permissions inspleak Linux - Software 0 10-12-2004 03:49 PM
Rsync eddiefdz Linux - Software 0 02-20-2004 02:56 PM
rsync slack66 Slackware 1 07-29-2003 10:33 PM


All times are GMT -5. The time now is 12:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration