LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 03-10-2011, 02:43 AM   #1
lakshmanan_linux
LQ Newbie
 
Registered: Mar 2011
Posts: 1

Rep: Reputation: 0
rpmlib(PayloadIsLzma) <= 4.4.2-1


Hi all,

When i try to install some rpm packages in my RHEL 5.5 box i am getting the following error

error: Failed dependencies:
rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed

I am not able to download the rpmlib(PayloadIsLzma) rpm file in any site. Can anyone tell me the site where i can download its rpm file.



Thanks,
Lakshmanan.
Software Engineer.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 03-10-2011, 03:13 AM   #2
corp769
Guru
 
Registered: Apr 2005
Posts: 5,807

Rep: Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996Reputation: 996
You are getting that error because the packages you are trying to install are compressed using lzma, and your current version of rpm doesn't not apparently support it. You need to upgrade rpm and the rpm libs.

Cheers,

Josh

PS - If you really were a software engineer, I highly doubt you would be asking this question. Just my ten cents...
 
Old 03-10-2011, 03:36 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,557

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
Welcome to LQ.

Please only use packages meant for EL5.
The "rpmlib(PayloadIsLzma) <= 4.4.2-1" issue appears,
when you try to install e.g. a Fedora 12 package.

EL 5 packages : 1) The EPEL repo https://fedoraproject.org/wiki/EPEL
>> http://download.fedora.redhat.com/pub/epel/5/i386/

2) Redhat (source) http://ftp.redhat.com/pub/redhat/lin...r/en/os/SRPMS/

P.S. : When you tell, which package this is about, we will advice you
with a package suggestion.
http://linuxsilo.net/docs/smart-questions_en.html

..

Last edited by knudfl; 03-10-2011 at 03:42 AM.
 
Old 03-12-2011, 02:22 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,140
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
//OT comments moved here.
 
Old 02-24-2013, 12:31 AM   #5
shriakntmore
LQ Newbie
 
Registered: Feb 2013
Posts: 1

Rep: Reputation: Disabled
rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed

when i am installing any packages with rmp getting an error rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed.
please give the solution to resolve this issue.

if i need to update the rmp,then please tell me how to update it.

thank you!
 
Old 02-25-2013, 12:11 PM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,557

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
Post # 5, @shriakntmore : Welcome to LQ.

Which OS are you using ? ?
http://www.linuxquestions.org/linux/...Ask_a_Question
http://linuxsilo.net/docs/smart-questions_en.html

It is usually not the solution to change the rpm version.
Solution : Please use rpm packages meant for your OS.
** Which rpm package are you trying to install ?


-

Last edited by knudfl; 02-25-2013 at 01:49 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] rpmlib(PayloadIsLzma) is needed nisagnel Linux - General 5 09-20-2010 08:44 AM
What provides rpmlib(PayloadIsLzma)? catapult1 Suse/Novell 10 12-25-2009 01:10 AM
rpmlib(PayloadIsLzma) vduvvuru Linux - General 2 08-29-2008 09:41 AM
where to get rpmlib ? mahesh_chavan Linux - Newbie 1 02-08-2008 12:23 PM
rpmlib ras123 Linux - Newbie 1 05-13-2004 02:27 PM


All times are GMT -5. The time now is 03:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration