LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-01-2009, 11:56 PM   #1
bharatlalgupta
Member
 
Registered: Aug 2008
Posts: 79
Blog Entries: 1

Rep: Reputation: 16
Question root login is disable only on GUI


hello dear all
i have a machine RHEL 5.3 in that machine root user directly login on tty1-6 but when try to login on GUI it get a message "Root login is disable" so what reason ????????
 
Old 12-02-2009, 12:13 AM   #2
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Quote:
Originally Posted by bharatlalgupta View Post
hello dear all
i have a machine RHEL 5.3 in that machine root user directly login on tty1-6 but when try to login on GUI it get a message "Root login is disable" so what reason ????????
Login as root in the GUI is a very bad idea .
And is disabled in many distros
Which tasak could you not perform in the terminal as su or sudo ?
 
Old 12-02-2009, 12:21 AM   #3
sirlancealot
Member
 
Registered: Mar 2008
Location: Washington State, US
Distribution: OPENSuse 11.1
Posts: 35

Rep: Reputation: 17
I've run into this problem as well with ubuntu machines, never actually tried to solve it, but some people were suggesting it was the login manager that controls whether root can login or not. (and generally some option that you just have to set to "true" or "false" in the login manager's config file).
 
Old 12-02-2009, 12:36 AM   #4
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Quote:
Originally Posted by sirlancealot View Post
I've run into this problem as well with ubuntu machines, never actually tried to solve it, but some people were suggesting it was the login manager that controls whether root can login or not. (and generally some option that you just have to set to "true" or "false" in the login manager's config file).
More ore less they are correct that depending on the GUI you use that it is possible to enable the root login
And in fact it is quit simple.
For a start you need to use GNOME
But still it is a very bad idea to do so.

Last edited by ronlau9; 12-02-2009 at 12:38 AM.
 
Old 12-03-2009, 12:39 AM   #5
bharatlalgupta
Member
 
Registered: Aug 2008
Posts: 79
Blog Entries: 1

Original Poster
Rep: Reputation: 16
hello friend
i understand this is bad so but
how to resolve it
 
Old 12-03-2009, 01:03 AM   #6
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
If you determine nano /etc/pam.d/gdm
The line is So user =root quiet make it a remark
 
Old 12-03-2009, 01:46 AM   #7
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Debian, SL
Posts: 5,318

Rep: Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142
Quote:
Originally Posted by bharatlalgupta View Post
i understand this is bad so but
Ok, if you say so.

Quote:
how to resolve it
As stated by others, log in as a normal user then su to root.

If you really insist on logging into X as root...
You didn't say, but I guess you are using gdm. In the gdm conf file
which could be something like /etc/gdm/gdm.conf you need to replace

Code:
AllowRoot=false
with
Code:
AllowRoot=true
Enjoy putting your system at risk.

Cheers,

Evo2.
 
Old 12-20-2009, 11:58 PM   #8
bharatlalgupta
Member
 
Registered: Aug 2008
Posts: 79
Blog Entries: 1

Original Poster
Rep: Reputation: 16
sorry friend
your gdm configuration file is not exist i'm using GNOME......
ok plz tell me another way to login here..

Last edited by bharatlalgupta; 12-20-2009 at 11:58 PM. Reason: rectification
 
Old 12-21-2009, 06:37 AM   #9
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Debian, SL
Posts: 5,318

Rep: Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142Reputation: 1142
Quote:
Originally Posted by bharatlalgupta View Post
sorry friend
your gdm configuration file is not exist i'm using GNOME......
Well, find where where you system has the gdm (Gnome Display Manager) config file. You're the one sitting at the machine. Not me.

Evo2.
 
Old 12-21-2009, 03:50 PM   #10
bret
Member
 
Registered: Apr 2005
Location: SLC, Utah
Distribution: RHEL 4, RHEL 5
Posts: 59

Rep: Reputation: 16
Check out your /etc/securetty file. This file determines which terminals (vc/1-vc/11 and tty1-tty11) are available for root to login with.
 
Old 12-22-2009, 12:10 AM   #11
bharatlalgupta
Member
 
Registered: Aug 2008
Posts: 79
Blog Entries: 1

Original Poster
Rep: Reputation: 16
yes friend this tty and vc are availabel
 
  


Reply

Tags
gui, login, root


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable root login in GUI (RHEL5)? saagar Linux - Newbie 4 08-06-2009 11:54 AM
disable root login shivanrathore Linux - Security 6 07-15-2008 07:26 AM
Disable root login n00bified Slackware 8 07-17-2006 04:42 AM
disable root login with ssh linuxtesting2 Slackware 3 02-16-2005 12:33 PM
Disable GUI Login and Config StartX firefly2442 Linux - Newbie 6 07-21-2003 11:02 PM


All times are GMT -5. The time now is 07:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration