LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 01-17-2008, 07:41 AM   #1
Bad_Mouse
LQ Newbie
 
Registered: Jan 2008
Location: Surrey England
Distribution: Centos 5.1
Posts: 6

Rep: Reputation: 0
Smile rhel9 wireless and ndiswrapper final step - what is it?


I have installed ndiswrapper and everything went fine.

So much so that I can see my router with iwlist wlan0 scan and also other nearby wireless APs. I set the ESSID using iwconfig.

The last bit of the NDISwrapper installation says:

Quote:
Now, setup the network parameters for the interface wlan0. This varies from distribution to distribution. Refer to your distributionís documents on how to do this. Once this is done, you can use network tools to bring up the network e.g., ifconfig wlan0 up
I can't use the Sysadmin GUI on the desktop because my card is not in the drop-down list, so no card, no connection.

What parameters do I need to set? How do I do this? Do I use iwconfig in the same way as I did for the ESSID?

With thanks in advance.
 
Old 01-17-2008, 07:52 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
rhel9
... but thuru is no such thing! The latest is RHEL5.
Could you be talking about "Redhat Linux 9"?

Show output of

ifconfig

iwconfig
 
Old 01-17-2008, 08:07 AM   #3
Bad_Mouse
LQ Newbie
 
Registered: Jan 2008
Location: Surrey England
Distribution: Centos 5.1
Posts: 6

Original Poster
Rep: Reputation: 0
whoops! I better come clean and say I'm running Centos 5.1 (Distro downloaded about 2 weeks ago). This as you probably know is rhel in disguise. So yes, it is RHEL 5.

I'll post the output you ask for, in a few hours time, thanks. (not at the right site right now).
 
Old 01-17-2008, 10:14 AM   #4
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
I'm running Centos 5.1
Why didn't you say so you've just saved yourself a speech about community vs commercial support. In future, quote "CentOS5.1" as your distro, put it in your profile. You've nothing to hide... everyone has the right to use, copy, modify and distribute any free software.
 
Old 01-17-2008, 05:55 PM   #5
Bad_Mouse
LQ Newbie
 
Registered: Jan 2008
Location: Surrey England
Distribution: Centos 5.1
Posts: 6

Original Poster
Rep: Reputation: 0
Here is the output. I typed this in after reading it off the monitor because at the moment I have no way of getting data out of the Centos Box. There is a floppy but it is not working - but that's another story though. Here is what I'm getting: (I've changed the ESSID and encryption key just in case there is a bunch of hackers lurking outside my front door, reading this on a laptop...)

iwconfig

wlan0 IEEE 802.11g ESSID:"WoofWoof"
Mode:Managed Frequency:2:2.412 Ghz Access Point: Not-Associated
Bit Rate:108 Mb/s
Encryption key:3D56-4G68-4B87-7373-79 Security Mode:restricted
Link Quality:0 Signal level:0 Noise Level:0
Rx invalid nwld:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


and now the output from ifconfig. I notice the local loopback entry below is showing a bunch of packets. I've started Firefox and tried to get to Google a number of times.


iwconfig

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets: 4734 errors:0 dropped:0 overruns:0 frame:0
TX packets: 4734 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5252764 (5.0 Mib) TX bytes:5252764 (5.0 Mib)

virbr0 Link encap:Ethernet HWaddr: 00:00:00:00:00:00
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets: 0 errors:0 dropped:0 overruns:0 frame:0
TX packets: 35 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:7550 (7.3 Kib)

wlan0 Link encap:Ethernet HWaddr: 00:0D:88:93:3E1
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets: 0 errors:0 dropped:0 overruns:0 frame:0
TX packets: 0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:10 memory:efdf0000-efe00000

xenbr0 Link encap:Ethernet HWaddr: 00:00:00:00:00:00
inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
UP BROADCAST RUNNING NOARP MTU:1500 Metric:1
RX packets: 0 errors:0 dropped:0 overruns:0 frame:0
TX packets: 0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Whew! once I get the card working, I'm going to get a USB card reader or at least the floppy working, to save typing all this out.

In the meantime, thanks for your help and this is the data I got from the commands. Keep in mind that the problem is most likely something glaringly obvious for someone like yourself, not a subtle error.

(BTW I did turn off my firewall MAC exclusion list).
 
Old 01-17-2008, 06:37 PM   #6
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
So... have you tried

ifup wlan0
 
Old 01-18-2008, 01:45 PM   #7
Bad_Mouse
LQ Newbie
 
Registered: Jan 2008
Location: Surrey England
Distribution: Centos 5.1
Posts: 6

Original Poster
Rep: Reputation: 0
(sorry about the delay - just got home I think I work in a different timezone).

I did

ifup wlan0

and got this:

/sbin/ifup: configuration for wlan0 not found.

The iwconfig output still shows all the output - the machine has not been powered off or restarted in between. Does this mean a config file is somewhere else? (and not in /sbin/ifup?)

Last edited by Bad_Mouse; 01-18-2008 at 01:48 PM.
 
Old 01-19-2008, 02:59 AM   #8
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
iwconfig wlan0 up
 
Old 01-19-2008, 04:40 AM   #9
Bad_Mouse
LQ Newbie
 
Registered: Jan 2008
Location: Surrey England
Distribution: Centos 5.1
Posts: 6

Original Poster
Rep: Reputation: 0
I entered the command and got no response - I thinnk it worked, no error messages and back to the prompt.

Still can't see anything in Firefox when I try some URLs, though.

ifconfig is still showing a status of:

UP BROADCAST MULTICAST

for the wlan0 interface, so it looks klike it is activated. I found my firewall was set to exclude http traffic so I set it to allow it WWW, then even better I turned it off. (This is a test machine, I'll risk it until it is connected). Still no joy, though. Firefox says "Server not found".

I don't know if this is important, but the system log has a bunch of messages which sem to be saying it can't get a DHCP client:

localhost dhclient: NoDHCPOFFERS received.
localhost dhclient: No working leases in persistent database - sleeping.

I am at home for the weekend so I will poke around a bit, but I will be watching out in case you have time to give any advice, thanks.

When I did the ndiswrapper install, there was a warning that I might need to recompile the kernel to allow 4k stack size. Don't know if that's important.
 
Old 01-19-2008, 05:19 AM   #10
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
No DHCP would certainly stop internet... your access point needs to be running a DHCP server - that is, you are not using a static IP. I notice that wlan0 has been assigned an inet address in your previous posts. How was it getting this?

iwconfig wlan0 down (see what changes)

In your panel there is a network applet (if not, put one there).
Have a look what it lets you do.

It's been a while since I had anything redhat on my desk... normally, to configure the wireless connection one would:
http://web.mit.edu/ist/products/redh...connected.html

Red Hat Menu > System Settings > Network
<enter password>
select "hardware" tab
select card

from your previous posts, I understand that you tried this and your card wasn't in the list. Is this correct?
 
Old 01-19-2008, 09:48 AM   #11
Bad_Mouse
LQ Newbie
 
Registered: Jan 2008
Location: Surrey England
Distribution: Centos 5.1
Posts: 6

Original Poster
Rep: Reputation: 0
On the setup for the wireless server I see it is acting as a DHCP server.
The checkbox called "Use router as DHCP server" is checked, with starting IP address set to 192.168.0.2 and ending address 192.168.0.254

The router has an address of 192.168.0.1

The address on the stats is a 192.168.x address, that is to say it is not an Internet / WAN address; addresses in this range are for internal use on a LAN and are not used on the internet / outside of a LAN, so I think it is assigning that address itself somehow? (I'm guessing here).

On the router it can see my XP box and our PS3 but it is not listing the Linux box. (Not yet, I should say.)

-- (the above situation has now changed) --

Woo hoo success!

- I started the services "NetworkManager" and "WPA Supplicant".
- Then the network icon at the top right (I'm running GNOME, was default desktpo with Centos) had a red line through it, but when I clicked on it, it listed the wireless networks available.
- I chose my one, entered my WPA password which it asked for,
- was prompted to create a keyring password,

-then suddenly a ton of messages appeared in the system log, the hard drive was busy and bingo!

Now Firefox is working fine, I can ping anything, surf the web and everything is hunky dory.

My next task is how to make these changes permanent so they happen at boot-up time. I think there is some stuff in the NDISwrapper install about this, I will check that out. (If you know of a "howto" or similar then do let me know, but if you don't have one handy, not to worry, yet.)


To answer your last question (and for anyone else reading this), the answer is yes. I tried the procedure from the manual/installation guide.

The problem I found was that although the Network admin GUI (Menu System --> Administration --> network) does display a handy tabbed GUI with everything you would want to set up, it does not show the connection I have set up with ndiswrapper - and still does not show it (no connection, no card) even now it is working, the card is defined, the connection as well, etc.

I'd love to use the network GUI, but in order to create any connection (wireless or ethernet or add a hardware Network Interface Card), first off you have to choose you type of card from their drop-down list. There is no "other" option listed.

Since most ethernet cards are not listed there, this stops you using the network GUI.

I suspect there are some config files underneath the GUI, I might dig around and see if I can fool it into displaying my card, connection and config, now it is all working. Having a GUI admin option would be good for lazy people like me, although it has been great to learn all the command-line commands on the way. Every time you have mentioned a command like iwconfig, I go to the MAN pages and read up on it - this has been a good learning experience for me.

** Anyway, most important: ** Thank you very much for your time and help, this was greatly appreciated. I have to say the generous help given so freely on these forums, is nothing short of incredible. Keep up the good work, this is much appreciated!

Last edited by Bad_Mouse; 01-19-2008 at 09:52 AM.
 
Old 01-21-2008, 02:51 AM   #12
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
I started the services "NetworkManager" and "WPA Supplicant"
Well yes, having the services disabled would also have this effect

Well spotted... CentOS has the same services dialog that RHEL has, you check the radio boxes.
The cli for starting services the redhat way is

/etc/something/service start

(Sorry about the "something" but I don't have a redhat machine handy )

Any CLI thing you need can be added to the end of /etc/rc.local which will run at login.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Step-By-Step Record: Installing Ndiswrapper/card on FC5 Sam Liu Linux - Wireless Networking 1 11-15-2006 10:40 AM
Need step-by-step instructions for ndiswrapper installation sheruty Linux - Wireless Networking 7 06-01-2006 11:51 PM
radio card works.. final step help needed... Adrian Baker Suse/Novell 3 01-11-2006 04:36 PM
final step to wifi? unholy Linux - Wireless Networking 8 12-19-2004 10:14 AM
The Fourth and Final Step... Plz Hlp kaz4u2dig Linux - Newbie 4 05-05-2004 12:22 AM


All times are GMT -5. The time now is 07:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration