LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   RHEL5 just recognize 2GB after upgrade to 8GB RAM (http://www.linuxquestions.org/questions/red-hat-31/rhel5-just-recognize-2gb-after-upgrade-to-8gb-ram-647917/)

phuongtqh 06-08-2008 11:58 PM

RHEL5 just recognize 2GB after upgrade to 8GB RAM
 
Dear linux's users,

I installed RHEL5 on Fujitsu Siemens Server TX600 S3 with 2GB RAM. I have just upgraded to 8GB RAM.
After upgraded, I checked in BIOS,and saw 8GB RAM. But the RHEL5 just recognize 2GB RAM.
Some information:

# dmesg | head -4
Linux version 2.6.18-8.el5 (brewbuilder@ls20-bc2-14.build.redhat.com) (gcc version 4.1.1 20070105 (Red Hat 4.1.1-52)) #1 SMP Fri Jan 26 14:15:21 EST 2007
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 0000000000100000 (reserved)

# head -1 /proc/meminfo
MemTotal: 2053072 kB
[root@db ~]# free -m
total used free shared buffers cached
Mem: 2004 1878 126 0 2 449
-/+ buffers/cache: 1426 578
Swap: 4094 0 4094

Anybody experienced with this problem, please help me.
Thank you in advance.

jtshaw 06-09-2008 12:12 AM

If you are using the 32bit version of RHEL5 you will need to using the kernel-PAE (Physical Address Extension) kernel to get 8GB of RAM I believe. Also check your grub config to make sure it did put a hard coded mem line in when you did the initial install that is telling it to only use 2GB.

If your using the x86-64 kernel then PAE shouldn't be necessary.... but still check for the mem arguement in your grub config.

phuongtqh 06-09-2008 05:52 AM

Hi Jtshaw,

Thank you very much for your reply. Here is my grub config:

# cat /boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/sda5
# initrd /initrd-version.img
#boot=/dev/sda
default=1
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux Server (2.6.18-8.el5xen)
root (hd0,1)
kernel /xen.gz-2.6.18-8.el5
module /vmlinuz-2.6.18-8.el5xen ro root=LABEL=/ rhgb quiet
module /initrd-2.6.18-8.el5xen.img
title Red Hat Enterprise Linux Server-base (2.6.18-8.el5)
root (hd0,1)
kernel /vmlinuz-2.6.18-8.el5 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.18-8.el5.img
title Other
rootnoverify (hd0,0)
chainloader +1

I didn't see any line concerned with hard coded mem line.
I think at least RHEL5 must recognize 4GB. Are there any config files about memory setting?

Vit77 06-09-2008 07:15 AM

As a variant, append mem=4096M to the end of kernel line of grub.conf.
Has the size of memory changed?

Another advice: check your kernel for CONFIG_HIGHMEM64G=y.

linux4shakir 09-09-2009 09:38 AM

Quote:

Originally Posted by jtshaw (Post 3178872)
If you are using the 32bit version of RHEL5 you will need to using the kernel-PAE (Physical Address Extension) kernel to get 8GB of RAM I believe. Also check your grub config to make sure it did put a hard coded mem line in when you did the initial install that is telling it to only use 2GB.

If your using the x86-64 kernel then PAE shouldn't be necessary.... but still check for the mem arguement in your grub config.

Hi,

the same problem is with me.I have RHEL 5 32bit server, i have upgrated its memory from 4GB to 8 GB but it showing arround 4GB as i have paste the output below.
as you suggest to using kernel-PAE, but i am not able to using kernel-PAE as i dont have RHEL 5 licence version. and this package is not available in my linux box. can you help me in this...As i am new to linux can u tell me step by step.

[root@IONDELVM33 ~]# head /proc/meminfo
MemTotal: 3894208 kB
MemFree: 150144 kB
Buffers: 144864 kB
Cached: 2932124 kB
SwapCached: 0 kB
Active: 1744268 kB
Inactive: 1854244 kB
HighTotal: 3014592 kB
HighFree: 25176 kB
LowTotal: 879616 kB


Thanks in advance,
Shakir

johnsfine 09-09-2009 10:12 AM

That is a strange amount of memory being reported in /proc/meminfo. It is more than you would expect if you don't have PAE support in your kernel but far less than the total ram you think you have installed.

Maybe the restriction is some redhat licensing issue. I don't know anything about redhat licensing. Do you depend on redhat support? If so, maybe you need to ask them this question, rather than ask LQ. If not, then you may be better off switching at least your kernel and maybe your whole install to Centos.

But first, I think you should verify that the problem is not in the BIOS or motherboard. For that, you should post the BIOS physical RAM map. If it hasn't been so long since the last boot that the log overflowed, you can see that map with
Code:

dmesg | less
Notice the OP posted the beginning (the useless part) of the map. We need to see the whole thing (all those lines tagged BIOS-e820) to know whether the issue is in the BIOS/motherboard vs. in Linux.

chrism01 09-10-2009 01:40 AM

I think you'll find this informative.
http://kbase.redhat.com/faq/docs/DOC-6571
If you don't have RHEL license, you should (iirc) still find the PAE option on the install DVD.
Also, (as you REALLY should) try to keep up with security etc updates by either
1. buy a license
OR
2. get Centos (free equiv)

johnsfine 09-10-2009 07:21 AM

Quote:

Originally Posted by chrism01 (Post 3676894)
I think you'll find this informative.
http://kbase.redhat.com/faq/docs/DOC-6571

That page explain the virtual memory limits per process. But the question was about the physical memory limits for the whole system.

Quote:

If you don't have RHEL license,
On reread, I think I misunderstood that detail in Shakir's post. I misread that as not having the right version of the RHEL license, but I guess it does mean not having any RHEL license at all.

Quote:

you should (iirc) still find the PAE option on the install DVD.
Notice the value quoted
Code:

MemTotal: 3894208 kB
Few, if any, motherboards can allow MemTotal that high with a 32 bit non PAE kernel. So more likely, Shakir already has a PAE kernel installed. Then something else is wrong which prevents use of the full 8GB of ram.

Quote:

Also, (as you REALLY should) try to keep up with security etc updates by either
1. buy a license
OR
2. get Centos (free equiv)
I don't understand why anyone would run unlicensed RHEL. Was the install DVD available somewhere / somehow that much easier than downloading and burning a Centos install DVD?

I think the free support any Centos user can get in this (Red Hat) subforum of LQ is better than the support redhat users pay for. If I'm wrong about that, maybe buying an RHEL license is a good idea. I think switching to Centos is a better idea. Struggling with any license issues in RHEL is pointless. It isn't that hard to switch to Centos.

chrism01 09-11-2009 01:15 AM

Re unlicensed RHEL; typically one of 3 scenarios

1. user had the 30 day free trial and never upgraded after 30 days expired
2. DVDs get passed around like anything else
3. user has license for prod servers, but not for dev/test ... it happens.

Generally I'd go Centos, but for a serious user (ie commercial or org) might be worth having licensed RHEL for more obscure stuff; think kernel panics for example. Also, speed of response.
Of course there's always the corporate rule that you must have official support.

Mistoffeles 09-14-2009 02:56 PM

Quote:

Originally Posted by johnsfine (Post 3677168)
Few, if any, motherboards can allow MemTotal that high with a 32 bit non PAE kernel. So more likely, Shakir already has a PAE kernel installed. Then something else is wrong which prevents use of the full 8GB of ram.

I am pretty sure no 32-bit OS can see memory above 4GB without PAE extensions, regardless of what motherboard they use. Depending on the way the memory banks are set up in phuongtqh's computer, this may be another hurdle in the hardware that is limiting him to just 2GB rather than giving him the full 4GB. If it were not a server I would guess he is eating all his high memory (below 4GB) with video cards, but most servers don't support dual cards (it would take two 768MB-1GB cards to use up that much).

Regardless, you must use PAE or 64-bit to use more than 4GB of RAM, there are no exceptions that I know of to this, it's just not possible to do it on a vanilla (non-PAE) 32-bit OS.

Personally, I would never use PAE again. There are enough silly games going on inside Intel's CPUs already without adding another whole layer of smoke and mirrors (remember segmented addressing on early x86 CPUs?).

Edit: Also try running MemTest (64-bit of course) to see if the 8GB reported in the hardware is actually available and working.

johnsfine 09-14-2009 03:27 PM

Quote:

Originally Posted by Mistoffeles (Post 3682612)
this may be another hurdle in the hardware that is limiting him to just 2GB

The 2GB problem belonged to the OP who left this thread a year ago.

The new question, last week (from another poster who seems to have left the thread) was a very different problem (though I can see how a beginner might think it similar enough to justify asking in the old thread).

I think no more help is required here until someone requests some.


All times are GMT -5. The time now is 08:42 PM.