LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-10-2007, 09:28 AM   #1
deadlock
Member
 
Registered: Apr 2003
Distribution: Red Hat
Posts: 65

Rep: Reputation: 15
Question RHEL4 ES VNC Issues


Not the usual VNC issue as to all appearances it's working fine - can connect, use terminal, browse internet, change background etc...

However, if I want to use any of the system-config-* applications such as packages, nothing happens.

If logged in as a non-root user I get the authorisation box, then nothing...

From terminal, after su-ing to root I get the following error:
Code:
[root@server ~]# system-config-packages
Xlib: connection to "server.company.com:1.0" refused by server
Xlib: No protocol specified

Unable to import gtk module. This may be due to running without DISPLAY set. Exception was:
could not open display
Edit:
This is only an issue from boot - performing a manual vncserver restart seems to sort things out...

Any suggestions? It's a bit of a bind having to trot off to the server room whenever I need to use a gui app...

Last edited by deadlock; 12-10-2007 at 09:52 AM.
 
Old 12-26-2007, 04:55 AM   #2
ingerul9
Member
 
Registered: Jan 2007
Posts: 35

Rep: Reputation: 15
I may be a bit off here. Does your X start when it boots?
 
Old 01-03-2008, 03:12 AM   #3
deadlock
Member
 
Registered: Apr 2003
Distribution: Red Hat
Posts: 65

Original Poster
Rep: Reputation: 15
Everything starts and appears to be as normal when going in for the first time, just the Redhat admin apps fail to authorise until the vncserver is restarted...
 
  


Reply

Tags
redhat, vnc, xlib


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rhel4 vnc problem, where to configure GUI vnc server? hocheetiong Linux - Newbie 1 10-24-2007 06:05 AM
Apache 2.0/SSL issues RHEL4. misconfiguration Linux - Enterprise 3 08-01-2007 11:20 PM
PS/2 Keyboard and Mouse Issues with RHEL4 rjcarr Red Hat 3 08-13-2006 10:02 AM
VNC issues jtapiaRedHat Linux - Newbie 6 02-11-2006 09:57 AM
VNC issues in RH 8.0 glockfan Linux - Software 0 01-23-2003 12:03 PM


All times are GMT -5. The time now is 01:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration