LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 11-18-2012, 06:31 PM   #1
mijohnst
Member
 
Registered: Nov 2003
Location: Huntsville, AL
Distribution: RHEL, Solaris, OSX, SuSE
Posts: 401

Rep: Reputation: 31
RHEL 6 - Disable Gnome DVD Automount


I'm trying to figure out how to stop Gnome from automounting any CD or DVD that goes in the drive. In RHEL5 it was done by adding the following key pairs to the GDM repository.

Code:
/usr/bin/gconftool-2 --direct \
--config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory \ 
--type bool --set /desktop/gnome/volume_manage/automount_media false
/usr/bin/gconftool-2 --direct \
--config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory \
--type bool --set /desktop/gnome/volume_manager/automount_drives false
Apparently that that doesn't work in RHEL6 and those key pairs are not even there anymore. Those configuration lines above run on 6 and the pairs are added, but they do not work. Thanks for the support!
 
Old 11-18-2012, 06:43 PM   #2
mijohnst
Member
 
Registered: Nov 2003
Location: Huntsville, AL
Distribution: RHEL, Solaris, OSX, SuSE
Posts: 401

Original Poster
Rep: Reputation: 31
Ok, I solved my own problem. They just moved it to a different section and renamed the key pairs. You only need to run the first command in this list but it doesn't hurt to be safe.

Code:
/usr/bin/gconftool-2 --direct \
--config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory \
--type bool --set /apps/nautilus/preferences/media_automount false
/usr/bin/gconftool-2 --direct \
--config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory \
--type bool --set /apps/nautilus/preferences/media_automount_open false
/usr/bin/gconftool-2 --direct \
--config-source xml:readwrite:/etc/gconf/gconf.xml.mandatory \
--type bool --set /apps/nautilus/preferences/media_automount_never true
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CD/DVD/Flash automount like in Gnome by default Mr. Alex Linux - Hardware 1 04-01-2011 07:47 AM
Disable automount under xfce cccc Debian 2 03-09-2011 05:12 PM
[SOLVED] Ubuntu Disable automount izghitu Linux - Software 3 07-19-2010 08:07 AM
Disable automount for speciffic DVD writer in SuSE 10.0 lpwevers Linux - Hardware 2 03-21-2007 08:18 AM
Disable automount zokik Linux - General 5 12-07-2003 06:59 AM


All times are GMT -5. The time now is 12:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration