LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 07-01-2007, 09:45 AM   #1
rkmason
LQ Newbie
 
Registered: Dec 2005
Location: Austin, Tx
Distribution: Ubuntu 9.10
Posts: 25

Rep: Reputation: 15
RHEL 5 w/ Gnome - How to set 32 bit Firefox as default browser?


I just installed RHEL 5 Desktop x86_64 using Gnome as the Desktop Manager.

It works fine with one exception - the Gnome default browser is the 64 bit Firefox version. My ISP's homepage needs to use the Flash plugin to work properly. There is not yet a 64 bit Flash plugin version so I want to run 32 bit Firefox as my default browser (the one that runs when you pick the browser icon on the toolbar). I have 32 bit Firefox installed and I can run it from a launcher icon on my desktop, but I want to set it as the default that runs from the toolbar icon.

I've looked at the Preferred Applications utility and the "htmlview" script called by it but I can't determine how the Gnome default browser is established. Any ideas about where I should look? Thanks
 
Old 07-01-2007, 10:05 AM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,705
Blog Entries: 1

Rep: Reputation: 220Reputation: 220Reputation: 220
One option is to remove the 64-bit version. You really don't need both anyway. The other option is System --> Preferences --> Preferred Applications and then select the 32-bit version of Firefox. Might require you to select Custom and enter the command to launch Firefox 32-bit. You could get the correct command from the Properties tab of the panel launcher.
 
Old 07-01-2007, 10:42 AM   #3
rkmason
LQ Newbie
 
Registered: Dec 2005
Location: Austin, Tx
Distribution: Ubuntu 9.10
Posts: 25

Original Poster
Rep: Reputation: 15
Weibullguy had the Fix!

You are "the man" Weibullguy, Thanks!

I went into Preferred Applications and selected "custom" as the default browser choice. I used "/usr/lib/firefox-1.5.0.12/firefox" as the command and now my default browser is the 32 bit version (64 bit version is at "/usr/lib64/firefox-1.5.0.12/firefox").

I had previously removed the 64 bit version Firefox and had everything working the way I wanted, but I installed a package that had 64 bit Firefox as a prerequisite and that put me back into this problem. I needed to make the 32 and 64 bit Firefox versions coexist without causing me problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't set Firefox as default browser under Mandrake/kde Gustavoang Mandriva 1 09-19-2005 01:18 PM
set firefox as default web browser Knowledgements Slackware 10 07-25-2005 07:54 AM
Unable to set preferred browser to Firefox: FC3/Gnome essdeeay Linux - Software 1 04-04-2005 05:05 AM
How do i set firefox as default web browser in 10.1 official rockmeisster Mandriva 4 12-24-2004 11:12 AM
FireFox as default browser lcdial Linux - Software 19 09-12-2004 11:43 PM


All times are GMT -5. The time now is 04:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration