LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 11-19-2009, 03:27 AM   #1
Deathkarr
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Rep: Reputation: 0
Exclamation RHEL 5 server / client problem


Hi all

I've been recently setting up a RHEL5 server and I have run into some problems. I can't ping the server's ip address. I have set static ip to 192.168.0.1 . Though when I go to ping the network I get a response telling me to try ping -b. I do that and I get no response. Though the server can ping to the client machines. Here's my static ip configuration:

Static IP Address: 192.168.0.1
Netmask: 255.255.255.0
Gateway: 10.10.0.1

Hostname: homer.simpson.org
Primry DNS: 192.168.0.1


If this helps the server has dhcpd running. The client machine runs Fedora 8.


I really need to get this problem fixed so that I can finish off LDAP.

Thanks in advance
 
Old 11-19-2009, 05:15 AM   #2
centauricw
Member
 
Registered: Dec 2005
Location: Lawrenceville GA
Distribution: Slackware, CentOS. Red Hat Enterprise Linux
Posts: 216

Rep: Reputation: 31
Your static IP and the gateway are on two different subnets. The gateway IP needs to be on the 192.168.0.0/24 subnet or you need to re-IP the server to be on the 10.10.0.0/?? subnet.
 
Old 11-19-2009, 07:40 AM   #3
Deathkarr
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Original Poster
Rep: Reputation: 0
Thankyou very much. I'll try it tomorrow and let you know how everything goes.
 
Old 11-20-2009, 03:00 AM   #4
chiragrk
Member
 
Registered: Nov 2009
Location: India
Distribution: Xandros, Ubuntu
Posts: 74

Rep: Reputation: 16
You definitely need to correct that Gateway IP address. However, just as a FYI, if you're pinging any host in your network say 192.168.0.2, it should have pinged - gateway IP address is irrelevant to reach a machine which is within your subnet.
 
Old 02-02-2010, 03:49 AM   #5
Deathkarr
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Original Poster
Rep: Reputation: 0
Question

Sorry I haven't replied for ages but I have been doing a lot of configurations on the server like openldap and stuff like that. Changed it and just to clarify does that mean that I would now have to ping 192.168.0.1/24. Plus if i was testing to see if i could mount an nfs folder on a client machine would i have to change the following command:

mount 192.168.0.1:/home /home/ to

mount 192.168.0.1/24:/home /home/
 
Old 02-02-2010, 05:38 AM   #6
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Can you now ping Server from Client and vice versa?

If you can, setting up nfs share and accessing it from Client is not to much complicated. I even set up automounting nfs share for my notebook.
 
Old 02-02-2010, 09:00 PM   #7
Deathkarr
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Original Poster
Rep: Reputation: 0
No. the ping returns network host unreachable or it returns ping -b. Which is why i thought you would need to add the /24 .
 
Old 02-02-2010, 10:08 PM   #8
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Then you need to learn a networking one-on-one. I sugest you visit www.tldp.org and read few manuals and howto's

Using the 192.168.0.x subnet, set it this way:
Server:
IP: 192.168.0.1
netmask 255.255.255.0
gateway: 192.168.0.Y (where Y is numer of your network gateway/router to get outside of that subnet). this not necessary for now.

Client: 192.168.0.2
netmask 255.255.255.0
gateway: 192.168.0.Y (where Y is numer of your network gateway/router to get outside of that subnet). this not necessary for now.

Run as root "service network restart" on the Server (and on the client if you use Linux).

Now to ping client from server PC, run: "ping 192.168.0.2", and from the client type "ping 192.168.0.1". If you are not getting anything, you have something wrongly setup, either software or hardware.

Be aware that if you connect 2 PC's directly, without a network switch, you need to use crossover LAN cable.
 
Old 02-03-2010, 04:02 AM   #9
Deathkarr
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Original Poster
Rep: Reputation: 0
Accidentally posted twice ignore this reply

Last edited by Deathkarr; 02-03-2010 at 04:24 AM.
 
Old 02-03-2010, 04:03 AM   #10
Deathkarr
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Original Poster
Rep: Reputation: 0
My server is a dhcp server so I shouldn't neet to make a static ip for my client. Wouldn't this mean that my ip address for the server 192.168.0.1 will also be the Default gateway address. The network will have no internet

Last edited by Deathkarr; 02-03-2010 at 04:37 AM.
 
Old 02-03-2010, 04:54 AM   #11
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Yes, if your server acts as DHCP server PROPERLY, and you DO NOT have any OTHER DHCP server plugged in that physical network, it will. But since you are unable to ping between client and server, I suggest you set it up manually as I told you, so we can debug this problem.

Removing unknown variables is the best way to do that, and your networking knowledge is so low I can not rely you set that DHCP server properly.

By the way, 192.168.0.1/24 (or 192.168.0.1/255.255.255.0) is not proper IP address to use, that is logical representation of the IP, meaning IP/netmask since /24 replaces "255.255.255.0"

Last edited by DrLove73; 02-03-2010 at 04:56 AM.
 
Old 02-03-2010, 06:41 AM   #12
Deathkarr
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Original Poster
Rep: Reputation: 0
I think that my option router in the dhcpd.conf file might not be 192.168.0.1. Though if it was I would turn off the dhcp service and make the client and server both static using the settings you previously said. But would I leave the gateway blank or should I put in 192.168.0.1 for both server and client.

Both of my machines are Linux. I'm just using windows as a way to communicate to you guys.
 
Old 02-03-2010, 12:17 PM   #13
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Then take a look at your Network settings in Windows and just change IP for both server and client. You can use last number in IP address from 1-254, but I recommend 200 (192.168.1.200) for server and 201 (192.168.1.200) for client. Also, if you use router with DHCP, then both Linux units should be able to access internet when left in Automatic IP mode.

There is a possibility that you overlap 192.168.0.1 on your server with routers IP, so change IP's for both Linux-es as above and use gateway that Windows set's on his connection.
 
Old 02-03-2010, 05:31 PM   #14
Deathkarr
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Original Poster
Rep: Reputation: 0
I'm not understanding. Should i change option routers to server ip address. I also need to keep the server ip at 192.168.0.1 cause that's what i have my clients connect to for ldap.

Let me explain my network a bit better I have about 3 client machines all running linux and one server running rhel5. I have a network switch which connects to a larger switch and I can't get internet on the machines. I use the Windows machines to get internet help like through forums. The windows machines are not connected to the network

Last edited by Deathkarr; 02-03-2010 at 05:59 PM.
 
Old 02-03-2010, 07:45 PM   #15
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Umph. What is the IP of the router/gateway facing internet that is connected to your Linux network? If it is 192.168.0.1, then you have problem since the same IP is used for server.

Something bothers me. DO you or don't you have connection between clients and Server? Can you ping Server from clients? You are too much confusing to understand.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing VLC in RHEL 5.1 Client RedHatGuru Linux - Enterprise 4 01-19-2009 03:56 AM
Solaris 10 with DSEE 6.2 as ldap server and RHEL 5.1 as Openldap client al.lmco Linux - Newbie 1 07-04-2008 06:28 AM
RHEL 4 client in VMware not binding to NIS server. panini.kompella Linux - Newbie 0 03-17-2008 05:10 AM
RHEL 4 client in VMware not binding to NIS server. Ping works fine and NIS server wo panini.kompella Linux - Server 1 03-17-2008 12:06 AM
Login problems with XDMCP from a pre-RHEL-4 client to a RHEL-4 server running KDE cspao Red Hat 0 07-21-2006 07:30 AM


All times are GMT -5. The time now is 01:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration