LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-09-2009, 03:38 PM   #1
protos78
LQ Newbie
 
Registered: Feb 2009
Posts: 10

Rep: Reputation: 0
RHEL 5.3 Hangs when yum, rpm or df -h is run


We have Red Hat Enterprise Linux Server release 5.3. For the last two weeks, the server started not to respond "df -h", rpm and yum requests. Here is an example of yum package installation.

[root@helios tmp]# yum install sysstat
Loaded plugins: rhnplugin, security
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package sysstat.x86_64 0:7.0.2-3.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================ Package Arch Version Repository Size
================================================================================Installing:
sysstat x86_64 7.0.2-3.el5 rhel-x86_64-server-5 174 k

Transaction Summary
================================================================================Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 174 k
Is this ok [y/N]: y
Downloading Packages:
sysstat-7.0.2-3.el5.x86_64.rpm | 174 kB 00:00
Running rpm_check_debug
Running Transaction Test
Killed
(I killed the process. I waited for more than2 hours. This should be done instantly. )

If I run, df -h, it shows some of the mounted drives and hangs. Waited for more than 12 hours, nothing happened. I checked the system log, and there is no error message. It would be great if you can tell me how I can diagnose the issue?

Thanks,
 
Old 12-09-2009, 04:56 PM   #2
protos78
LQ Newbie
 
Registered: Feb 2009
Posts: 10

Original Poster
Rep: Reputation: 0
I solved the issue. THe problem was stale nfs mounts. I first checked /etc/mtab and removed the stale nfs mounts. Then, commented stale nfs mounts at /etc/fstab. Restarted nfs client. Mounted drives again. Rebuild rpm databases. Bingo, it works!!!
 
Old 12-09-2009, 06:17 PM   #3
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 808

Rep: Reputation: 104Reputation: 104
Ah, thanks for sharing that. As a matter of fact, I had the same problem, and I didn't realized that having a stale NFS mount would do that.
 
Old 12-10-2009, 04:32 AM   #4
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
When you have stale NFS mounts in fstab, or no connection to NFS server, even booting will take forever. Just a week ago I have disabled NFS from fstab and set it via autofs.

The trick I used to be able to see autofs mounts from krusader (ls and others open them without a problem but file managers can not see them) is to mount them all in some other folder then desired one, and then (while mounted via ls) create a softlink (symlink) in the location where you want it to be. That way you can double click on the softlink and have autofs mounted NFS folders from file manager.

Procedure:

My server will be caled vmaster, with export named "extra". Example uses nfs4 because of the firewall friendly caracteristics. Mount point will be /vmaster/extra.

1. I created folder /autofsmounts and within that folder a subfolder called "vmaster".
2. I added following line in /etc/auto.master:
Code:
/autofsmounts/vmaster  /etc/auto.vmaster --timeout=90
3. I created a file called /etc/auto.vmaster with following content:
Code:
#
# $Id: auto.misc,v 1.2 2003/09/29 08:22:35 raven Exp $
#
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

extra	-fstype=nfs4,rw,proto=tcp	vmaster:/extra
4.Then I executed following command from terminal:
Code:
ls /autofsmounts/vmaster/extra
.

5. After that, I created "/vmaster" folder and created symlink of /autofsmounts/vmaster/extra folder in "/vmaster" folder (/vmaster/extra).

Now I have NFS mount point visible all the time from file managers like krusader, but mounted only when they are needed. On boot this mount is not checked hence there is no freezing if mount is unaccessible.

Last edited by DrLove73; 12-10-2009 at 05:05 AM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] using rhel/centos 5 without connection to the internet (yum/rpm question) deadeyes Red Hat 3 10-16-2009 07:36 PM
Rpm & yum "unsupported hash version: 8" error on RHEL 5.1 Muddoll Red Hat 4 02-12-2009 05:40 AM
RPM Hangs on RHEL 3 Ziggie Linux - Enterprise 7 12-04-2008 10:10 AM
Problem With Yum and RPM in RHEL Client 5 kaplan71 Red Hat 1 11-07-2007 09:01 AM
rpm and Yum Hangs cryzpene Linux - Newbie 0 05-25-2004 09:07 PM


All times are GMT -5. The time now is 07:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration