LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-08-2003, 07:06 PM   #1
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
Resolution Problems


Hello,
I just installed red hat 9 (first linux experince) and can only run it on a 640x480 resolutition, which is annoying to say the least. Whenever I change it and reboot i just get a blank screen when the computer trys to load the red hat GUI. Also when I was begining the installation my monitor would bring a screen up that said "Out of frequency. HF 23.9kHz, VF 38.0 Hz Opperating frequency: HF 30-71kHz, VF 50-160Hz" at which point the monitor would power down and I would have to reboot. I have a S3 ProSavageDDR video card and a LG Flatron T710BH monitor and am runing a dual-boot windows XP and Red Hat 9 system.

Any help would be greatly appreciated.
Thanks
 
Old 12-08-2003, 07:14 PM   #2
simbo
LQ Newbie
 
Registered: Apr 2003
Posts: 17

Rep: Reputation: 0
Smile

Hi mate,
Fellow newbie here with you, I have posted about startx problems thats the thread name, anyways I think you have to look at the XF86Config or XF86Config-4 file in /etc/X11 or /usr/X11R6/etc/X11 or /usr/X11R6/lib and check out the monitor section, I think thats where the VSYNC and HSYNC are defined, anyways like I said I'm a newbie so don't take my word for it. Good Luck.

Sim
 
Old 12-08-2003, 07:54 PM   #3
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
That's one way... however you may find it easier to run XFConfig:

1) open a root console (better if under X)
2) backup your /etc/X11/XF86Config-4:
cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4-backup
3) run xf86config
4) when it comes to configuring the monitor, choose expert mode and insert proper frequences (HF 30-71kHz, VF 50-160Hz)
5) choose your preferred video modes (resolutions), then save.
6) logout and restart X (ctrl+alt+backspace). you don't need to reboot
 
Old 12-09-2003, 04:48 AM   #4
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Well thanks for the tips guys, but no dice. I tryed to run XF86Config but it wouldnt work, so i guess i dont have the program. I did find a text file in ect/X11 called XF86Config, and It says my horizantal/verticle frequencys are what they should be, however the only video mode listed was 640x480. I added "1024x768" beside that, saved it and restarted(that works a lot easyer buy the way, thanks) but my monitor just went to standby. Any other thoughts on this little predicamint?
 
Old 12-09-2003, 05:21 AM   #5
ac1980
Member
 
Registered: Aug 2003
Location: Trento, Italy
Distribution: Debian testing
Posts: 394

Rep: Reputation: 30
Note that despite the config file name is XF86Config, the program name is xf86config. Remember unix filenames are case-sensitive.
In my debian the complete path is /usr/X11R6/bin/xf86config
It usually comes boundled with X, so you probably have it.

I would give it a try, since setting wrong values in XF86Config may damage your monitor.
If you are in trouble accessing your system, press ctrl+alt+f1 to go to a console prompt, then restore your XFConfig backup (you did it, didn't you?) or change it back to what it was, then restart your pc - don't really need to, but safer in this case - (shutdown -r now)

If even with c+a+f1 you can't get to the console, don't panic: at boot prompt, start with 'single' option, i.e. if your boot option is called 'Linux' type 'Linux single' to boot prompt. This will bring you to single user console mode (runlevel 1)

Last edited by ac1980; 12-09-2003 at 05:24 AM.
 
Old 12-09-2003, 07:07 AM   #6
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 620

Rep: Reputation: 30
howzit

Once u login and it fails press Ctrl-ALT-F1 login into text mode as root then type the cmd init 3 this will reboot system into text mode. Once there type the cmd redhat-config-xfree86 this will bring up a a GUI version to setup monitor resolution, etc. Remember to choose right setting for refresh rates etc. If does´t work try the above steps again and choose lower settings like thousands of clours instead of millions.

chow
 
Old 12-09-2003, 08:32 PM   #7
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Still nothing guys. I tryed that init 3 command but all i got was "bash: init: command not found", but i ran that redhat-config-xfree86 and tryed different resolutions with lower colour settings without any luck. Also i'm pretty sure I don't have this xf86config program, when i do a locate for it all i get is:
/usr/lib/python2.2/site-packages/ixf86configmodule.so
/usr/lib/python2.2/site-packages/xf86config.py
/usr/lib/python2.2/site-packages/xf86config.pyc
/usr/share/doc/pyxf86config-0.3.5
/usr/share/doc/pyxf86config-0.3.5/ChangeLog
/usr/share/doc/pyxf86config-0.3.5/AUTHORS
/usr/share/doc/pyxf86config-0.3.5/COPYING
/usr/share/doc/pyxf86config-0.3.5/NEWS
/usr/share/doc/pyxf86config-0.3.5/README
 
Old 12-09-2003, 10:39 PM   #8
Technoslave
Member
 
Registered: Dec 2003
Location: Northern VA
Posts: 493

Rep: Reputation: 30
That's because there is no xf86config in a RH9 install. Unless my full install of RH9 with all the bells and whistles is lying to me. There is, however, a redhat-config-xfree86 as previously mentioned. It's located in /usr/bin.

Likewise, there won't be an XF86Config-4 file, you found the right one though, it's called XF86Config.

If you didn't find "init" then there is a slightly more serious problem. init is a root command and should be located in /sbin

( By the way, there is a command called "locate", it's like a quicker form of find, oops just read your post, you know what locate is, to make your locate "find" what you want a little bit better, try doing something like "locate xf86config | grep bin", that way you only find the binary version...assuming of course that it's a program in a bin dir, like it should be. )

Basically, if you want the technical, this is what your /etc/X11/XF86Config should look like where it concerns Monitor, Device, and Screen:

Section "Monitor"
Identifier "Monitor0"
VendorName "LG"
ModelName "Flatron T710BH"
DisplaySize 360 270
HorizSync 30.0 - 71.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "savage"
VendorName "Videocard vendor"
BoardName "S3 ProSavageDDR "
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Don't take my sections as gospel, I had to do some hand editing as I do dual monitors with different drivers and what not.

Some things to look at, using my examples above. Driver...make sure yours is "savage". This is the source of a possible problem. If you don't have a savage driver there, then google "+linux +savage", unless someone else has a better place to look?

Also, make sure your Horz and Vert refresh look like mine, those should be accurate based off of your monitor ( I looked up what they were, just in case )

Also, if you don't plan on switching res with your monitor and your linux box, then just have one resolution set...in my case, it's 1280x1024.

Also, no need to really go to init3...if you're in windowed mode, just hit Ctrl+Alt+Backspace, and that will reboot your windowed mode. If your config is goofed, it'll take just as long for it to tell you it's goofed, as it would if you weren't in it...

Anyway, try the redhat-config-xfree86, then look at doing things manually, as a last resort, or until you feel comfortable.

Last edited by Technoslave; 12-09-2003 at 10:41 PM.
 
Old 12-10-2003, 06:04 PM   #9
Stan the caddy
Member
 
Registered: Dec 2003
Location: Victoria, B.C
Distribution: Slackware
Posts: 61

Original Poster
Rep: Reputation: 15
Well, that config file looks exactaly like mine, except modes in the screen section was set at "640x480", but I had already tried changing that with no luck. However I have fixed the problem, I scraped Red Hat and put on Mandrake 9.2 instead and everythings working great now. Thanks for trying guys.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolution Problems Rick069 Ubuntu 1 06-16-2005 09:53 PM
Resolution Problems ajunt_ornj Mandriva 1 02-26-2005 12:26 PM
Resolution Problems kamransoomro84 Slackware 5 05-20-2004 05:47 PM
Resolution Problems garamatt Linux - General 2 10-14-2003 11:24 PM
resolution problems saturn_vk Slackware 4 03-01-2003 01:29 PM


All times are GMT -5. The time now is 03:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration