LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-22-2004, 03:43 AM   #1
Sailaja Reddy
LQ Newbie
 
Registered: Jul 2004
Location: INDIA
Posts: 14

Rep: Reputation: 0
Redhat9:rpm dependency errors:libasound.so.2,libasound.so.2(ALSA_0.9)


Hi,

I am having redhat linux 9.0 with inbuilt kernel 2.4.20.-8 and installed ALSA 1.0.5. When I am trying to install my own application rpm (which actually uses ALSA 1.0.5 APIs), I am getting the following dependency errors:
[root@aims-pc-100 i386]# rpm -ivh tone-2.Release8_0_1.0-69.i386.rpm
error: Failed dependencies:

libasound.so.2 is needed by tone-2.Release8_0_1.0-69
libasound.so.2(ALSA_0.9) is needed by tone-2.Release8_0_1.0-69
libasound.so.2(ALSA_0.9.0rc4) is needed by tone-2.Release8_0_1.0-69

How do I get rid of these errors?
In spec file nothing of these dependencies defined.

Experts, please help me.

Thanks,
 
Old 06-16-2009, 12:41 PM   #2
Piyush Sachan
LQ Newbie
 
Registered: Apr 2009
Location: Kanpur>U.P.>India
Distribution: RHEL5/4
Posts: 4

Rep: Reputation: 0
Post rpm dependency error

Dependency r failed definitely bcz required files r missing to install the above package. Try this link to download the misssing "lib*" files from here http://rpmfind.net/linux/rpm2html/se...libasound.so.2 OR on
http://rpm.pbone.net/
U have to install the ur previous packages force ably by adding "--nodeps" option like:

rpm -ivh tone-2.Release8_0_1.0-69.i386.rpm --nodeps --force

"--force" option will install it forcefully even though the package is already installed..

Last edited by Piyush Sachan; 06-17-2009 at 10:39 AM.
 
  


Reply

Tags
dependency, error, rpm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
libasound?? SnowSurfAir Linux - Software 5 02-28-2009 10:24 PM
Dependency error : libasound.so.2 pinakidutta Linux - Newbie 1 12-31-2004 06:59 AM
I cant install libasound.so.2 flamah Linux - Newbie 3 11-14-2004 06:27 PM
libasound.la OGreenOLeaf Slackware 2 01-06-2004 10:53 PM
where is libasound DavidPhillips Linux - General 1 06-02-2002 07:24 PM


All times are GMT -5. The time now is 04:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration