LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 01-22-2006, 10:31 PM   #1
ahmedb72
Member
 
Registered: Jan 2006
Location: Sydney
Distribution: RHEL
Posts: 72

Rep: Reputation: 15
Quota management


I have a question about Quota management in RHE 4 AS.

I tried to test the quota control option in Linux, so I followed the following steps:

#edquota -u fuad

I sat the quota setting as follows:
Disk quotas for user fuad (uid 501):
Filesystem blocks soft hard inodes soft hard
/dev/mapper/VolGroup00-LogVol00 16 5000 8000 12 0 0


#edquota -t
Time units may be: days, hours, minutes, or seconds
Filesystem Block grace period Inode grace period
/dev/mapper/VolGroup00-LogVol00 6days 7days


then I logged on as "fuad" and created number of files with sizes greater than his quota. No error generated.


#quotacheck -avugm
quotacheck: Scanning /dev/mapper/VolGroup00-LogVol00
quotacheck: Checked 7511 directories and 74201 files
repquota -a
Block grace time: 6days; Inode grace time: 7days
Block limits File limits
User used soft hard grace used soft hard grace
----------------------------------------------------------------------
fuad +- 19016 5000 8000 6days 12 0 0


the report showed that fuad exceeded his quota, but I thought Linux will prevent him from doing that in first place.

Can you clarify that to me please?
 
Old 01-22-2006, 10:59 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 117Reputation: 117
Did you enable quotas using 'quotaon'?
 
Old 01-22-2006, 11:43 PM   #3
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
True and after executing quotaon I believe you need to run quotacheck to set up the initial quota files. You may also find this thread useful.

Bill
 
Old 01-23-2006, 02:35 AM   #4
ahmedb72
Member
 
Registered: Jan 2006
Location: Sydney
Distribution: RHEL
Posts: 72

Original Poster
Rep: Reputation: 15
hi Matir and wmakowski,

yes.. using quotaon -avug command, it worked just fine.

Thanks alot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What content management or file management software is best for the job? Niceman2005 Linux - Software 2 05-10-2005 10:02 PM
quota jrafalek Linux - Software 2 03-04-2005 01:23 AM
Quota....??? IwantLINUX Linux - Newbie 4 02-09-2005 03:12 PM
ftp quota probs - 0kb files at quota limit ph_xm Linux - Newbie 0 02-02-2005 11:13 AM
Can I enable quota management in root(/)? paranoia1980 Red Hat 4 09-17-2003 11:19 AM


All times are GMT -5. The time now is 06:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration