Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 03-16-2012, 02:40 PM   #1
LQ Newbie
Registered: Feb 2012
Posts: 19

Rep: Reputation: Disabled
PXE kickstart problem with rhel6

We have custom RH5 PXE kickstarts via nfs that work great. Now I'm trying to setup, on the same nfs system, a RH6 PXE KS but I'm running into this error.

The file *.rpm cannot be opened. This is due to a missing file, corrupted package or corrupted media.

The PXE boots, downloads the .cfg file and does everything in there. It then does the "checking dependencies" step successfully, but as soon as it starts to try and install the packages the above message is displayed. I think this is a missing file issue, I can install the rpms from the nfs location, but I don't understand why. I setup the tree like a rh6 dvd, which is different from a rh5 dvd.

How can I troubleshoot this? It would be nice to actually see where the process is looking for the rpms

Old 03-16-2012, 02:53 PM   #2
Senior Member
Registered: Sep 2003
Posts: 1,091

Rep: Reputation: 41
I ran into this a while back unfortunately I do not recall what I did to fix this issue (i think it was nic settings in the pxe file ala eth_options="auto neg off..etc")... however it is not a missing file issue. Try hitting enter a few times to the message and it will move past it and install the file.
Old 03-20-2012, 09:24 AM   #3
LQ Newbie
Registered: Feb 2012
Posts: 19

Original Poster
Rep: Reputation: Disabled
I tried hitting enter several times but it never moved past.

After spending a day of frustration I really think it something to do with creating the repository metadata.

If I take the contents of a rhel 6 iso and add it to my pxe server it works. You can boot to the PXE and install. The problem occurs when I add a custom group to the comps.xml and run createrepo to regenerate the repo metadata.

My PXE server is running rh5 and I was using the createrepo tool on it for the rh6 kickstart.
But I found in the rh6 deployment guide that will not work. Full explanation here

So I built a rh6 system, ran createrepo there and moved everything back to my rh5 pxe server and I got the same result.
What am I missing?
Old 03-20-2012, 11:41 AM   #4
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,939
Blog Entries: 15

Rep: Reputation: 1665Reputation: 1665Reputation: 1665Reputation: 1665Reputation: 1665Reputation: 1665Reputation: 1665Reputation: 1665Reputation: 1665Reputation: 1665Reputation: 1665
Moderator response

Moved: This thread is more suitable in <Red Hat> and has been moved accordingly to help your thread/question get the exposure it deserves.
Old 03-23-2012, 06:10 AM   #5
Registered: Nov 2008
Location: UK
Distribution: RHEL, Fedora
Posts: 68

Rep: Reputation: 12
I rememeber on RHEL5, the directory structure of a repo was

On RHEL6 it is

Then run

# createrepo /path/to/repo


Last edited by mikey99; 03-23-2012 at 06:11 AM.
Old 03-23-2012, 07:43 AM   #6
LQ Newbie
Registered: Feb 2012
Posts: 19

Original Poster
Rep: Reputation: Disabled
Thanks that confirms what I found but it was stated another way.

Instructions for createrepo are not correct when you need to create bootable DVD
path/to/RPMs should be path/to/root/of/DVD


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] PXE booting RHEL6 via Windows SCCM server, kernel problems AndyLandy Linux - Kernel 2 07-21-2011 05:13 AM
PXE install for RHEL6 x86 not working miszum Linux - Networking 8 07-15-2011 10:32 PM
Kickstart installation of RHEL6 thatishari Linux - Server 5 04-27-2011 07:55 AM
RHEL6 Kickstart documentation EricTRA Red Hat 4 01-04-2011 11:34 AM
Strange problem while installing linux using kickstart using pxe asab Linux - Newbie 2 12-17-2010 07:10 PM

All times are GMT -5. The time now is 12:32 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration