LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 11-06-2007, 01:36 PM   #1
kaplan71
Member
 
Registered: Nov 2003
Posts: 718

Rep: Reputation: 39
Problem With Yum and RPM in RHEL Client 5


Hi there --

I have a workstation where the yum and rpm utilities are unable to download and install any packages on the system. When the user accesses the Add/Remove Software GUI, he is presented with a list of packages that are installed on the workstation. However, when he searches for any available package, nothing shows up. Also, the Browse tab appears completely blank even though there should be a listing of groups. I ran the rpm utility with the --initdb and --rebuilddb options, but neither of which seems to have resolved the issue.

I did a check of the yum utility by trying to download the emacs package, and I discovered the system in question is NOT registered with RHN. I know registering the system in question with RHN will solve the yum issue, but will it also resolve the problem with rpm? If not, what other step(s) can I take to enable rpm to work properly? Thanks.
 
Old 11-07-2007, 10:01 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
This may be helpful; http://www.centos.org/modules/newbb/...=8943&forum=37

Yes, I know this is for CentOS-5 but CentOS == RHEL

As a suggestion install the rpmforge-release package as instructed here:

http://dag.wieers.com/rpm/FAQ.php#B

And use yumex instead of pirut (the Add/Remove Software GUI); yum install yumex

This may be another repo to add if desired; http://fedoraproject.org/wiki/EPEL
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 5 yum Problem no RHN subcsription ngrid Linux - Distributions 2 04-16-2010 11:43 AM
problem yum install videolan-client koscek Linux - Software 11 08-02-2007 02:51 PM
Yum / RPM problem deleting mysql-server mperkel Fedora 7 11-14-2006 10:45 PM
Login problems with XDMCP from a pre-RHEL-4 client to a RHEL-4 server running KDE cspao Red Hat 0 07-21-2006 07:30 AM
RHEL 4 RPM package dependency problem tekhed21 Linux - Enterprise 2 01-06-2006 02:18 PM


All times are GMT -5. The time now is 01:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration