LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Problem in Glib installation (http://www.linuxquestions.org/questions/red-hat-31/problem-in-glib-installation-752608/)

comsuite6u2 09-04-2009 05:00 AM

Problem in Glib installation
 
Hi

I am trying to install GTK+-2.16 on RHEL 4.5 with kernel version 2.6.9 . I downloaded "gtk+-2.16.0.tar.bz2", untar it then run ./configure. I got following error message -

---------------
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.19.7 atk >= 1.13.0 pango >= 1.20 cairo >= 1.6) were not met:

No package 'glib-2.0' found
No package 'atk' found
No package 'pango' found
No package 'cairo' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
----------------------

Then I downloaded "glib-2.20.0.tar.bz2" . untar it then run the following in sequence
./configure
make
make install
sbin/ldconfig

It had made glib2.0 folder in followings folder
/usr/local/lib/glib-2.0
/usr/local/include/glib-2.0
/usr/local/share/glib-2.0
and made glib-2.0.pc file in folder
/usr/local/lib/pkgconfig/glib-2.0.pc
I haven't set any PKG_CONFIG_PATH variable because all libraries are installed in default location.
but when I do -
rpm -q glib it displays-
glib-1.2.10-15....(Older Version) although it should show newer file.
Again when I went to gtk and did ./confiure , it shows same message as above ( about glib , pango and atk). I am very much stuck in it.

To solve above problem I again configured glib in different directory as
./configure --prefix=/usr/include
make
make install
sbin/ldconfig
and added line in /etc/profile file as
export PKG_CONFIG_PATH = /usr/include/glib2.0
but above method is also not solving the problem

Prior to that I ahd installed higher version of pkg-config in /usr/pkg-config(User created folder) and made a symbolic link as

ln -s /usr/pkg-config/bin/pkg-config /usr/bin/pkg-config - I did this link to solve an issue related to pkgconfig package.

Please reply ......
Regards
Vivek Gupta

knudfl 09-04-2009 07:25 AM

Welcome to LQ.

First : What is the purpose of gtk-2.16 ?
A lot of applications will work with e.g. version 2.10.
.....

The command to show glib2 :

rpm -qa | grep glib2
... the reply could be ..
glib2-2.4.7-1
glib2-devel-2.4.7-1
evolution28-glib2-devel-2.12.3-6.el4
( and glib2-2.4.7 is always installed )

rpm -qa | grep evolution28-
... shows
evolution28-glib2-2.12.3-6.el4
evolution28-atk-devel-1.12.2-4.el4
evolution28-atk-1.12.2-4.el4
evolution28-glib2-devel-2.12.3-6.el4
evolution28-cairo-1.2.4-6.el4
evolution28-gtk2-2.10.4-22.el4
evolution28-cairo-devel-1.2.4-6.el4
evolution28-pango-devel-1.14.9-11.el4_7
evolution28-pango-1.14.9-11.el4_7

.. So some "new" version are available, with 'yum' or 'up2date'.
.....

comsuite6u2 09-04-2009 12:48 PM

Quote:

Originally Posted by knudfl (Post 3669533)
Welcome to LQ.


First : What is the purpose of gtk-2.16 ?
A lot of applications will work with e.g. version 2.10.
.....

The command to show glib2 :

rpm -qa | grep glib2
... the reply could be ..
glib2-2.4.7-1
glib2-devel-2.4.7-1
evolution28-glib2-devel-2.12.3-6.el4
( and glib2-2.4.7 is always installed )

rpm -qa | grep evolution28-
... shows
evolution28-glib2-2.12.3-6.el4
evolution28-atk-devel-1.12.2-4.el4
evolution28-atk-1.12.2-4.el4
evolution28-glib2-devel-2.12.3-6.el4
evolution28-cairo-1.2.4-6.el4
evolution28-gtk2-2.10.4-22.el4
evolution28-cairo-devel-1.2.4-6.el4
evolution28-pango-devel-1.14.9-11.el4_7
evolution28-pango-1.14.9-11.el4_7

.. So some "new" version are available, with 'yum' or 'up2date'.
.....



Hi knudfl
thanks for replying so fast.Purpose for gtk16 is to have a firefox of version 3.0.X.Since i have to update the firefox so I downloaded firefox source as "firefox-3.0.10-source.tar.bz2" . Untar it as
tar -jxvf firefox-3.0.tar.bz2 in directory /opt then to start the firefox I did the following -
# /opt/firefox/firefox then I got the error that
------
TO start firefox you need a gtk of version 2.10 and you have gtk of version 2.4.
------------
I download gtk from www.gtk.org and did as mention in first posting of this thread.

knudfl 09-04-2009 02:23 PM

No reason to compile / use firefox 3.0.10 .
The latest update is firefox-3.0.12-1.el4 .
So why not use it ?
Please get it with 'yum' or 'up2date'.
If you did not subscribe / pay for 'Redhat Support'
you can just download the package :
http://mirror.centos.org/centos/4.8/...entos.i386.rpm
which is the free version from CentOS 4.8 = RH EL 4.8.
It uses the libs in /usr/evolution28/lib/ :
libgtk-x11-2.0.so.0 , etc. etc.
.....

The dependencies :
http://mirror.centos.org/centos/4.8/updates/i386/RPMS/
evolution28-pango-1.14.9-11.el4_7.i386.rpm

http://mirror.centos.org/centos/4.8/...6/CentOS/RPMS/
evolution28-atk-1.12.2-4.el4.i386.rpm
evolution28-cairo-1.2.4-6.el4.i386.rpm
evolution28-glib2-2.12.3-6.el4.i386.rpm
evolution28-gtk2-2.10.4-25.el4.i386.rpm
.....
P.S.: Even firefox 3.5.x runs perfect on gtk2-2.10, etc.
.....


All times are GMT -5. The time now is 05:17 PM.