LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 04-12-2005, 03:12 AM   #1
abd_bela
Member
 
Registered: Dec 2002
Location: algeria
Distribution: redhat 7.3, debian lenny
Posts: 598

Rep: Reputation: 31
port 25 is closed?


Hi, I just installed the CentOS4.0, (redhat Entreprise based) .
I installed the smail server postfix, configured,
when I test telnet 25, the remote machine doesn't reply ( access refused ) ???
I tried manually the /usr/libexec/postfix/smtpd -D, it failed ,with message , not running by hand
There is no /usr/sbin/smtpd ( maybe it has another name or in another place ???) as in mandrake for example ?

the port 110 ran correcly
telnet server 110 gives the login

please someone can help me, pointing me what are the required soft to run correctly the postfix server

best regards
bela
 
Old 04-12-2005, 05:49 AM   #2
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 620

Rep: Reputation: 30
Howzit

I hope I understood the quetion correctly. Are u telneting to the mail server from the remote box and if yes then u have to enable that port 25 on the FW where the mail server is installed. The easiest way to test this before configuring iptables disable it first then test the telnet connection. To disable FW type service iptables stop. If u not familiar with iptables use redhat-config-securitylevel and configure port 25 to be accessed

cheers
 
Old 04-12-2005, 12:05 PM   #3
abd_bela
Member
 
Registered: Dec 2002
Location: algeria
Distribution: redhat 7.3, debian lenny
Posts: 598

Original Poster
Rep: Reputation: 31
thanks,
but I flushed the iptables and after that I stopped it .
the problem is that sometimes it works and sometimes not, so there is probably a daemon who stops the access

For example I noticed in mandrake 9.0 ( i think, don't really remember the release) /usr/sbin/smtpd with permission only for root, and I fixed the problem by running by hand the smtpd as daemon with -D option.
here there is no smtpd at all !!!!

thanks for replies
best regards
bela
 
Old 04-12-2005, 03:58 PM   #4
cowboy_jake
Member
 
Registered: Apr 2005
Location: Texas
Distribution: RHEL 2.1,3.0,4.0
Posts: 39

Rep: Reputation: 15
A default install of Postfix (or Sendmail) on CentOS 4.0 or RHEL will only be listening on the loopback interface. I think this is a precautionary measure to keep folks from exploiting you as a spam relay or whatever. The fewer open ports, the better.

You can check which interfaces are listening with the following command

# lsof -ni
COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME
sshd 3420 root 3u IPv6 7408 TCP *:ssh (LISTEN)
sendmail 3450 root 4u IPv4 7498 TCP 127.0.0.1:smtp (LISTEN)

in the above example, ssh is listening on all interfaces & sendmail is only listening on the loopback interface.

You can also use the "netstat -l" command to see similar output.

At any rate, you need to edit the Postfix config file to tell it to listen on an interface besides the loopback.

-Jake
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Port to be closed. lancillotto4648 Debian 7 12-09-2004 06:21 AM
is the 25 port closed abd_bela Linux - Networking 5 08-18-2004 08:27 AM
Port 25 Closed karuna Linux - Newbie 0 03-02-2004 02:17 PM
port closed hotrodowner Linux - Networking 2 12-02-2002 05:06 AM
firewall.rc.config says :"open port 8080" but nmap says port is closed saavik Linux - Security 2 02-14-2002 12:16 PM


All times are GMT -5. The time now is 07:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration