LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-31-2003, 06:40 AM   #1
phil81
Member
 
Registered: Jun 2003
Location: France
Distribution: Lenny/sid
Posts: 141

Rep: Reputation: 15
Unhappy php connecting to mysql data base


Hello

I have running

Apache/2.0.40 (Red Hat Linux)

PHP Version 4.2.2

phpmyadmin 2.5.4

php runs fine so does apache

I can set up my databases that run with phpnuke / coppermine + a bunch of other stuff.
using phpmyadmin or in a terminal..

again so far so good ..

NOW when I point my browser to /localhost/phpnuke/index.php or any one of the other data base sites
I just get a blank page ! no error message nothing .

I tried to provoke error messages by putting false information regarding users or pass word in the relevent config.php file But no error message .. still a blank page ..

The only way I can provoke error messages is by leaving data base type blank like this

$dbtype = "";

instead of

$dbtype = "MySQL";



So I gather that php cant connect to a MySQL data base on my computer ..
Is this correct and If so How can I remedy this ..

I looked in php.ini but could not fond any thing yet But still looking

I know its new years eve so you all have a good time tonight

Phil81



Last edited by phil81; 12-31-2003 at 06:43 AM.
 
Old 12-31-2003, 06:44 AM   #2
phil81
Member
 
Registered: Jun 2003
Location: France
Distribution: Lenny/sid
Posts: 141

Original Poster
Rep: Reputation: 15
sorry the provoked error messages are


Warning: Failed opening 'language/lang-.php' for inclusion (include_path='.:/usr/share/pear') in /var/www/html/nuke/mainfile.php on line 79

Warning: Failed opening 'themes//theme.php' for inclusion (include_path='.:/usr/share/pear') in /var/www/html/nuke/header.php on line 31

Fatal error: Call to undefined function: themeheader() in /var/www/html/nuke/header.php on line 47
 
Old 12-31-2003, 07:56 AM   #3
phil81
Member
 
Registered: Jun 2003
Location: France
Distribution: Lenny/sid
Posts: 141

Original Poster
Rep: Reputation: 15
Smile problem fixed

I just uncommented
extension=php_mysql.dll
in php.ini
all is running fine now

thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error connecting to MySQL from PHP anindyanuri Linux - Software 18 04-24-2005 09:30 AM
Connecting to Mysql using PHP mahugl Linux - Software 1 01-31-2004 11:20 AM
I need help connecting to mysql with php Pete Dogg Programming 4 06-08-2003 12:52 AM
Mysql-BDB Data Base driver rwelch Linux - General 1 03-19-2003 06:46 AM
connecting mysql by php norbs Linux - Software 1 07-25-2002 01:40 AM


All times are GMT -5. The time now is 08:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration