LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   package compat-libstdc++ is not installed (http://www.linuxquestions.org/questions/red-hat-31/package-compat-libstdc-is-not-installed-635633/)

jimmyjiang 04-15-2008 09:37 PM

package compat-libstdc++ is not installed
 
hi,
I tried to install oracle 10g on my centOS 5.1 32bit Guest OS, and it need package compat-libstdc++ installed.
but when I tried to install it:
[root@db ~]# yum install compat-libstdc++
Loading "priorities" plugin
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
extras 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
addons 951 B 00:00
Reading repository metadata in from local files
0 packages excluded due to repository priority protections
Parsing package install arguments
Nothing to do

I even manually downloaded them to a "rpm" directory, then installed them, but:
[root@db rpm]# rpm -ivh compat-libstdc++-296-2.96-138.i386.rpm
Preparing... ########################################### [100%]
package compat-libstdc++-296-2.96-138 is already installed
[root@db rpm]# rpm -ivh compat-libstdc++-33-3.2.3-61.i386.rpm
Preparing... ########################################### [100%]
package compat-libstdc++-33-3.2.3-61 is already installed

root@db rpm]# rpm -q compat-libstdc++
package compat-libstdc++ is not installed

still show it not installed.
can anyone tell me what happen?
thanks in advance!
jimmy

frndrfoe 04-15-2008 10:38 PM

do you have libstdc++ and libstdc++-devel?

lazlow 04-15-2008 11:59 PM

Try giving the full name. Sometimes rpm is funny about names.

Quote:

[fred@localhost ~]$ rpm -q compat-libstdc++-33
compat-libstdc++-33-3.2.3-62
[fred@localhost ~]$ rpm -q compat-libstdc++
package compat-libstdc++ is not installed
[fred@localhost ~]$


walterbyrd 04-16-2008 07:08 AM

I am having the same problem. I am trying to install Oracle 10 on a fully-registered RHEL 3 system. I have up2date working, but none of the compat-* stuff will install, and Oracle requires a ton of these libraries. I think these libraries are supposed to provide backward compatibility with Redhat 7.3.

I need these:

compat-gcc
compat-gcc-c++
compat-libstdc++
compat-libstdc++_devel

Code:

# up2date compat-gcc-c++
Fetching Obsoletes list for channel: rhel-i386-es-4...
Fetching rpm headers...
########################################
Name                                    Version        Rel   
----------------------------------------------------------
The following packages you requested were not found:
compat-gcc-c++


jimmyjiang 04-16-2008 09:41 AM

[root@db ~]# rpm -q libstdc++
libstdc++-4.1.2-14.el5
[root@db ~]# rpm -q libstdc++-devel
libstdc++-devel-4.1.2-14.el5

[root@db ~]# rpm -q compat-libstdc++-33
compat-libstdc++-33-3.2.3-61

I do have them installed.


All times are GMT -5. The time now is 01:50 PM.