LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 08-16-2007, 07:26 AM   #1
manohare
LQ Newbie
 
Registered: Aug 2007
Posts: 13

Rep: Reputation: 0
Post Not able to upgrade the version of the rpm package



I am getting the following error while trying to upgrade the package called acl.
[buildadmin@tuxlab-build8 x86_64]$ rpm -U acl-2.2.39-1.1_WR_at.x86_64.rpm
error: Failed dependencies:
libacl.so.1()(64bit) is needed by acl-2.2.39-1.1_WR_at.x86_64
libacl.so.1(ACL_1.0)(64bit) is needed by acl-2.2.39-1.1_WR_at.x86_64
libattr.so.1()(64bit) is needed by acl-2.2.39-1.1_WR_at.x86_64
libc.so.6()(64bit) is needed by acl-2.2.39-1.1_WR_at.x86_64
libc.so.6(GLIBC_2.2.5)(64bit) is needed by acl-2.2.39-1.1_WR_at.x86_64
libc.so.6(GLIBC_2.3)(64bit) is needed by acl-2.2.39-1.1_WR_at.x86_64
libc.so.6(GLIBC_2.3.3)(64bit) is needed by acl-2.2.39-1.1_WR_at.x86_64
Any help would be appreciated
 
Old 08-16-2007, 09:40 AM   #2
nightshade_1977
Member
 
Registered: Nov 2006
Location: Oklahoma City, OK
Distribution: Suse, Fedora, RHEL, Ubuntu
Posts: 112

Rep: Reputation: 15
you have two options use the --nodeps to ignore the missing dependencies (this could result in issues with acl) or get on google and locate the packages that provide the missing dependencies (this is never fun but we've all had to do it at some point
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM Drake Package Upgrade Question rrrssssss Linux - Software 3 12-07-2006 03:15 PM
upgrade package to non-slack version moob8 Slackware 1 09-25-2006 11:37 PM
what is the command to install or upgrade an rpm package??? Simon Adebisi Linux - Software 5 06-29-2005 04:26 AM
is the a package of ndiswrapper-1.1 version in rpm golpemortal Linux - Wireless Networking 2 03-28-2005 10:04 PM
How do I upgrade a package or lib without using rpm or pkgtool? purpleburple Linux - General 4 10-16-2002 09:45 PM


All times are GMT -5. The time now is 07:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration