LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-04-2004, 08:18 PM   #1
mcalizo
Member
 
Registered: Aug 2003
Location: Manila, Philippines
Distribution: RH
Posts: 43

Rep: Reputation: 15
No module raid0 found for kernel 2.6.9


Hi all

I got a error during kernel compile:


Kernel: arch/i386/boot/bzImage is ready
sh /home/src/linux-2.6.9/arch/i386/boot/install.sh 2.6.9StableMikE arch/i386/boot/bzImage System.map ""
No module raid0 found for kernel 2.6.9StableMikE
mkinitrd failed
make[1]: *** [install] Error 1
make: *** [install] Error 2

Bellow is the lsmod output of my workin kernel (2.4.20-30.9smp)

[root@bir-proxy linux-2.6.9]# /sbin/lsmod
Module Size Used by Not tainted
ipt_TOS 1656 17 (autoclean)
ipt_multiport 1176 5 (autoclean)
ipt_limit 1688 37 (autoclean)
ipt_state 1080 11 (autoclean)
ipt_LOG 4280 37 (autoclean)
ipt_unclean 8024 0 (autoclean)
ipt_ULOG 4808 0 (autoclean)
ip_conntrack_ftp 5424 0 (unused)
ip_nat_irc 3408 0 (unused)
ip_conntrack_irc 4208 1 [ip_nat_irc]
autofs 13684 0 (autoclean) (unused)
e1000 60704 1
tg3 53064 1
iptable_nat 22936 2 (autoclean) [ip_nat_irc]
ip_conntrack 29928 4 (autoclean) [ipt_state ip_conntrack_ftp ip_nat_irc ip_conntrack_irc iptable_nat]
iptable_mangle 2776 1 (autoclean)
ipt_REJECT 3992 0 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 15864 13 [ipt_TOS ipt_multiport ipt_limit ipt_state ipt_LOG ipt_unclean ipt_ULOG iptable_nat iptable_mangle ipt_REJECT iptable_filter]
keybdev 2976 0 (unused)
mousedev 5688 0 (unused)
hid 22404 0 (unused)
input 6208 0 [keybdev mousedev hid]
usb-ohci 22248 0 (unused)
usbcore 82816 1 [hid usb-ohci]
ext3 73408 5
jbd 56368 5 [ext3]
raid0 3848 1
mptscsih 39408 7
mptbase 43040 3 [mptscsih]
sd_mod 13452 14
scsi_mod 110872 2 [mptscsih sd_mod]
[root@bir-proxy linux-2.6.9]#


Here is the .config of my new kernel:

CONFIG_BLK_DEV_3W_XXXX_RAID=y
#
# Multi-device support (RAID and LVM)
#
CONFIG_MD=y
CONFIG_BLK_DEV_MD=y
CONFIG_MD_LINEAR=y
CONFIG_MD_RAID0=y
CONFIG_MD_RAID1=y
# CONFIG_MD_RAID10 is not set
CONFIG_MD_RAID5=y
# CONFIG_MD_RAID6 is not set
CONFIG_MD_MULTIPATH=y
CONFIG_BLK_DEV_DM=y
# CONFIG_DM_CRYPT is not set
# CONFIG_DM_SNAPSHOT is not set
# CONFIG_DM_MIRROR is not set
# CONFIG_DM_ZERO is not set
#
# Fusion MPT device support
#
CONFIG_FUSION=y
CONFIG_FUSION_MAX_SGE=40
CONFIG_FUSION_CTL=m
CONFIG_FUSION_LAN=y

Below is my module.conf file:

alias eth0 tg3
alias eth1 tg3
alias eth2 e1000
alias eth3 e1000
alias usb-controller usb-ohci

Here is some of my modprobe.conf:
alias irda-dongle-5 litelink
alias irda-dongle-6 airport
alias md-personality-3 raid1
alias md-personality-4 raid5
alias md-personality-7 multipath

What would be the problem? Im stuck wit this problem. Even at Google i cant se any solutions?

Help me
 
Old 12-06-2004, 07:26 PM   #2
mcalizo
Member
 
Registered: Aug 2003
Location: Manila, Philippines
Distribution: RH
Posts: 43

Original Poster
Rep: Reputation: 15
Is this problem unique that no one can help me here?
 
Old 12-19-2004, 11:29 AM   #3
xmaxik
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
I have the same problem
 
Old 12-23-2004, 11:33 AM   #4
gsgleason
Member
 
Registered: Oct 2004
Posts: 69

Rep: Reputation: 15
I am getting the same problem. I just installed a fresh RH9 using software raid. help. I need to go to 2.6.9 so my linux box can read my ntfs external drive.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No module mptbase found for kernel 2.6.1 kcox920 Linux - General 2 05-29-2008 07:38 PM
No Module BusLogic Found for Kernel 2.6.2 benjaminrtz Linux - General 2 09-08-2006 12:22 PM
Message with kernel No module aic7xxx found for kernel 2.4.28 abefroman Red Hat 1 01-31-2005 06:41 AM
No module raid0 found during kernel compile mcalizo Linux - Software 2 12-08-2004 12:09 AM
mkinitrd failed with message "no module raid0 found for kernel 2.6.9" ythevenot Red Hat 3 12-07-2004 09:15 PM


All times are GMT -5. The time now is 12:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration