LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 04-06-2008, 09:50 AM   #1
paulhamm
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Rep: Reputation: 0
Question No in program icons for Evolution x86_64 Fedora 8 install


Sorry people I should have dropped this in the fedora forum. So I am.


Here is an interesting problem. I just installed Fedora 8 x86_64 on my machine with KDE and without Gnome. I decided to remove all the i386 arch apps from the install and go purely x86_64. Everything seems to be functioning perfectly except Evolution. All the in program icons except "cancel" on the tool bar display as sheets of paper with a red x. This includes the little folder and envelope icons for the messages in the frames. I have a suspicion that the app is looking for the icons in an i386 arch specific location, possibly just a link, purely a WAG mind. Has anyone seen this type of odd behavior? I have tried reinstalling the evolution rpms but no help. Any ideas on the wibbly bits I should be poking at would be greatly appreciated.


Paul

Last edited by paulhamm; 04-06-2008 at 10:33 AM.
 
Old 04-06-2008, 10:51 AM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,701
Blog Entries: 1

Rep: Reputation: 219Reputation: 219Reputation: 219
The icons aren't arch specific. They'll all be in in a shared folder like /usr/share/pixmaps or /usr/share/icons. You're probably missing the GNOME Icon Theme package. Start Evolution from the command line. It should throw warnings about icons it can't find.
 
Old 04-06-2008, 03:48 PM   #3
paulhamm
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Smile Solved!!!!!!!!!!

Solved though I will leave it to the reader as to which set of icons needs to be installed.

Icons installed with the Evolution problem
[root@localhost x86_64]# cat installed.rpms |grep icon
gnome-icon-theme.noarch 2.20.0-2.fc8 installed
hicolor-icon-theme.noarch 0.10-2 installed
xorg-x11-drv-siliconmotion.x86_64 1.5.1-3.fc8 installed

One or more of the following icon sets solves the problem. I just installed all of them at once and the icons work now. So not sure which needs to be installed. I doubt that I will bother trying to narrow down the issue. Interestingly I now have a set of binoculars for the search button in smart --gui instead of a magnifing glass.

[root@localhost x86_64]# yum list installed |grep icon
bluecurve-icon-theme.noarch 8.0.0-1.fc8 installed
echo-icon-theme.noarch 0.3.1-1.fc8 installed
fedora-icon-theme.noarch 1.0.0-1.fc8 installed
fusion-icon.noarch 0.1.0-0.1.5e2dc9git.fc installed
fusion-icon-gtk.noarch 0.1.0-0.1.5e2dc9git.fc installed
fusion-icon-qt.noarch 0.1.0-0.1.5e2dc9git.fc installed
kdeartwork-icons.x86_64 3.5.9-1.fc8 installed
tango-icon-theme.noarch 0.8.1-1.fc8 installed
tango-icon-theme-extras.noarch 0.1.0-1.fc7 installed
xfce4-icon-theme.noarch 4.4.2-1.fc8 installed
xfce4-volstatus-icon.x86_64 0.1.0-2.fc8 installed

Before I installed the icon rpms above I got this when running evolutoin from command line.

[paulhamm@localhost ~]$ evolution
CalDAV Eplugin starting up ...
** (evolution:4108): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:4108): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
(org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files

(evolution:4108): e-spinner.c-WARNING **: Throbber animation not found

(evolution:4108): e-spinner.c-WARNING **: Throbber fallback animation not found either
get paulhamm pop://blah.blah.blah.mysmtp/
Find Items 0

(evolution:4108): e-spinner.c-WARNING **: Throbber animation not found

(evolution:4108): e-spinner.c-WARNING **: Throbber fallback animation not found either

(evolution:4108): e-spinner.c-WARNING **: Throbber animation not found

(evolution:4108): e-spinner.c-WARNING **: Throbber fallback animation not found either


After the icon install I get this

[paulhamm@localhost ~]$ evolution
CalDAV Eplugin starting up ...
** (evolution:4991): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:4991): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
(org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files

Last edited by paulhamm; 04-06-2008 at 08:13 PM.
 
Old 04-06-2008, 06:19 PM   #4
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,701
Blog Entries: 1

Rep: Reputation: 219Reputation: 219Reputation: 219
You should edit your post and get rid of this line get paulhamm pop://paulhamm@incoming.verizon.net
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
install flash player on fedora 6 x86_64 lianbinjie Linux - Software 4 03-27-2008 06:11 AM
help: fedora 8 x86_64 install always fails maxreason Fedora - Installation 1 12-28-2007 09:54 AM
Fedora 7 x86_64 won't install on Dimension 8400 drick Fedora - Installation 0 09-17-2007 06:52 PM
Wine.i386 on a X86_64 Fedora install cuco76 Linux - Games 3 04-22-2007 05:10 PM
No Icons on my Evolution install... fieldyweb Linux - Software 5 05-10-2006 09:54 PM


All times are GMT -5. The time now is 10:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration