LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-03-2010, 02:38 AM   #1
mydownload
LQ Newbie
 
Registered: Dec 2010
Posts: 5

Rep: Reputation: 0
NFS RHEL4 server client RHEL5


Hi,


i have an RHEL5.2 client which cannot mount any NFS directory from RHEL4 (all release).

i've tried to mount directory from another RHEL5 (5, 5.2) and all works fine.

here is error message when i'm trying to mount from a RHEL4 :

# mount server_name:/nfs_dev /nfs_dev
mount: server_name:/nfs_dev failed, reason given by server: Permission denied

same message with IP adress of the server.

all servers are on a NIS domain, authentication works fine.

thanks,

regards.
 
Old 12-03-2010, 09:04 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,598

Rep: Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516
Configure the server to allow the client to mount (/etc/exports, man exports) then re-export the NFS shares on the server (exportfs -vra)
 
Old 12-06-2010, 04:25 AM   #3
mydownload
LQ Newbie
 
Registered: Dec 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Hi,

server configuration is good, all another REHL4 can mount shares. Only REHL5 cannot. Is there a special configuration in /etc/exports to be make for sharing with REHL5 ?
 
Old 12-06-2010, 05:55 AM   #4
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,598

Rep: Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516
No. What's in /var/log/messages on the server when the RHEL5 client tries to mount?
 
Old 12-06-2010, 09:14 AM   #5
mydownload
LQ Newbie
 
Registered: Dec 2010
Posts: 5

Original Poster
Rep: Reputation: 0
mountd[10410]: authenticated mount request from RHEL5:786 for /nfs_dev (/nfs_dev)

the RHEL4 server "allows" the mount request but i have the error message on RHEL5 (and nothing on var/logs/messages).
 
Old 12-06-2010, 09:22 AM   #6
chickenjoy
Member
 
Registered: Apr 2007
Distribution: centos,rhel, solaris
Posts: 200

Rep: Reputation: 30
can you add the type switch/option:
Code:
mount -t nfs x.x.x.x:/source /destination
and if it doesn't work; can you post the line of the shared directory in your exports file.
 
Old 12-06-2010, 10:26 AM   #7
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,598

Rep: Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516Reputation: 516
Right, do what chickenjoy says. When you do that, can you also post any related lines in the client's /var/log/messages?
 
Old 12-07-2010, 02:53 AM   #8
mydownload
LQ Newbie
 
Registered: Dec 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chickenjoy View Post
can you add the type switch/option:
Code:
mount -t nfs x.x.x.x:/source /destination
and if it doesn't work; can you post the line of the shared directory in your exports file.
i've already tried with :

mount -t nfs RHEL4:/nfs_dev /nfs_dev

error message => mount: server_name:/nfs_dev failed, reason given by server: Permission denied

and with

mount -t nfs4 RHEL4:/nfs_dev /nfs_dev

error message => mount.nfs4: Operation not permitted


when i ask RHEL4 shares from RHEL5 with "showmount -e REHL4", all shares are sent to RHEL5.

here find RHEL4 exports file :

/data1 *(rw,sync,no_root_squash)
/home *(rw,sync,no_root_squash)
/nfs_dev *(rw,sync,no_root_squash)

In var/log/messages client, nothing about mount operation.

thanks.
 
Old 12-09-2010, 04:21 AM   #9
chickenjoy
Member
 
Registered: Apr 2007
Distribution: centos,rhel, solaris
Posts: 200

Rep: Reputation: 30
Can you try to check your /etc/hosts.allow and /etc/hosts.deny files for any clue that might be blocking the network that the rhel5s are in.
 
Old 12-10-2010, 02:51 AM   #10
mydownload
LQ Newbie
 
Registered: Dec 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by chickenjoy View Post
Can you try to check your /etc/hosts.allow and /etc/hosts.deny files for any clue that might be blocking the network that the rhel5s are in.

Hi,

those files are empty. there's no restriction on all servers and clients.

thanks
 
Old 12-10-2010, 10:47 AM   #11
chickenjoy
Member
 
Registered: Apr 2007
Distribution: centos,rhel, solaris
Posts: 200

Rep: Reputation: 30
Did a test with rhel 4.8 and centos 5.5 and had no problems mounting an nfs share from ver4 on ver5.
 
Old 09-09-2011, 03:24 AM   #12
ynux
LQ Newbie
 
Registered: Sep 2011
Posts: 1

Rep: Reputation: Disabled
entry in /etc/hosts helps

Hi. I know I'm late, but maybe this will still help.
I had this issue when trying to mount an nfs share on a AIX machine, the client was a linux RHEL 5 server. It was a DNS problem. On AIX, the nfs server must be able to resolve the client’s IP address to host name (see ibm redbooks). To see it can resolve it, do a nslookup or connect from the client to the server and issue a "who".
An entry of the nfs client in the host's /etc/hosts solved the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] NFS mount fails (times out): NFS server is in DMZ, NFS client is in intranet Hiroshi Linux - Networking 2 05-24-2010 10:22 AM
Linux NFS client <--> Leopard NFS server ACL support tplessers Linux - Networking 0 02-17-2010 04:28 AM
nfs server on ubuntu doesn't play nice with nfs client on solaris mathiraj Linux - Networking 11 09-15-2009 02:08 PM
SELinux: RHEL4 to RHEL5 rules migration - unknown type var_lib_t in RHEL5 zbiggy Red Hat 2 05-12-2009 03:14 AM
NFS client = Linux, NFS server = Mac OS X Tiger --> Hell of a problem make Linux - Networking 9 03-10-2006 05:16 AM


All times are GMT -5. The time now is 12:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration