LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 05-26-2008, 01:56 PM   #1
ComputerErik
Member
 
Registered: Apr 2005
Location: NYC
Distribution: Debian, RHEL
Posts: 268

Rep: Reputation: 42
Network Accounts Disabled?


I am setting up a Red Hat Enterprise Linux 5 workstation to play with a bit. I want to setup authentication against an existing Sever 2003 AD domain. I setup winbind, and joined the domain fine. Then when it comes to login I enter domain\username and hit enter, then enter the correct password. I then get an error that the administrator has disabled this account, but it isn't disabled in AD.

So I am guessing that in Red Hat somewhere there is something preventing a network based account from logging in. I have tried multiple accounts, and all get me the same error. What other steps do I need to take to get this working?
 
Old 05-27-2008, 03:45 PM   #2
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
It sounds like a configuration setting is missing or incorrect - there isn't a setting that stops accounts from logging in, but if you configure this by hand you have to edit a few different things. Red Hat supply a configuration tool to do the necessary setup for you, although I don't know how well it works.

If using the Red Hat tool doesn't solve the problem, post the text of the error, and a summary of how you've configured the system. This stuff is fiddly on Linux, and easy to get wrong
 
Old 05-29-2008, 08:59 PM   #3
ComputerErik
Member
 
Registered: Apr 2005
Location: NYC
Distribution: Debian, RHEL
Posts: 268

Original Poster
Rep: Reputation: 42
Thanks, I think I got it figured out. I am now able to login authenticating with my NT account no problem.

I tried a bunch of different config setups, but in the end I am pretty sure the change(s) that got me up and running were pointing to my Windows server for NTP and also configuring SMB as an authentication method on Red Hat.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Root and all user accounts disabled mht17 Linux - Newbie 3 05-10-2011 06:23 PM
Disabled Accounts oasisbhrnw99 Linux - General 3 09-02-2005 12:25 PM
su to disabled accounts? sat86 Linux - Security 1 01-24-2005 06:05 AM
Disabled accounts on the login screen! HELP!!!! Adeas Linux - Newbie 5 09-07-2003 08:19 PM
Disabled access to user accounts! HELP! Adeas Mandriva 2 09-07-2003 08:17 PM


All times are GMT -5. The time now is 04:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration