LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-06-2011, 07:15 PM   #1
Xyan
Member
 
Registered: Oct 2003
Location: Arizona
Distribution: ClearOS, Ubuntu, CentOS, Fedora
Posts: 33

Rep: Reputation: 15
Mysterious "hibernate" with CentOS 6, cannot disable.


Hello,
I have a server (Dell PowerEdge 9550, if I remember right) running CentOS 6.0 in the GUI mode (Gnome).

I have disabled all screen saver and power-saving options, as well as completely remove the power management modules, but I keep running into this problem.

What happens is, if a "vncserver" session is left running for multiple hours (not exactly sure what the time frame is, but somewhere within 12 hours), the server will go into a hibernate-like mode. At this point, all remote services are disabled, and a friend has to manually power cycle the machine since the keyboard and reset button seem to do nothing (power light is on, but no HDD activity).

I connect to this server with SSH, then tunnel with VNC to control the desktop environment. I've discovered this problem when I've left the session open so I could return to my testing, but we do hope to turn it into a production server for a university project.

I just did a test of this last night and its locked up again -- no programs were running, just the VNC service.

Any ideas? Where should I be looking in logs for this? Has anyone even heard of a problem like this before?

Thank you!
 
Old 12-07-2011, 11:29 AM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: Fedora
Posts: 1,335

Rep: Reputation: 320Reputation: 320Reputation: 320Reputation: 320
I assume you have looked at a console and the system didn't just crash? A sudden crash won't make it to /var/log/messages. You need an attached display, serial or network console window open.

Dell PowerEdge servers have a service processor with lots of configurable options. Make sure there isn't some inactivity timer turned on that is putting itself to sleep. While you're in there check the event log. It also lets you change the power/reset button behavior too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
remove "Suspend" and "Hibernate" from the "Shut Down" applet cccc Debian 2 05-02-2011 10:05 AM
[SOLVED] Cannot get to "sleep" or "hibernate" states succesfully with Slack 13.1 bogzab Slackware 14 06-03-2010 12:35 PM
[SOLVED] Cannot "sleep" or "hibernate" my Thinkpad X61 Tablet SaintDanBert Linux - Laptop and Netbook 1 02-01-2010 10:05 AM
How to disable the kernel update notification using "Package Updater" in CentOS 5.2? colucix Red Hat 1 12-29-2008 11:48 AM
How do I disable "shutdown" and "restart" options in KDE logout screen for all users? maxgsp Linux - Distributions 1 12-12-2008 03:18 PM


All times are GMT -5. The time now is 12:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration