LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 09-27-2010, 10:48 AM   #1
twaddlac
Member
 
Registered: Jun 2010
Posts: 34

Rep: Reputation: 0
Question Mount: wrong fs type, bad option, bad superblock missing codepage or other error


Hello,

I am running a CentOS vm on a Windows 7 host and I recently installed the latest version of guest additions (3.2.8) when I received the error:

Code:
#mount -t vboxsf ez sequence_data/
mount: wrong fs type, bad option, bad superblock on ez,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
when trying to mount an external hard drive to the guest. I have done this procedure many times with no errors but now for whatever reason I don't know what happened. Please, let me know if you have any suggestions on how to fix this!

Thank you very much!
 
Old 09-27-2010, 12:01 PM   #2
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,546
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Maybe a silly question but are you running VirtualBox 3.2.8 on the host? When you write "external drive" is that a VirtualBox shared folder that is attached to the VM? Have you tried not specifying the file system type?
 
Old 09-27-2010, 12:32 PM   #3
twaddlac
Member
 
Registered: Jun 2010
Posts: 34

Original Poster
Rep: Reputation: 0
Yes, I am running the version 3.2.8 on my Windows 7 guest. The external drive is set up for sharing under the shared folders tab in the guest's settings. As for specifying the file system type - I don't think that there's a way to do such a thing (at least I have not found it). Hopefully these answer your questions!
 
Old 09-27-2010, 01:20 PM   #4
twaddlac
Member
 
Registered: Jun 2010
Posts: 34

Original Poster
Rep: Reputation: 0
I should also mention that after trying to mount the hard disk I received another error message:

Code:
/sbin/mount.vboxsf file does not exist
or something very similar to that. After getting this message I tried to create a file named "mount.vboxsf" and it still didn't work. Hopefully this helps!
 
Old 09-28-2010, 04:45 AM   #5
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
Your Guest Additions installation on the CentOS has crashed somehow. Try reinstalling it. If this does not help, try installing newer or older version.
 
  


Reply

Tags
centos, mount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 08:55 AM
Cannot mount NFS share (wrong fs type, bad option, bad superblock)... martinezpt Linux - Server 3 04-25-2010 08:44 PM
ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1, saiket Linux - Hardware 3 04-12-2008 12:07 AM
usb drive won't mount - error: wrong fs type, bad option, bad superblock on /dev/sda1 bluecog6 Linux - Hardware 4 01-27-2007 09:07 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 05:50 PM


All times are GMT -5. The time now is 09:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration