LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 03-10-2005, 12:33 AM   #1
lewkh
Member
 
Registered: Oct 2004
Posts: 69

Rep: Reputation: 15
mount.smbfs problem


Hi, I encouter the problem of mount directory from Windows by using mount.smbfs command, my command is

mount -t smbfs -o username=<username>, password=<passwd> //<ip address>/<mount point> /<mount point>

after the command issue then it shows me message as 4588: Session request to <ip address> failed (called name not present)
then cursor keep on blinking and no command prompt return but I terminate it by using Ctrl + C then command prompt return. I check the mount table, it is mounted.

I wonder know what is the problem here? Anyone here got the same problem with me? Because I put the command to startup script , it cause booting hang up on the mounting
samba. What can I optimize it? Please advice....
 
Old 03-10-2005, 05:54 PM   #2
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
Can you actually access the files once it mounts ?

WRT the startup script, it's worth considering using autofs for this instead - you have to plan for the possibility that the Windows system will be off-line.
 
Old 03-10-2005, 10:49 PM   #3
lewkh
Member
 
Registered: Oct 2004
Posts: 69

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by hob
Can you actually access the files once it mounts ?

WRT the startup script, it's worth considering using autofs for this instead - you have to plan for the possibility that the Windows system will be off-line.
Hi Hob, the Windows system is always on (checked) and I can access the directory once it mounted. I tried to touch a files and even transfer 2 Gb files to it, there is no problem. By the way, what is autofs? How do I use it? Please advice..
 
Old 03-11-2005, 11:39 AM   #4
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
It sounds like a name resolution problem, so it's probably worth checking DNS and WINS.

Autofs automatically mounts a device or remote share when the local mount point is accessed in anyway.

You create a file in /etc/ called auto.share (or similar) and put something like this in it:

# A shared directory on a Windows server holding some home directories.
# This will be accessible as /nethome/winhome/
winhome -fstype=smbfs ://server1/fileshare

(you'll probably want some more options in as well).

Then edit /etc/auto.master and add:

/nethome /etc/auto.share

Then restart the autofs service.

You'll see a new directory called /nethome has appeared. Whenever somebody accesses /nethome autofs will check auto.share. The line in auto.share says to mount the fileshare whenever somebody tried to access /nethome/winhome. Auto.share could actually be a script rather than a fixed set of options - check /etc/auto.net for an example.

Autofs automatically unmounts shares that haven't been used for more than five minutes. So you won't risk hanging the boot process, and will only have live connections to the Windows server when they are needed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with smbfs mount-point in /etc/fstab - "mount -a" works, but not at boottime MarkSide Linux - Software 4 11-20-2005 03:30 PM
small problem with smbfs mount synapse Slackware 4 03-16-2005 09:26 AM
cannot mount smbfs flipboi Linux - Security 2 08-12-2004 09:18 AM
mount Smbfs problem lupus9537 Linux - Newbie 4 04-26-2004 08:33 AM
mount -t smbfs loganwva Linux - Networking 1 10-21-2003 11:02 AM


All times are GMT -5. The time now is 11:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration