LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Monitor trouble in RH9/W2K dual-boot situation (http://www.linuxquestions.org/questions/red-hat-31/monitor-trouble-in-rh9-w2k-dual-boot-situation-151444/)

BixGomez 02-28-2004 01:55 AM

Monitor trouble in RH9/W2K dual-boot situation
 
Hello!

I just (almost) successfully installed RH9 on one drive of my otherwise Windows machine, thereby creating a dual-boot situation.

However, I have one big question, and one big problem.

When I start up my machine, I have three (3) choices:

1. DOS

2. Red Hat Linux (2.4.20-8smp)

3. Red Hat Linux-up (2.4.20-8)

The big question is this: what is the difference between the two Red Hat choices?

And, the big problem is this:

Regardless of which Red Hat choice I make, my monitor invariably goes BLACK (and loses sync) just at the point of "First Boot."

At first, I suspected that this is due to the fact that my monitor is attached to a third-party PCI video card, and that at the moment of first boot, Red Hat switched over to the on-board card, rather than sticking with the PCI card.

But this is not the case, because after the monitor loses sync, I unplug it from the PCI card and into the on-board card, alas to no avail...

Any thoughts on how to fix this?

Thanks for any help you can offer...

~ Bix

scott_R 02-28-2004 02:38 AM

If you only have one monitor attached, you should disable the onboard card in bios. That's not to say that is the problem, because it might cause Windows problems too, but it's always good to disable things you aren't using (security reasons).

smp means symmetric--uh, lets just say it means more than one cpu in your case. You'll already know if you have it, as these are far more expensive, and somewhat harder to find. If you have an average PC, you don't have it. No chain retailer sells them, either.

Your screen is going black, most likely because your GUI is configured wrong. Your screed settings don't fit your card/monitor configuration. This happens. The best way to fix this is to log into Linux by hitting ctrl-alt-F2, then typing root to login, your password, then 'xf86cfg -textmode' to fix it.

The easier way is to rerun your installation, picking different (to be safe, lesser) settings. I hate installs, reinstalls, and the like, but for newbies, this can be less frustrating than fighting with the command line or trying to figure out what means what. If you go the second route, pick fairly low settings (800x600 and svga drivers are usually safe, unless your computer is pre-1996), you'll have better results. Remember, you can easily improve your settings, once you're more familiar with linux.

BixGomez 02-28-2004 09:27 AM

Yes, I do have 2 CPUs -- my machine is a Dell PowerEdge 1300 with dual 700 mHz processors.

So should I choose this option?

Does the other option mean that it will only use one of the processors?

Re: the monitor, yes I think my GUI is configured wrong -- in times past, when I have experimented with Linux, I have kept the defaults (800x600) on install.

This time, I changed it to a higher resolution during install -- probably not a good idea, as you indicate.

I will try the command-line solution, until I get too frustrated!

But, question -- at what point during bootup should I invoke ctrl-alt-F2 ?

Thanks!

aqoliveira 03-01-2004 04:43 AM

Howzit

I would choose the option with smp the only time u r going to get full benefit from both processors is when u havw apps that take advantage of multi threading there will be a huge diff in performace over 1 CPU. The answer is yes if u choose option without smp.

to sort out prob with monitor goto a terminal with Ctrl-Alt-F2 lohin then type init 3 this will reboot your system into text mode once that is done type cmd redhat-config-xfree86 this a GUI verion to configure XFree86. Choose settings accordingly and u should be ok.

Ciao


All times are GMT -5. The time now is 01:15 PM.