LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 11-17-2004, 11:47 PM   #1
ppayton
LQ Newbie
 
Registered: Nov 2004
Location: austin,tx
Posts: 1

Rep: Reputation: 0
Unhappy machine doesn't boot now ... just GRUB in upper left; installed redhat9 on hdb


i was hoping someone could help me out...
i just installed redhat9 on my 2nd hard-drive (on the main-big partition of that drive)
all i get on reboot is GRUB in upper left corner (even with the install cd in drive).
my emergency floppy disk works and gets me into linux though.
do i need to reinstall grub? to what partition/ what drive?

grub.conf file contents:
default=2
timeout=10
splashimage=(hd1,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8smp)
root (hd1,0)
kernel /vmlinuz-2.4.20-8smp ro root=LABEL=/ hdd=ide-scsi
initrd /initrd-2.4.20-8smp.img
title Red Hat Linux-up (2.4.20-8)
root (hd1,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdd=ide-scsi
initrd /initrd-2.4.20-8.img
title DOS
rootnoverify (hd0,1)
chainloader +1


is there something wrong with it?

when i do "df" i get:
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/hdb2 37848096 2795248 33130272 8% /
/dev/hdb1 101089 14830 81040 16% /boot
none 127388 0 127388 0% /dev/shm
/dev/fd0 1430 1251 179 88% /mnt/floppy



hda isn't even showing up here... is that to be expected?
that hard drive has winXP on it

i am new to linux ... please help
thanks
 
Old 11-18-2004, 03:47 PM   #2
jsutton
Member
 
Registered: Nov 2003
Location: Greenville, SC, USA
Distribution: (K)ubuntu 5.04 / Fedora 4
Posts: 113

Rep: Reputation: 15
You could try reinstalling grub using this command (assuming that you are booting from /dev/hdb):

Code:
grub-install /dev/hdb
 
Old 11-19-2004, 02:43 AM   #3
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
You could try changeing:

root=LABEL=/

to:

root=/dev/hdb2

I'm not sure what the LABEL describes. I've seen one spot on this forum where the solution was to put something funny like that in the kernel parameters. Typically, I think, this should point to your root partition. In your case (judging by your df output) this is /dev/hdb2.

If someone who knows more about the kernel would care to fill me in, I would appreciate it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
idesk - icon in upper left corner displayed wrong titopoquito Linux - Software 0 06-19-2005 04:08 AM
Fedora 2 installed HDB, need a boot loader... sndinc Fedora 11 01-16-2005 06:34 AM
Booting via GRUB from hdb and XP Boot-laoder amber66 Linux - Newbie 5 04-07-2004 05:09 AM
Tux Graphic in Upper Left Corner After Boot tofu Debian 6 07-13-2003 02:20 AM
Mouse in Upper Left Corner KDE3 Rockzilla Linux - Newbie 3 10-03-2002 04:56 PM


All times are GMT -5. The time now is 11:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration