LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 08-13-2004, 09:56 AM   #1
RahmanJan
LQ Newbie
 
Registered: Aug 2004
Posts: 2

Rep: Reputation: 0
Red face Linux Red Hat 9 start up problem - Init ID X respawning too fast


Hi Guys,

I finally installed linux red hat 9 with many problems in my PC under Microsoft Virtual PC 2004.

Finally it looked everything is working I rebooted the system and it Oked every hardware except the Eth 0 which I believe could be the Network card.

Anyways, now even before the log in screen I am getting the message:

"INIT: Id "x4" respawning too fast: disabled for 5 minutes" and it is going on and on.

Finally I pressed Cntl+c and got the log in screen, I could log in but again it continues
bringing the same message again and again.

I have bought a brand new PC , Pentium 4. I don't know what is going wrong. I have installed almost
all linux with all GUI GNOME, KDE etc. I am not a Linux newbe.

Any respond will be appreciated.

regards
 
Old 08-14-2004, 07:31 PM   #2
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
Hi RahmanJan,
This "x4" thing is a label of some action which init is trying to start but it is not working. Every time it breaks, init restarts it again and, as it is happening too fast, it disables for 5 minutes. After this time, the process starts again. First you need to know what process is this. You can edit or view "/etc/inittab", looking for a line starting with this label. I would guess it is Xwindow.
 
Old 08-14-2004, 08:06 PM   #3
RahmanJan
LQ Newbie
 
Registered: Aug 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks Mate,

as I mentioned I am very new to Linux World and very optimistic to learn it ;-) .... I got the following info from etc/inittab:

there are many other lines but it ends with:

#run getteys in standard run level
1: 2345 : respawn : /sbin/mingetty tty1
2: 2345 : respawn : /sbin/mingetty tty2
3: 2345 : respawn : /sbin/mingetty tty3
4: 2345 : respawn : /sbin/mingetty tty4
5: 2345 : respawn : /sbin/mingetty tty5
6: 2345 : respawn : /sbin/mingetty tty6

#run xdm in run level 5
x:5: respaun :/etc/x11/prefdm - nodamon

Please let me know if you guys need more info ...

much appreciated.

Regards

Ra
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Server broken. start w/ "INIT: ld "x" respawning too fast: disabled for 5 minutes&q tektone Linux - Hardware 5 07-25-2007 07:18 PM
INIT:Id "x" respawning too fast: disabled for 5 minutes problem satimis Red Hat 4 07-22-2004 06:03 AM
Redhat Linux 7.2 > INIT: Id "X" respawning too fast tekquest Linux - Distributions 7 09-02-2003 07:43 PM
INIT: id 'x' respawning too fast: disabled for 5 minutes unitcoed Linux - Newbie 1 07-06-2003 07:35 PM
init id 1 respawning too fast : disable for 5 minutes nogor Linux - General 1 06-10-2003 08:56 AM


All times are GMT -5. The time now is 05:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration