LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 08-15-2007, 06:01 PM   #1
bluethumb
Member
 
Registered: Jan 2006
Distribution: RHEL 4, Scientific Linux, Centos, Ubuntu
Posts: 58

Rep: Reputation: 15
Unhappy krb5 up2date tangle on RHEL4


Running up2date on RHEL4 (x86_64) works OK except for some krb5 packages. I downloaded the RPMs to update by hand, but that didn't help. Here's how it goes:
Code:
# ll *rpm
-rw-r--r--  1 root root 895974 Aug 15 14:47 krb5-devel-1.3.4-49.x86_64.rpm
-rw-r--r--  1 root root 493895 Aug 15 14:49 krb5-libs-1.3.4-49.i386.rpm
-rw-r--r--  1 root root 531526 Aug 15 14:47 krb5-libs-1.3.4-49.x86_64.rpm
-rw-r--r--  1 root root 895390 Aug 15 14:47 krb5-workstation-1.3.4-49.x86_64.rpm

# rpm -Uvh *rpm
error: Failed dependencies:
        krb5-libs = 1.3.4-46 is needed by (installed) krb5-devel-1.3.4-46.i386
I don't understand. Why doesn't it realize that I'm installing a new version of krb5-devel, which presumably uses the new krb5-libs that are being installed?
 
Old 08-15-2007, 06:44 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Your forgetting the krb5-devel-1.3.4-49.i386.rpm file. Either download and install the missing package with the rest or try;

rpm -e krb5-devel-1.3.4-46.i386
 
Old 08-15-2007, 07:23 PM   #3
bluethumb
Member
 
Registered: Jan 2006
Distribution: RHEL 4, Scientific Linux, Centos, Ubuntu
Posts: 58

Original Poster
Rep: Reputation: 15
Thanks. That did the job.

The i386 version wasn't available through my subscribed "channels". I found a copy in Europe, though. When I added it to the mix, the update went OK. Now up2date tells me that it's fully updated.
 
Old 08-16-2007, 07:16 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
You may want to consider adding the CentOS4 repos to the mix for future use;

http://wiki.centos.org/HowTos/Packag...ment/YumOnRHEL
 
  


Reply

Tags
rhel, rhel4, rpm, up2date


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
krb5-telnet hokckey Linux - Software 0 07-05-2007 04:47 AM
RHEL4 up2date problem gireesha_ks Linux - Enterprise 2 06-15-2006 09:36 AM
SMP issue and kernel not updating after running up2date? RHEL4 devinnull Linux - Newbie 2 02-15-2006 05:13 PM
Krb5-telnet dvong3 Linux - General 1 03-27-2004 04:13 AM
up2date bug fixed: New up2date avail. with updated SSL certificate authority file dkaplowitz Red Hat 2 09-04-2003 06:05 PM


All times are GMT -5. The time now is 04:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration