LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 03-16-2004, 12:59 PM   #1
Keynote
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Rep: Reputation: 0
Kppp how to set in Dial up Script for PPP


Hi

I find out that Encore PCI modem is not support so I swap it. And got new modem, it is USR 56K PCI PN: 3CP2976-OEM. But I check Linux cat /proc/pci the modem is Serial controller: US Robotics/3Com 56K FaxModem Model 5610 (rev 1). I don't know why 2 different model, ie: 3CP2976-OEM and US Robotics Model 5610. I need to verify it. Need help.


I am new Linux Red Hat Enterprise Basic WS. Has not successful
connect Dial up modem. I do hear modem dialing up at Mini Terminal and then input login Username: and again input Password. Then wait for second, nothing come up so I press Enter once and there is ISP start activity and pppd too. I need pppd input in KPPP Login Script to activity ppp. How?

Here is my setup, might thought helpful.

KPPP Configuration:
Setup:Account:Edit:Login Script:

In Script, I have type as shown.
Expect Username:
Send xxxxxxxx
Expect Password:
Send xxxxxxxx
Pause(sec) 5

Then I dialing Connect, here what I getting message.
Login Script Debug Window:
ATZ
OK
ATM1L3
OK
ATDT4037836400
CONNECT 28800/ARQ/V34/LAPM/V42BIS

RTT Ascend PRI 2

Username:xxxxxxx
Password:
ascend>


And compare to Mini Terminal, When I dial atd7836400 and request to input login and password, I have enter both Login and Password. I wait, wait, nothing come up so press Enter and got enter PPP Mode.

I need how to make correction on KPPP Configuration Login Script, where I can find to input (Enter) and press once time, or is there ppp input in Login Script and how do that in order to get connect Internet ISP.

Here what I getting at Mini Terminal.
Mini Terminal:
ATZ
OK
atd7836400
CONNECT 28800/ARQ/V34/LAPM/V42BIS

RTT Ascend PRI 3


Username:xxxxxxx
Password:
ascend>
Entering PPP Mode.
IP address is xxx.xxx.xx.xxx
MTU is 1500.
}#@!}!}!} }=}"}&} }*} } }'}"}(}"}1}$}%\}3}+}!RTTstackR9~}#@!}!}!} }=}"}&} }*} } }'}"}(}"}1}$}%\}3}+}!RTTstackR9~}#@!}!}!} }=}"}&} }*} } }'}"}(}"}1}$}%\}3}+}!RTTstackR9~}#@!}!}!} }=}"}&} }*} } }'}"}(}"}1}$}%\}3}+}!RTTstackR9~}#@!}!}!} }=}"}&} }*} } }'}"}(}"}1}$}%\}3}+}!RTTstackR9~


Note:
Network: Device modem, they have decide pick, ttyS4 but not on KPPP Configuration Modem where there is no ttyS4 instead I use /dev/modem. It seem work ok.

System Settings:Network:Hardware: Modem Device /dev/ttyS4, Flow Control (Hardware CRTSCTS)


Kppp Configuration: Setup,
Device: Modem Device /dev/modem
Flow Control Hardware CRTSCTS
Line Termination CR
Connection Speed 115,200
check on (use lock file)

Pardon me for English bad.
 
Old 03-16-2004, 01:06 PM   #2
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Try to get kppp to send a carriage return.
 
Old 03-16-2004, 01:32 PM   #3
Keynote
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Original Poster
Rep: Reputation: 0
Finally, modem do connect. That when I press Connect at KPPP. I dont know how it happen. It ok. But now I got very very very slow speed.
The KPPP Connection screen show 0 KB speed. When open Redhat site, nothing but close. Much apprentice need your help. Thanks.
 
Old 03-16-2004, 01:40 PM   #4
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Make sure you have the serial port speed set right (at least 57600)
 
Old 03-16-2004, 02:18 PM   #5
Keynote
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Original Poster
Rep: Reputation: 0
Change to 57600 from 115,200 on both Network and KPPP Configurment.
KPPP Connection is work excellent. And it still slow. KPPP Statistics show
0.0(max .1.0)kb/sec. When I press redhat link at Mozilla browser, nothing and see modem speed back and forth at KPPP modem light or KPPP Statistics screen, it look like speed stall or modem stall look flatline dead.
Only recived 80 kb and out 86 kb and that is then stall or stay flat.
 
Old 03-16-2004, 02:37 PM   #6
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Quote:
CONNECT 28800/ARQ/V34/LAPM/V42BIS
28.8kbps. Bad phone line/ISP? You didn't specifically change any settings, so there is no reason for the modem to be the problem.
 
Old 03-16-2004, 03:42 PM   #7
Keynote
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Original Poster
Rep: Reputation: 0
I change setting at System Settings/Network/Generic Modem/Hardware/Baud Rate. Was 115,200, present setting is 57600, Flow Control is None. I don't know how get there. It was suppose to be Hardware(CRTSCTS) Again I change from None to Hardware(CRTSCTS).

Also change KPPP Configuration/Setup/Device/Connection Speed. It was 115,200 and now present setting is at 57600. Recently try dial up connection, connection was good, speed still at 0 kb. kppp statistics show bytes in (80) bytes out (86).

On other hand, recently I dial up, first KPPP connection, it was fine, then Enter RedHat-Config-Network to activative my Device Modem. The result is "Cannot Activative Network Device RTTincPonoka. Fail to activative RTTincPonoka with Error 1". And other KPPP Config screen show "The pppd daemon died unexpectedly. Exit status: 16. See 'man pppd' for an explanation of error code or take a look at the kppp FAQ on http://devel-home.kde.org~kppp/index.html." Thanks for trying help. I will check this website for error and what cause it error.

Last edited by Keynote; 03-16-2004 at 03:44 PM.
 
Old 03-16-2004, 04:02 PM   #8
Keynote
LQ Newbie
 
Registered: Mar 2004
Posts: 17

Original Poster
Rep: Reputation: 0
Amaze, I found out that just check off on KPPP Configuration/Setup/Device/Check off (Use Lock File). Then try Connection again, amaze Mozilla work and speed is excellent. Much Thanks to aaa for effort to try helpful. And also FAQ at http://devel-home.kde.org/~kppp/index.html. Just check off (Use Lock File) that all I change setting, before it was check on. Wow, Loving Linux, it amaze. Now I process learning new Linux World.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dial-In PPP dial-in server/ Cable-modem & LAN / Setting up "dannyboyOnline" dannyboy259 Linux - Networking 2 01-12-2007 12:40 AM
KPPP vs ppp-go in slackware pj320 Linux - Networking 1 07-26-2005 06:24 PM
Settup PPP without KPPP ibanez862 Slackware 24 12-28-2004 01:15 AM
Help.... Need to set KPPP to auto dial and ISP rocs78 Linux - Networking 1 10-05-2004 10:23 AM
Cousin having trouble with dial up in kppp with SBC dial, please help Fear58 Linux - Networking 1 07-03-2004 09:11 PM


All times are GMT -5. The time now is 11:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration