LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Kickstart - problem reading ks.cfg via http (http://www.linuxquestions.org/questions/red-hat-31/kickstart-problem-reading-ks-cfg-via-http-243019/)

scilec 10-15-2004 11:26 AM

Kickstart - problem reading ks.cfg via http
 
Hi,
I'm running Redhat Enterprise Linux 3 and I recently created a Redhat boot cd for automatic installations using Kickstart. Both my ks.cfg file and all of my files required for the installation are available via an http server. Originally, my isolinux.cfg file looked like the following:

default linux
prompt 1
timeout 600
display boot.msg
F1 boot.msg
F2 options.msg
F3 general.msg
F4 param.msg
F5 rescue.msg
F7 snake.msg
label linux
kernel vmlinuz
append initrd=initrd.img
label text
kernel vmlinuz
append initrd=initrd.img text
label expert
kernel vmlinuz
append expert initrd=initrd.img
label ks
kernel vmlinuz
append ks initrd=initrd.img
label lowres
kernel vmlinuz
append initrd=initrd.img lowres

After booting the cd, at the boot: prompt, I would type "linux ks=http.......ks.cfg" and hit return. The ks.cfg file would then be read and the rest of the installation would happen via http without a hitch.

However, I would ultimately like to create a boot cd that I can just boot from, and have the installation take place without any further intervention. So, I made the following changes to my isolinux.cfg file (bolded):

default linux
prompt 0
timeout 600
display boot.msg
F1 boot.msg
F2 options.msg
F3 general.msg
F4 param.msg
F5 rescue.msg
F7 snake.msg
label linux
kernel vmlinuz
append initrd=initrd.img ks=http........ks.cfg
label text
kernel vmlinuz
append initrd=initrd.img text
label expert
kernel vmlinuz
append expert initrd=initrd.img
label ks
kernel vmlinuz
append ks initrd=initrd.img
label lowres
kernel vmlinuz
append initrd=initrd.img lowres

However, when I boot the cd, it does not read the ks.cfg file via http. Instead, it jumps to the interactive install.

Does anybody know what I'm doing wrong here? I'd really appreciate any assistance!

Thank you,

Steve

PS: My url's are listed as "http......" because I'm not allowed to post url's yet.

scilec 10-15-2004 01:53 PM

Never mind - I got it
 
It helps if I read in my ks.cfg file under the specified default label!


All times are GMT -5. The time now is 06:34 AM.