LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 06-21-2005, 11:26 AM   #1
LQ Newbie
Registered: Jun 2005
Posts: 4

Rep: Reputation: 0
Keyboard/mouse doesn't work after Enterprise 4 install

i've done a redhat enterprise 4 install on a dual zeon motherboard. all goes well in the install process. then it's time to reboot to do the post-install stuff. the machine reboots, X starts and neither the keyboard nor mouse work. i then used the install disk and "linux recover" to change to run level 3 and rebooted. kudzu comes up and says to "hit any key" to install/remove new hardware. the keyboard still doesn't work! kudzu times out and when i try to log in i get the following message when i hit various keys on the keyboard (no other response from hitting any key):

"psmouse.c: Mouse at isa0060/serial0/imput0 lost synchronization, throwing 2 bytes away"

so it seems that the o/s thinks my keyboard is a serial mouse.

i'm clueless at this point. i've booted into single user mode - same thing. i've booted using the install disk and "linux recover" and checked out the XF86config. it looked ok but i made a few changes to
make it similar to one that works with the same keyboard/mouse (this is on an eight port kvm switch). i've tried booting without the switch and with a keyboard/mouse directly plugged into the machine - same results. this is with a ps2 keyboard/mouse. i've even redone the entire install with the same results.

i've googled but not come up with anything. i've poked around on redhat but haven't found anything. since things work fine in the install it seems like the hardware is eliminated.
Old 06-21-2005, 11:37 AM   #2
Registered: Apr 2005
Location: Texas
Distribution: RHEL 2.1,3.0,4.0
Posts: 39

Rep: Reputation: 15

Last edited by cowboy_jake; 06-21-2005 at 11:47 AM.
Old 06-21-2005, 02:52 PM   #3
LQ Newbie
Registered: Jun 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Some additional information:
the keyboard and mouse are plugged in correctly
i have done two other installs with this cd set and they work fine
the keyboard and mouse work fine while i'm installing
the keyboard and mouse also work fine under knoppix

i'm really at a loss on this one!



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse/Keyboard don't work. tmack8968 Debian 15 07-19-2005 07:22 PM
Keyboard doesn't work in RedHat Enterprise AS V4 Red Hat 3 07-17-2005 08:41 PM
the keyboard and mouse can't work!! ayiiq180 Linux - Hardware 2 09-12-2004 10:08 AM
Mouse and Keyboard won't work after install trmong Linux - Hardware 9 11-17-2003 12:38 AM
My mouse and keyboard dont work under X fatal Linux - General 4 06-08-2001 11:45 AM

All times are GMT -5. The time now is 01:24 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration