LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-14-2003, 02:08 PM   #1
Pisces107
Member
 
Registered: Dec 2003
Distribution: Slackware Current, Gentoo , Debian SID
Posts: 90

Rep: Reputation: 15
kernel-update, a success... BUT... couldn't boot from the updated-kernel


hi

i followed the Thetargos mini-tutorial for updating the kenrel... and after 3 failed attempts (following random info), i finally succeeded in updating my kernel from 2.4.18-14 to 2.4.23 by following that tutorial. i'm using Redhat8. Amazingly(for me ) it updated the grub.conf and put the system.map and other file in the /boot directory by itself.

BUT ... i have a smiliar problem which andy18 got! i'm not able to boot from new kernel and it spits out the following error message:

---------------------------------------------------
VFS: cannot open root device "LABEL=/" or 00:00
Please append or correct "root=" boot option
Kernel panic:VFS unable to mount root fs on 00:00
---------------------------------------------------


>>> here's my grub.conf file:

------------------------------------------------------------------------
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /vmlinuz-version ro root=/dev/hdb3
# initrd /initrd-version.img
#boot=/dev/hda
default=2
timeout=10
splashimage=(hd1,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.23)
root (hd1,0)
kernel /vmlinuz-2.4.23 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.23.img
title Red Hat Linux (2.4.18-14)
root (hd1,0)
kernel /vmlinuz-2.4.18-14 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.18-14.img
title Windows XPs
rootnoverify (hd0,0)
chainloader +1
------------------------------------------------------------------------


>>> also i see a link (menu.1st) to the grub.conf file in the 'grub' directory as:

------------------------------------------------------------------------
-rw-r--r-- 1 root root 101 Dec 10 20:56 device.map
-rw-r--r-- 1 root root 10848 Dec 10 20:56 e2fs_stage1_5
-rw-r--r-- 1 root root 9776 Dec 10 20:56 fat_stage1_5
-rw-r--r-- 1 root root 8864 Dec 10 20:56 ffs_stage1_5
-rw------- 1 root root 744 Dec 14 18:06 grub.conf
-rw-r--r-- 1 root root 11072 Dec 10 20:56 jfs_stage1_5
lrwxrwxrwx 1 root root 11 Dec 10 20:56 menu.lst -> ./grub.conf
-rw-r--r-- 1 root root 9280 Dec 10 20:56 minix_stage1_5
-rw-r--r-- 1 root root 12512 Dec 10 20:56 reiserfs_stage1_5
-rw-r--r-- 1 root root 7985 Sep 6 2002 splash.xpm.gz
-rw-r--r-- 1 root root 512 Dec 10 20:56 stage1
-rw-r--r-- 1 root root 130340 Dec 10 20:56 stage2
-rw-r--r-- 1 root root 8576 Dec 10 20:56 vstafs_stage1_5
-rw-r--r-- 1 root root 12552 Dec 10 20:56 xfs_stage1_5
------------------------------------------------------------------------


>>> here's my listing of /usr/src directory:

------------------------------------------------------------------------
lrwxrwxrwx 1 root root 15 Dec 11 17:30 linux-2.4 -> linux-2.4.18-14
drwxr-xr-x 17 root root 4096 Dec 13 12:58 linux-2.4.18-14
drwxr-xr-x 15 573 573 4096 Dec 14 14:48 linux-2.4.23
-r--r--r-- 1 root root 29832609 Dec 14 08:32 linux-2.4.23.tar.bz2
drwxr-xr-x 7 root root 4096 Dec 10 20:36 redhat
------------------------------------------------------------------------

>>> this is the listing of my /boot directory :

------------------------------------------------------------------------
-rw-r--r-- 1 root root 5824 Sep 6 2002 boot.b
-rw-r--r-- 1 root root 612 Sep 6 2002 chain.b
-rw-r--r-- 1 root root 42150 Sep 4 2002 config-2.4.18-14
drwxr-xr-x 2 root root 1024 Dec 14 18:06 grub
-rw-r--r-- 1 root root 129882 Dec 10 20:34 initrd-2.4.18-14.img
-rw-r--r-- 1 root root 67188 Dec 14 14:48 initrd-2.4.23.img
-rw-r--r-- 1 root root 473 Dec 10 20:34 kernel.h
drwx------ 2 root root 12288 Dec 10 20:29 lost+found
-rw-r--r-- 1 root root 23108 Sep 6 2002 message
-rw-r--r-- 1 root root 21282 Sep 6 2002 message.ja
lrwxrwxrwx 1 root root 21 Dec 10 20:34 module-info -> module-info-2.4.18-1
-rw-r--r-- 1 root root 15436 Sep 4 2002 module-info-2.4.18-14
-rw-r--r-- 1 root root 640 Sep 6 2002 os2_d.b
lrwxrwxrwx 1 root root 20 Dec 14 14:54 System.map -> System.map-2.4.18-14
-rw-r--r-- 1 root root 507814 Sep 4 2002 System.map-2.4.18-14
-rw-r--r-- 1 root root 599691 Dec 14 14:48 System.map-2.4.23
-rwxr-xr-x 1 root root 3236438 Sep 4 2002 vmlinux-2.4.18-14
lrwxrwxrwx 1 root root 14 Dec 14 14:48 vmlinuz -> vmlinuz-2.4.23
-rw-r--r-- 1 root root 1125194 Sep 4 2002 vmlinuz-2.4.18-14
-rw-r--r-- 1 root root 1197472 Dec 14 14:48 vmlinuz-2.4.23
------------------------------------------------------------------------


the listing seems long, but i want to give as much information as it can help understand my problem well.
i would really appreciate any help regarding this.
thanks.
P.S i chose the ext3 support during xconfig. btw is there any way i can check all the config i used during kernel build?
 
Old 12-14-2003, 05:48 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

Try removing 'ro root=LABEL=/' from the kernel arguments in grub.conf

Dave

P.S. I don't know why this is needed in the first place.
 
Old 12-15-2003, 03:52 PM   #3
Pisces107
Member
 
Registered: Dec 2003
Distribution: Slackware Current, Gentoo , Debian SID
Posts: 90

Original Poster
Rep: Reputation: 15
thanks ilkejam, i "succeeded" in booting from new kernel by removing " ro root=LABEL=/' from the kernel arguments in grub.conf but now i get modprobe couldn't find/probe modules for USB OHCI,UHCI etc (whereas i did choose those options during kernel config) and hence my USB optical mouse is not working anymore. the strange thing is, it popped up a configuration change message & asked me if i wan to "keep/remove/do nothing" with the Logitech USB mouse config. when i chose to remove, the mouse still worked but it was like real slow in responding to clicks. but the second time around when i booted again, it altogether disabked the mouse. and also my x server configuration was changed.

other problem: when i logged into my old kernel (2.4.18) , it asked about the USB mouse configuration and also about the X server config. what it looks like is if both kernel versions are using the same modules i don't know) or what?

does anybody have any idea why my USB devices are not working and it is spitting out errors of US OHCI, UHCI modules compalints.....whereas, i have selected those nodules during my kernel config.

how to make these two kernel (2.4.18 (current) and 2.4.20-24 (new) ) versions not to use the same modules(if they are using) and is there a way for me to undo/un-install the upgraded kernel and do the kernel-recompile ?

i'm a newbie and i'm almost there to my first successful kernel compile, if i can got rid of the USB and x server config errors.

thanks in advanc and i hope people here would make my migration from Windows to Linux easy for me.

thanks.
 
Old 12-16-2003, 04:03 PM   #4
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hmmm.

The two different kernels *should* use different folders for their modules.
did your kernel compile go something like:

make mrproper
make xconfig
make modules
make modules_install
make bzImage

If you forgot the 'make modules_install, then the modules wouldn't be put in their folders, so modprobe wouldn't work.

Are you sure you didn't compile uhci etc into the kernel instead of as modules? The startup scripts would complain that modprobe didn't work, but the devices would still work, as their drivers are in the kernel.

On my machine, USB devices don't even recieve power (my mouse doesn't light up) if the uhci module isn't loaded. I don't know if it's the same for all machines, but I doubt that your mouse would work at all if the uhci or ohci modules aren't loaded. Sounds to me like your uhci code has been compiled in instead of as a module, causing the device to work fine, but the modprobe to fail (harmlessly).

I'm away from my Linux box at the moment, but I'll get back to you when I get home and have had a chance to hunt around for some clues.

Dave
 
Old 12-16-2003, 07:45 PM   #5
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
HI again.

Have a look in /lib/modules

There should be a directory for each version of kernel you have (or indeed have had) installed.

Dave
 
Old 12-16-2003, 08:00 PM   #6
Pisces107
Member
 
Registered: Dec 2003
Distribution: Slackware Current, Gentoo , Debian SID
Posts: 90

Original Poster
Rep: Reputation: 15
yes, i remember compilig UHCI/OHCI into kernel, not as modules. does that create any problem? and what should be compiled into kernel and what should go into modules, any general guideline?

i'll check on /lib and see what's happening. and would recompile after changing UHCI/OHCI as modules. actually now, my mouse doesn't even light up in 2.4.23 (new kernel).

anyways, i'll give it a try and post the outcome here.
thanks illikejam.
 
Old 12-16-2003, 08:17 PM   #7
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi again.

There's no hard and fast rules about modules v compiled in, but if you want something to work at its very fastest, then compile it in. If you don't use something very often, then make it as a module.

I use a USB modem, and almost always have my TV card on, so USB is compiled in, as is bttv. The only things I have as modules are Windows filesystems, printers and scanners.

There's a file in /etc/rc.d called rc.sysinit - this is the shell script that's run when you start up (all the stuff where you get a green 'OK' or a red 'FAILED'). If you know what you're doing, then you can remove the parts about uhci or any other stuff that you've compiled into the kernel, so that modprobe doesn't have to look for modules that aren't there.

On the other hand, it doesn't do any harm to have modprobe try to load modules that don't exist, but there may be conditions in the rc.sysinit file where if a modprobe fails, then something else won't even try to load, but I've not had any problems yet. As usual Your Mileage May indeed Vary.

Dave.

P.S. If you do fancy messing with rc.sysinit, then make a backup. You'll be glad you did.
 
Old 12-17-2003, 02:27 PM   #8
Pisces107
Member
 
Registered: Dec 2003
Distribution: Slackware Current, Gentoo , Debian SID
Posts: 90

Original Poster
Rep: Reputation: 15
this thread can be closed.

thanks ilikejam for your help.

i switched to RH 9 for now...nad ..having troubles with X :{

thanks again...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
updated kernel w/up2date ... now dual boot jcarpio Linux - Software 2 04-12-2004 04:25 PM
Updated Kernel - Choosing at boot link1305 Linux - General 5 11-25-2003 07:38 PM
updated kernel from mandrake update? paradoxni Mandriva 1 10-31-2003 02:51 PM
howto boot updated kernel assaflavie Linux - Newbie 1 07-03-2003 09:39 AM
updated kernel now has 3 options to choose on boot centr0 Linux - General 1 02-26-2003 11:39 PM


All times are GMT -5. The time now is 02:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration