LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 11-07-2003, 05:41 PM   #1
rroorroo
LQ Newbie
 
Registered: Nov 2003
Posts: 2

Rep: Reputation: 0
kernel panic: no init found. Try passing init= option to kernel


Hi Linux friends,

Yesterday I installed Kylix3 open source from Borland on my redhat 8 successfully with the option sh ./setup.sh -m as root user at least I could compile and execute hello.pas then I tried to compile hello.pas as normal user and it failed from here the problems have begun.
1) as normal user I could not open an application from the command line.
Always the same error impossible to localize libx11.so this is not the exact error message.
2) when rebooting the computer I had the following error:

pivot root: pivot_root (/sysroot/sysroot/initrd) failed:2
umount /initrd/proc failed:2
freeing unused kernel memory: 172 freed
kernel panic: no init found. Try passing init= option to kernel.

That's it now I'm blocked I can still enter in rescue mode but I have no idea what file I have to modify ?
One thing is sure next time I install Kylix3 as normal user instead of root user.

I found a link that maybe can help me I did not try it yet and I don't understand it 100%
bugzilla.redhat.com/bugzilla/show_bug.cgi?id=65207

Regards,
Rodrigo

Last edited by rroorroo; 11-07-2003 at 05:42 PM.
 
Old 11-07-2003, 08:17 PM   #2
mrhyde
Member
 
Registered: Jul 2003
Location: Europe
Posts: 198

Rep: Reputation: 30
Did you make any changes to the boot loader configuration file? You may still enter rescue mode by booting from the cdrom, try viewing the "grub.conf" file to see if there have been any changes since you installed kylix, eg did the installation program update the kernel?

Last edited by mrhyde; 11-07-2003 at 08:18 PM.
 
Old 11-08-2003, 04:35 AM   #3
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Also make sure you have an empty /initrd directory in your top-level directory of your root partition.
 
Old 11-08-2003, 02:46 PM   #4
rroorroo
LQ Newbie
 
Registered: Nov 2003
Posts: 2

Original Poster
Rep: Reputation: 0
Hi,

Thank you very much for your quicly reply
I created an empty folder initrd in / and now all is fine again :-)
Also changed a little in my grub.conf as there was not the problem left it like it was before.
By the way what is the meaning of these folder initrd ?

Thank you very very very much
Rodrigo
 
Old 03-07-2004, 02:15 PM   #5
jmendez
LQ Newbie
 
Registered: Mar 2004
Posts: 4

Rep: Reputation: 0
Kernel Panic

I have this error message AND SYSTEM HANGS....
KERNEL PANIC: NO INIT FOUND TRY PASSING INIT=OPTION TO KERNEL
MOUNT:ERROR 6 MOUNTING EXT3
PIVOTROOT 'PIVOT ROOT(/SYSROOT,SYSROOT/INITR/FAILED2
UMOUNT/INITRD/PROC FAILED:2

INSTALLED RED HAT LINUX 9.2 ON A SECOND usb DRIVE, (FIRST DRIVE winxp). BOOT RED HAT FROM A FLOPPY.
CAN SOMEONE OUT THERE PLEASE HELP...

THANKS
JAMES
 
Old 03-07-2004, 03:11 PM   #6
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Red Hat Linux 9.2 does not exist.

Boot first CD into "rescue" mode, then create the /initrd directory as mentioned in the older posts.

Otherwise, more details about your installation are needed. Partitioning layout and things like that.

Last edited by misc; 03-07-2004 at 03:13 PM.
 
Old 03-07-2004, 04:07 PM   #7
jmendez
LQ Newbie
 
Registered: Mar 2004
Posts: 4

Rep: Reputation: 0
Thanks...but how and where do I create this new dir
at the prompt ? and what's the syntax

much appreciated...
James
 
Old 03-07-2004, 04:19 PM   #8
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Follow the instructions of "rescue mode" till the end. Read everything carefully. At the shell prompt, first check whether you really don't have the /initrd directory. Run ll /initrd or file /initrd which should print an error. If it does, run mkdir /initrd and exit to try rebooting again. If that's not it, something went wrong during your installation, and it can get complicated to investigate it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic: No init found. Try passing init=option to Kernel ridak Fedora 5 09-08-2004 01:25 AM
Kernal Panic: No init found. Try passing init= option to kernel raees Linux - General 12 03-18-2004 11:10 PM
Kernel Panic: No Init Found Try Passing Init=option To Kernel Bakame Linux - Newbie 4 03-10-2004 06:08 AM
error "Kernel panic: No init found. Try passing init= option Anauj0101 Linux - Newbie 3 05-06-2003 10:18 PM
Compiled own kernel and got: Kernel panic: No init found. Try passing init= option to fbl Linux - General 12 01-14-2003 03:38 AM


All times are GMT -5. The time now is 09:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration